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1 Progetti 

1.1 Creare e salvare progetti 
Si può accedere ai comandi che permettono di creare un nuovo progetto, di aprire o salvare un 

progetto selezionando nel menù File  il comando desiderato o cliccando sulle icone  
sulla barra dei comandi. Un progetto viene salvato con l’estensione *.gvp. 
 

 
 
Il Gestore di progetto  permette di gestire i documenti di un progetto. Ci sono tre tipi di documenti: 
viste, tabelle e mappe.  
 

 
 

Si accede al Gestore di progetto selezionando Mostra -> Gestore di Progetto. 
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1.2 Preferenze 
Le preferenze permettono di definire l’aspetto generale, le impostazioni generali del Editing, della 
mappa e della vista, di impostare il percorso alle cartelle di dati, di gestire l’estensioni e di 
configurare la rete. Le modifiche ai valori delle preferenze generali vengono solo applicate al 
riavvio dell’applicazione. Si accede alla finestra delle preferenze selezionando Finestra -> 

Preferenze  o cliccando sull’icona  sulla barra dei comandi. 
 

 
 
 

1.3 Copiare e incollare documenti 
Nel gestore di progetto  si possono copiare e incollare le viste, le tabelle e le mappe in un altro 
progetto cliccando con il tasto destro del mouse sul documento desiderato.  
 

 



  
 
 

 
5 

2 Viste 

2.1 Creare una vista 

Nel gestore di progetto  si crea una vista nuova selezionando Vista  e poi cliccando Nuovo . Il 
documento vuoto che viene creato si chiama ‘Senza titolo – 0’ per default e può essere rinominato. 
La vista si apre cliccando su Apri  o con un doppio click sul nome. 
 

 
 
 

2.1.1 Proprietà vista 
Selezionando la nuova vista e cliccando Proprietà  si possono impostare le proprietà della vista 
come il nome, il proprietario, l’unità della mappa, l’unità di misura, la proiezione, il colore di sfondo 
e i commenti. 
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Cliccando sul bottone della proiezione (Current projection) si apre una nuova finestra che permette 
di cambiare il sistema di riferimento: 
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2.2 Aggiungere un layer 

Per aggiungere un layer a una vista si può selezionare Vista -> Aggiungi layer  o cliccare 
sull’icona  sulla barra dei comandi. 
 

 
 
Si apre una finestra nuova che permette di scegliere i dati di diverse tipologie: 
 

 
 

2.2.1 File 
Il sottomenu File  permette di aggiungere dei layer di diversi formati. Cliccando sul pulsante 
Aggiungi  nella finestra Aggiungi Layer  si apre la finestra per localizzare il file desiderato. Per 
aprire un file per esempio in formato ‘shape’ bisogna selezionare il gvSIG shp driver  sotto Tipo 
file . Cliccando su Apri  e confermando con Accetta  si aggiungono i file alla vista. 
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2.2.2 Banca dati 
Il sottomenu GeoBD  permette di aggiungere dati salvati in una banca dati. Per aggiungere una 
connessione bisogna cliccare sull’icona Aggiungi connessione  a destra del menù a tendina sotto 
Seleziona connessione .  
 
 

 
 
 
 
Si apre una nuova finestra che permette di impostare i parametri della connessione. Bisogna 
inserire un nome arbitrario della connessione, scegliere il driver (PostGIS, HSQLDB, MySQL), 
inserire l’URL, la porta, il nome del DataBase, l’utente e la password.  
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Con Accetta  si torna al menù che permette di selezionare le tabelle e i campi degli attributi che si 
vuole aggiungere alla vista. Si possono impostare le specifiche del layer come il nome, la 
proiezione, i campi con ID e Geometria. Inoltre si possono applicare dei filtri usando SQL e 
impostare l’area di lavoro. 
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2.2.3 WMS 
 
Per inserire un WMS bisogna inserire l’URL del WMS e confermare con Connetti . 
 
 

 
 
 
 
Premendo il pulsante Successivo si arriva al menù Informazione  che informa su diversi aspetti 
del servizio e sulle proprietà.  
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Il menù Layers  permette di selezionare i layer desiderati. Si può mantenere la struttura dei layer o 
personalizzarne l’ordine.  
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Il menù Formati  permette di selezionare i formati, la trasparenza e il sistema di riferimento. Si 
confermano le impostazioni con Accetta  e i layer WMS vengono aggiunti alla vista. 
 
 

 
 

 
Per cambiare le impostazioni o selezionare altri layer si può accedere al menù descritto cliccando 
con il tasto destro del mouse sul layer WMS nell’elenco dei layer (ToC). 
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2.3 ToC – elenco dei layer 

Il ‘Table of Contents’ si trova sulla sinistra della finestra che visualizza i dati e mostra l’elenco dei 
layer della vista. Si possono accendere, spegnere, raggruppare o attivare i layer.  
 
Layer attivo: 

 
  

Raggruppamento dei layer: 
 

 
 

 
Cliccando con il tasto destro del mouse si apre un menù con i comandi per cambiare il nome, il 
colore, accedere alle proprietà, zoomare al layer, eliminare e copiare il layer o iniziare l’editing. 
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2.4 Proprietà del layer 

2.4.1 Proprietà generali 
Cliccando con il tasto destro del mouse su Proprietà  si apre la finestra per gestire le proprietà del 
layer: 
 
 

 
 
 
Il menù generale mostra le informazioni principali del layer. Inoltre permette di usare un indice 
spaziale, di impostare una scala minima e massima e di inserire un collegamento a un immagine o 
a un documento di testo. 
 

2.4.2 Salvare legenda 
La legenda può essere salvata o recuperata a ogni momento. 
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2.4.3 Simbologia 
Nel sottomenu Simbologia  delle Proprietà del layer  si può definire la tipologia di legenda che si 
applica al tema in base a un campo della tabella degli attributi. Il menù offre diverse possibilità per 
assegnare una simbologia: simbolo unico, valori unici e intervalli. 
 

2.4.4 Simbolo unico 
Il simbolo unico mostra tutti gli elementi di un layer usando lo stesso simbolo. 
 
 

 
 
 

Per modificare il colore assegnato di default al valore, si ricorre a una finestra cliccando sul bottone 
a destra del colore di riempimento (…). Si apre una nuova finestra che permette di scegliere il 
colore secondo campione, valori HSV o RGB. 
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2.4.5 Valori unici 
La simbologia con i valori unici mostra gli elementi di un layer usando un simbolo per ogni valore 
unico presente nel campo degli attributi, utilizzato per realizzare la legenda. Si possono 
aggiungere tutti i valori o solo alcuni attributi dalla lista completa. Per modificare il colore 
assegnato di default ai singoli valori si ricorre a una finestra cliccando sopra il simbolo da 
modificare. Si apre una nuova finestra che permette di scegliere il colore secondo campione, valori 
HSV o RGB. 
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2.4.6 Intervalli 
La simbologia con i mostra gli elementi del layer usando una gamma di colori in funzione del 
valore di un determinato campo di attributi.  
 
I tipi di classificazione sono i seguenti: 
 
- Intervalli uguali : Il numero di intervalli viene specificato in modo tale che sia il più possibile 

simile l’ampiezza delle classi. L’ampiezza delle classi sarà uguale al range dei dati diviso il 
numero delle classi. 
 

- Intervalli naturali : Il numero di intervalli viene specificato secondo l’algoritmo Jenk per 
minimizzare la somma della variazione interna a ciascuna classe. 
 

- Intervalli quantili : Il numero di intervalli viene specificato in modo da attribuire a ciascuna classe 
lo stesso numero di poligoni, cioè in modo da suddividere l’universo dei dati grafici in classi di 
pari dimensione di individui. 

 
 
Si possono scegliere il campo di classificazione, il tipo di classificazione, il numero di intervalli e il 
colore iniziale e finale in base a cui viene calcolato la colorazione continua. Per cambiare i colori 
bisogna cliccare sul bottone a destra del colore. Si apre una nuova finestra che permette di 
scegliere il colore secondo campione, valori HSV o RGB. 
Le classi vengono mostrate accettando con Calcola intervalli . Si possono anche aggiungere o 
rimuovere manualmente delle classi. 
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2.4.7 Etichette 
Il menù Etichettati  permette di etichettare gli elementi della mappa con il valore di un determinato 
campo. Si possono scegliere il campo di etichetta, un campo di rotazione, il carattere e il colore. 
Inoltre è possibile specificare un campo di altezza del testo o assegnare un’altezza fissa del testo 
in pixel o metri. 
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2.5 Navigare 

2.5.1 Zoom 
Ci sono diversi strumenti di navigazione che permettono di aumentare o diminuire lo zoom 
manualmente o secondo degli scaglioni fissi, di zoomare all’estensione massima o spostare la 
mappa. Nel menù Vista -> Navigazione  si trovano i seguenti comandi che sono anche accessibili 
sulla barra dei comandi: 
 

 
 
 

 

2.5.2 Zoom al layer 
Cliccando con il tasto destro del mouse sul layer attivo nel ToC si accede al comando Zoom al 
layer che mostra l’estensione del layer selezionato. 
 
 

2.5.3 Localizza per attributo 
Per zoomare su un elemento specificato nella tabella degli attributi si può selezionare Vista -> 

Localizza per attributo  o cliccare sull’icona  sulla barra dei comandi.  
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2.5.4 Bookmarks 
Il tool zoom permette di salvare uno zoom attuale o recuperare uno zoom già salvato. Si può 
accedere alla finestra che gestisce lo zoom selezionando Vista -> Navigazione -> Zoom  o 

cliccando sull’icona  sulla barra dei comandi. 
 
 

 
 
 

2.5.5 Zoom su elementi selezionati 
Si può zoomare su elementi selezionati selezionando Vista -> Navigazione -> Zoom selezionato , 
disponibile solo se ci sono elementi selezionati o cliccando sull’icona  sulla barra dei comandi. 
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2.6 Localizzatore 

Il localizzatore è una finestra che mostra l’estensione dello zoom attuale su uno o più layer definiti.  
 

 
 

Si accede cliccando sul menù Vista -> Configura localizzatore . Si apre una finestra per 
aggiungere o eliminare dei layer. Cliccando su Modifica legenda  si può impostare l’aspetto del 
layer selezionato. 
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2.7 Strumenti per consultare i layer 
Ci sono diversi strumenti per consultare i layer che si trovano nel menù Vista -> Consulta o sulla 
barra dei comandi: 
 
 

 
 

 

2.7.1 Informazione 

Selezionando Vista -> Consulta  -> Informazione  o cliccando sull’icone  si attiva lo strumento 
per ottenere l’informazione sugli elementi della vista. Nella finestra Identifica risultati  vengono 
mostrate le informazioni del layer attivo. 
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2.7.2 Misurare la distanza 
Lo strumento permette di misurare la distanza fra due punti. Si accede selezionando Vista -> 
Consulta -> Misura distanze  o cliccando sull’icona  sulla barra dei comani. 
 
 

 
 
 
La distanza misurata si vede sulla barra in fondo alla pagina. 

 
 

 
 
 
 

2.7.3 Misurare l’area 
Lo strumento permette di misurare l’area che si seleziona con il mouse. Si accede selezionando 
Vista -> Consulta -> Misura area  o cliccando sull’icona  sulla barra dei comandi. 
 
 

 
 
 
L’area misurata si vede sulla barra in fondo alla pagina. 
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2.8 Selezionare elementi 
Ci sono diverse possibilità per selezionare elementi nella vista che si trovano nel menù Vista -> 
Selezione  o sulla barra dei comandi. 
 
 

 
 
 

2.8.1 Selezionare con punto 
Si può selezionare un elemento cliccando con il mouse sull’elemento desiderato. 
 
 

 
 
 

2.8.2 Selezionare con rettangolo 
Si possono selezionare uno o più elementi che si trovano completamente o solo parzialmente 
dentro un rettangolo definendo con il cursore il rettangolo. 
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2.8.3 Selezionare con poligono 
Si possono selezionare uno o più elementi che si trovano completamente o solo parzialmente 
dentro un poligono definendo con il cursore il poligono. 
 
 

 
 
 
 

2.8.4 Selezionare per layer 
Lo strumento Selezionare per layer  permette di selezionare degli elementi del layer attivo basato 
su un altro layer della vista. 
 
 

 
 
 
 

Lo strumento offre diverse opzioni: 
 
 
- Nuovo insieme : Crea una selezione nuova. 

 
- Aggiungi all’insieme : Crea una selezione basata alla selezione precedente e attuale. 
 
- Seleziona dall’insieme : Crea una selezione estraendo la richiesta attuale dalla selezione 

precedente. 
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2.8.5 Selezionare per attributi 
Lo strumento Selezionare per attributi  permette di fare richieste complesse basate sugli attributi 
del layer. Si possono usare diversi attributi, operatori e funzioni. 
 
 

 
 
 

2.8.6 Invertire la selezione 

Si può invertire la selezione cliccando su Vista -> Selezione -> Inverti selezione  o sull’icona  
sulla barra dei comandi. 
 

   
 

 

2.8.7 Annullare la selezione 

Si può annullare la selezione cliccando su Layer -> Annulla/Elimina selezione  o sull’icona  
sulla barra dei comandi. 
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2.9 Esportare layer 

Lo strumento nel menù Layer -> Esporta … permette di salvare degli elementi di un layer in un 
altro formato. Si possono scegliere diversi formati: 
 
 

 
 

 
È possibile esportare solo gli elementi selezionati o tutti gli elementi del layer.  
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3 Tabelle 

Le tabelle sono documenti che permettono di salvare e gestire l’informazione alfanumerica 
associata agli elementi di un layer vettoriale.  
 
 

 
 
 

3.1 Aggiungere una tabella 

3.1.1 Aprire una tabella nel gestore di progetto 
Nel Gestore di progetto  si aggiunge una nuova tabella selezionando Tabelle  e poi cliccando su 
Nuovo . Si apre una nuova finestra che permette di selezionare la tabella desiderata.  
La tabella si apre cliccando su Apri  o con un doppio click sul nome. 
 
 

3.1.2 Aprire una tabella di un layer nella vista 
Per aprire una tabella di attributi di un layer nella vista si può selezionare Layer -> Mostra tabella 
degli attributi  o cliccare sull’icona  sulla barra dei comandi. 
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4 Editing  

Ci sono due tipi di editing: l’editing degli elementi grafici e l’editing dell’informazione alfanumerica. 

4.1 Editing grafico 

4.1.1 Iniziare e finire l’editing 
Per iniziare l’editing bisogna attivare il layer nel ToC e cliccare con il tasto destro del mouse sul 
layer, oppure selezionare Layer -> Inizia Editing . 
 
 

 
 
 
Per terminare l’editing si può cliccare con il tasto destro del mouse sul layer o selezionare Layer -> 
Termina Editing . Si apre un menù che permette di salvare o di non salvare le modifiche 
confermando con Si o annullando con No. 
 
 

 
 

4.1.2 Comandi 
Ci sono diverse possibilità per effettuare delle modifiche. Si possono 
 

• selezionare i comandi direttamente nella tool bar:  
 

 
 

• attivare il comando selezionando del menù Geometria -> Modifica / Inserisci : 
 

 
 

• inserire dei comandi nella console dei comandi usando la tastiera: 
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4.1.3 Selezionare elementi 
Ci sono due tipi di selezione: selezione semplice e selezione complessa. 
 
 
Selezione semplice: 

Per selezionare un elemento si può cliccare sull’icona  sulla barra dei comandi o selezionare 
Geometria -> Seleziona . 
 

 
 
 
 
Selezione complessa: 
Scegliendo la selezione complessa e cliccando col tasto destro del mouse nella mappa si apre un 
menù che offre le seguenti possibilità di selezione: 
 
 

 
 
 

Scegliendo per esempio All’interno della circonferenza  bisogna cliccare col cursore sul centro 
della circonferenza che si vuole aprire e definire con un secondo click la grandezza. Verranno 
selezionati tutti gli elementi che si trovano completamente nella circonferenza. 
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4.1.4 Modificare geometrie 
Per modificare degli elementi si può cliccare sulle icone sulla barra dei comandi o scegliere del 
menù Geometrie -> Modificare  il tipo d’azione: 
 

 
 
 

4.1.5 Inserire geometrie 
Per creare geometrie nuove si può cliccare sull’icona sulla barra dei comandi o scegliere del menù 
Geometrie -> Inserisci  il tipo di geometria. Secondo il tipo di layer (punto, linea, poligono) si 
possono scegliere le forme corrispondenti. 
 

 
 

4.1.6 Lista dei comandi 
Ogni azione durante la sessione d’editing viene salvata in una lista dei comandi  (storico) che si 

apre cliccando sull’icona  sulla barra dei comandi. Cliccando su un’azione si può tornare a 
quello stato. 
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4.2 Editing tabelle 

4.2.1 Modificare valori 
Per editare la tabella di attributi di un layer bisogna attivare il layer nel Toc e iniziare l’editing. Si 
apre la tabella selezionando Layer -> Mostra tabella degli attributi  o cliccando sull’icona  sulla 
barra dei comandi. 
 
Si possono modificare i valori cliccando direttamente nel campo. Il menù permette anche di 
inserire o di eliminare delle righe. 
 
 

 
 
 

4.2.2 Modificare campi 
Lo strumento Tabella -> Modifica struttura  permette di modificare i campi della tabella. Si apre 
l’Editor dei Campi  che permette di aggiungere, cancellare o rinominare i campi.  
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Cliccando su Nuovo campo  si possono definire le proprietà del nuovo campo come il nome, il tipo, 
la lunghezza, la precisione e assegnare un valore predefinito. Con Accetta  si torna al Editor dei 
Campi . 

 
 

 



  
 

 

 
34 

5 Mappe 

5.1 Creare una mappa nuova 

Nel Gestore di progetto  si crea una mappa nuova selezionando Mappa  e poi cliccando su 
Nuovo . Il documento vuoto che viene creato si chiama ‘Senza titolo – 0’ per default e può essere 
rinominato. La mappa si apre cliccando Apri  o con un doppio click sul nome. 
 

 

5.2 Impostare la mappa 

Per accedere al menù che permette di impostare la pagina della mappa si può selezionare Mappa 
-> Imposta pagina  o cliccare sull’icona  sulla barra dei comandi. 
 
Si apre la finestra seguente per impostare la pagina: 

 
 

 
 
 
 
- Dimensione della pagina : Si può scegliere una grandezza predefinita o impostare una 

grandezza personalizzata della pagina.  
- Unità di misura : Si possono selezionare le unità di misura per l’altezza e la larghezza della 

pagina. 
- Orientamento : Definisce se la pagina sarà stampato in formato orizzontale o verticale.  
- Margini : Si possono personalizzare i margini della pagina. 
- Qualità di stampa : Si può scegliere fra alta, normale e bassa qualità.  
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5.3 Inserire elementi 

Per inserire degli elementi nella mappa, si può selezionare il menù Mappa -> Inserisci  o cliccare 
sulla barra dei comandi. Si possono inserire i seguenti elementi nella mappa: 
 

 
 

 
 

5.3.1 Vista 
Per inserire una vista nella mappa si può selezionare Mappa -> Inserisci -> Vista  o cliccare 
sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo nell’area 
della mappa. Si apre una finestra che permette di selezionare la vista e di impostare la scala e la 
qualità della mappa. 
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5.3.2 Legenda 
Per inserire una legenda nella mappa si può selezionare Mappa -> Inserisci -> Legenda  o 
cliccare sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo 
nell’area della mappa. Si apre una finestra che permette di selezionare la legenda e di impostare il 
carattere e la qualità della mappa. 
 

 
 

 

5.3.3 Scala 
Per inserire una barra di scala nella mappa si può selezionare Mappa -> Inserisci -> Scala  o 
cliccare sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo 
nell’area della mappa. Si apre una finestra che permette di impostare le proprietà della scala. 
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5.3.4 Nord 
Per inserire il nord nella mappa si può selezionare Mappa -> Inserisci -> Nord  o cliccare 
sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo nell’area 
della mappa. Si apre una finestra che permette di scegliere fra vari immagini. 
 
 

 
 
 
 

5.3.5 Testo 
Per inserire un testo nella mappa si può selezionare Mappa -> Inserisci -> Testo  o cliccare 
sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo nell’area 
della mappa. Si apre una finestra che permette di inserire il testo, impostare l’allineamento, la 
grandezza, il colore, e il tipo delle carattere. Inoltre si possono definire un bordo o un titolo. 
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5.3.6 Immagini 
Per inserire un’immagine nella mappa si può selezionare Mappa -> Inserisci -> Immagine  o 
cliccare sull’icona  sulla barra dei comandi. In seguito bisogna definire col cursore un rettangolo 
nell’area della mappa. Si apre una finestra che permette di cercare il file e di impostare la qualità. 
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5.4 Tavole 
Si può salvare una mappa come tavola per creare delle mappe nuove usando un layout 
predefinito. Si accede al menu sotto File -> Salva come tavola  e si crea un file con l’estensione 
*.gvt. Per aprire o salvare una tavola si può selezionare File -> Apri Tavola / Salva come tavola  o 
cliccando sull’icona sulla barra dei comandi.  
 

 
 
 

5.5 Esportare la mappa 

Si può esportare una mappa come formato postscript (estensione *.ps) o come formato pdf ( 
estensione *.pdf) selezionando File -> Esporta come pdf / Esporta come ps  o cliccando 
sull’icona sulla barra dei comandi.  
 

 
 
 

5.6 Stampare la mappa 

Per stampare la mappa si seleziona Mappa -> Stampa  o si clicca sull’icona  sulla barra dei 
comandi. Si apre una finestra per impostare le opzioni di stampa che dipendono dal tipo di 
stampante installata. 
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6 Geoprocessing 

Gli strumenti d’analisi si accedono selezionando Vista -> Gestore di processi  o cliccando 
sull’icona  sulla barra dei comandi. Nel Gestore dei processi  sono elencati i diversi tipi di 
processi che vengono spiegati sul lato destro della finestra. Con Apri Geoprocesso  si apre il 
menù del processo selezionato. 
 
 

 
 

 


