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Part 1: GIS Project

The objective of this project is to show the main functionalities of a GIS open source
software. These ones are some of the objectives: 

- Create new views and work in different reference systems.
- Reproject vector layers to work in a same reference system.
- Create event layers from an attribute table where there are two fields with point

coordinates.
- Label layers and change symbology.
- Create a layout with scale, north, legend... 
- Add hyperlinks to image files.
- Load remote layer from external services.
- Use field calculator for operation.
- Create files to be loaded in Google Earth. 
- Edit a shapefile graphically and the attribute table associated to a shapefile. 
- Analyze different situations using geoprocessing tools.
- Apply color tables in order to see the results of an analysis easily.

Data of the project 

At this project we are going to use several layers: 

- Skateparks of New York.
This layer contains the skateparks of New York city. It is a SHP file available in EPSG
4326 reference system (geodetic coordinates, WGS84).  

- Graffiti complaints.
This is a CSV file that contains the graffiti complaints in New York city. It has two fields
with Latitude and Longitude values, that will be used to get a point layer. Its reference
system will be EPSG 4326. 

- Streets of New York.
This layer is in SHP format, and contains the streets of New York city, that we will have as
reference in the View. The reference system of this layer is EPSG 26918 (NAD 1983
UTM Zone 18N). 

- Neighborhood Tabulation Areas of New York.
This is a polygon layer that contains the different neighborhood areas of New York city. It
is available in EPSG 4326 reference system. 

- Population of the Neighborhood Tabulation Areas of New York.
This is a table that contains the population of the neighborhood areas in New York. It is
available in XLS format. 

- Orthophoto of New York city.
This is an ortho imagery of a small area of New York city. It is available in SID format.



Introduction  

Geographic information is information that can be associated with a place name, a street
address, a zip code, or coordinates. 

A  great  number  of  government  functions  require  geographic  information.  A  high
percentage of the information used by governments is geographically referenced. For
example,  infrastructure  and  transportation  management,  agriculture,  safety  and
emergencies, property records and assessment, planning, natural resource management,
economic development planning, health...

All  of  these applications consider the location of certain features on the landscape in
relation  to  other  features.  A geographic  information  system (GIS)  allows  the  user  to
examine and visualize these relationships. 

At this mini-project we want to analyze the skateparks location in New York city in relation
with the complaints about requests on graffiti cleaning. 

Picture 1. Graffiti in New York city

We will load the different layers in a View, reprojecting some of them in order to work in a
same reference system. If they are not reprojected, they won't be able to be visualized
correctly, over the other ones. 

We will apply a first symbology by district to the neighborhood layer. It will allow us to see
the different districts easily by different colors, and we will label the neighborhood areas
too by their name. 

We also will link some image to a neighborhood. It will be a photography characteristic of
that area. When we click on the polygon we get that image. At this point we will edit a
layer alphanumerically, adding a new field to the attribute table and filling it in. 



Picture 2. New York neighborhood

An Excel file will be imported too with the population of every neighborhood area. At that
table there's a field with neighborhood codes, and other one with the names. Both ones
are included at the neighborhood layer too, and we will join both tables in order to add the
population value to the neighborhood layer. Every polygon will have the population after
that. To join the tables we will do it through a common field. We will have to take into
account that the neighborhood name can be different in both tables (one of them can
have the article “the” for example, so it wouldn't be joined). To avoid that problem we will
use the neighborhood codes because they are the same in both tables. 

At that point we will have population and area for every polygon, so we will calculate the
density for every neighborhood. Area is available in squared meters, but we will calculate
inhabitants per squared kilometer. With the field calculator it can be calculated with a
simple operation. That tool allows the user to calculate areas of polygons, length of lines,
coordinates of points, to split strings or concatenate them, fill in the registers of a field
with a value easily... 

After having a new field with the densities, we also will obtain the media of all of them.
There's an option to get the maximum and minimum values, media... 

We will  apply  a new type of  symbology in  order  to  visualize the neighborhoods with
higher density in an easy way. Using a legend by intervals, with a graduation from a light
color to a dark one, we will show it. 

Having the neighborhoods by density we will create a layout. The layout is the graphical
representation of  a  view, the “paper” space,  where we can add scale, north,  legend,
images, titles... It would be able to be printed directly, or exported to a PDF file. 

We also will load a raster file over the neighborhood layer. As the raster file will cover the
vector layer we will apply transparency to the image in order to see the symbology of the
neighborhoods applied previously. Other tools for raster files are: Brightness, contrast,
filters... that allow users to do analysis, for example to find the areas with high humidity,
coastal boundaries... 



We have skateparks and neighborhoods layers in a view at this moment, and we will
want to get the neighborhoods that have the biggest skateparks of the city. For that we
will select the skateparks, the area of which are more than 15000 squared meters firstly,
and then we will intersect the results with the neighborhood layer. 

Besides  loading  local  files,  we  also  have  the  possibility  to  load  remote  layers,  from
external services. There are a lot of public servers available that we can connect to, and
at this project we are going to connect to a national server in USA, to load an orthophoto,
and to a worldwide service, where we will load a layer with country boundaries. We could
work with this last layer like a local vector file. We could select elements, export to a
shapefile, do geoprocessing, apply symbology and labeling...  

Apart from editing alphanumerical information of a layer, like we have done in a previous
step, we also can edit a layer graphically, creating new elements, moving them, scaling
them, applying rotation, autocompleting a polygon... We will create a new layer, and we
will edit it then. 

If we have a vector layer, it can be exported to a format supported by Google Earth. We
will  do  it.  Then,  that  layer  can  be  loaded  in  Google  Earth,  where  we  can  get  the
information of the attributes, change its symbology, create animations following a line...

After loading the previous layers, a point layer will be created from the attribute table got
with the graffiti complaints. The table has two fields with Latitude and Longitude values,
and a point  layer will  be created from it,  in Geodetic coordinates, and then it  will  be
reprojected to work in the same reference system than the other layers. 

At  that  point,  the  final  analysis  will  start.  For  that,  the  first  step  would  be to  get  an
estimated area of influence from the skateparks. It will be the estimated area around the
skateparks where the skaters would be able to work, going by walk or skating. 

Picture 3. Graffiti in a Skatepark

Then, for the point layer with the complaints, a density map will be got, where the values
will be different where there's a higher density of points (complaints). 

The results will be a raster layer, and a color table will be applied on that layer in order to



see the areas with more graffiti complaints in an easier way for a better analysis. 

Finally, visualizing the information that have been got at this point, we will  be able to
analyze  if  the  skateparks  location  in  New  York  city  has  any  relationship  with  the
complaints about requests on graffiti cleaning. We will see if the area of influence of each
skatepark contains the areas with highest density of complaints. 



Part 2: Using gvSIG for analysis 

Exercise 1: Installing gvSIG 

To download the application we will access to the gvSIG website (http://www.gvsig.com),
and then to the Products->gvSIG Desktop section. 

Figure 1. gvSIG website homepage 

At the gvSIG Desktop we will access to the “Downloads” section, from the menu at the
right side. At this section the latest final gvSIG version is available to download (in this
case it is gvSIG 2.2). 

http://www.gvsig.com/


Figure 2. gvSIG downloads web page

There are two different distributions: 

- All-included version: It is a version to be installed on the computer. 
-  Portable version: It  is a ZIP file to be unzipped, and the file to run gvSIG is

available in the unzipped folder. It's very useful to install in a pen-drive to run it in different
computers. 

If  you  download  the  “All-included  version”  you  will  have  to  install  it,  following  the
instructions. 

Exercise 2: Download the layers to be used at the project 

We will download the cartography from public servers, and we will use the open source
GIS software called gvSIG.

The data for the project can be download from https://nycopendata.socrata.com/. 

- Skateparks: 

At the previous web page we can look for “Skateparks” at the “Searching” text box. The
first result will be: Skateparks, (Directory of Skateparks) 

https://nycopendata.socrata.com/


Figure 3. Search results for “Skateparks” expression 

We will click on the “Skateparks” link, and a new web page will be opened with a viewer. 

At the right side, there's a button to export the layer (the blue one). 

Figure 4. Main menu at the Viewer 

When we click on it we get the export options for the current layer. At the “Download
Geospatial Data” section we can select the file format to be exported. We will select the
shapefile format, that can be loaded in gvSIG. When we download it we will get a .ZIP
file, that we can save in our hard disk. 

Then we will access to the folder where we've saved it ans we unzip the ZIP file. We'll
see the shapefile, that is composed by 4 files (.shp, .shx, .dbf and .prj files). 

We have to take into account the Reference System of the layers in order to load them
correctly in gvSIG (from gvSIG 2.3, if the layer has the prj file attached, it will be loaded
correctly). 

If  we open the  prj  file,  we can see the  reference system of  this  layer. We can see
“GEOGCS["WGS84(DD)",  DATUM["WGS84",  SPHEROID["WGS84",  6378137.0,
298.257223563]], PRIMEM["Greenwich", 0.0], UNIT["degree", 0.017453292519943295],
AXIS["Geodetic longitude",  EAST],  AXIS["Geodetic latitude", NORTH]]”, so that means
that its reference system is EPSG 4326 (Geodetic coordinates, WGS84). 

- Graffiti complaints: 

At the same webpage, https://nycopendata.socrata.com/, we can look for “graffiti” at the
“Searching” text box. At the “Search Results” section we will see: “311 Service Requests
from 2010 to Present”, where the 311 Service Requests are compiled in a database. 

We can filter by type of complaint in order to get the graffiti complaints. For that we will
click on the “filter” option at the right side, and we will  display the pull-down menu to
select: 

https://nycopendata.socrata.com/


“Complaint Type” is, 

and we will write 

“graffiti”

and then we mark that option. 

At  the  attribute  table  we  can  see  that  there  are  registers  where  the  Latitude  and
Longitude fields are empty. So they can't be georeferenced. We will apply another filter
then to remove these registers. Firstly we have to press “Add a New Filter Condition”, and
we will display the pull-down menu to select:

“Latitude” is greater than 

and we will write “0”. 

Here we can see the filter applied: 

Figure 5. Filter options to be applied

The filter  is applied automatically. We will  see only the complaints related to “graffiti”
issues (we can check it  at the “Complaint type” column”),  and all  the Latitude values
completed. 

In addition, as there are a lot of columns without information, and other ones with less
important information, we can reduce the number of fields, keeping only the important
ones. We will access to the “Manage” option (the brown menu), where we can select the
fields to show or hide. 



Figure 6. Selection of fields to be exported

We will hide all of them, excepting “Complaint type”, “Incident address”, “City”, “Latitude”
and “Longitude”, and then we will press “Apply”. We will see only five columns. 

Figure 7. Visualization of the table to be exported

And finally we will click on the “Export” button at the top part (the blue one): 

Figure 8. Export menu

and then on the “CSV” format to download the results. We will save the file in the folder
where we are saving the cartography. We can name it “graffiti_complaints.csv”. 

About the reference system, in this case, the Latitude and Longitude fields indicate that



the data are in EPSG 4326 (Geodetic coordinates, WGS84). 

- Streets of New York:

We are going to use a layer with the streets of New York. To download it we will access to
http://gis.ny.gov/gisdata/inventories/details.cfm?DSID=932, and we have the option “ NYS
Streets  –  Public  ”,  inside  the  “Files  available  to  the  Public”  section,  where  we  can
download a SHP file. 

Figure 9. NY Streets layer to be exported

Firstly we have to accept the conditions, and then clicking on “Download the NYS Streets
– Public File“ we will save it in our computer. We will unzip the ZIP file finally. 

About  the  reference  system  of  the  layer,  if  we  open  the  PRJ  file  we  can  read
"NAD_1983_UTM_Zone_18N". If we search in Google that string, and “EPSG” word, we
can  find  that  the  EPSG  code  for  that  layer  is  26918
(http://spatialreference.org/ref/epsg/nad83-utm-zone-18n/)

- Neighborhood Tabulation Areas of New York: 

We also will use the Neighborhood Tabulation Areas layer of the city. We can download it
from: 
https://data.cityofnewyork.us/City-Government/Neighborhood-Tabulation-Areas/cpf4-rkhq.

We press “Export” like we did with the Skatepark layer, and then we select the Shapefile
format. Se save the layer in our disk, and we will unzip the ZIP file. 

About the reference system of the layer, if we open the PRJ file we can see that it is in
EPSG 4326. 

- Population of the Neighborhood Tabulation Areas of New York:

We will use a table with the population of every Neighborhood Tabulation Area in New
York, that we will join to the graphical part. It can be downloaded from: 
https://data.cityofnewyork.us/City-Government/New-York-City-Population-By-
Neighborhood-Tabulatio/swpk-hqdp 

We will press “Export” at the right side, like in the previous layers, and we will export it as
a XLS file. We will call it: New_York_City_Population.xls 

https://data.cityofnewyork.us/City-Government/New-York-City-Population-By-Neighborhood-Tabulatio/swpk-hqdp
https://data.cityofnewyork.us/City-Government/New-York-City-Population-By-Neighborhood-Tabulatio/swpk-hqdp
https://data.cityofnewyork.us/City-Government/Neighborhood-Tabulation-Areas/cpf4-rkhq
http://spatialreference.org/ref/epsg/nad83-utm-zone-18n/
http://gis.ny.gov/gisdata/inventories/details.cfm?DSID=932


- Ortophotography of an area in New York city:

We will use an ortho imagery of New York city, in SID format. It can be downloaded from
ftp://ftporthos.dhses.ny.gov/napp%5CI9/Jersey_CityNE_tile2.zip 

After unzip the file we will have a file called Jersey_CityNE_tile2.sid. 

It is available in EPSG 26918 (NAD_1983_UTM_Zone_18N) reference system. 
 

Exercise 3: Starting with gvSIG

  
Now we run gvSIG, and when it opens we will see a window called “Project Manager”,
where we can manage our project. 

gvSIG allows to work with different types of documents. These documents allow to work
with  data  from different  points  of  view:  data  as a  map,  as  a  alphanumeric  table,  as
graphics... Each document has a series of menus and buttons. 

When we save a session or project in gvSIG, this is saved in a file with a “.gvsproj”
extension. 

In gvSIG there are the following documents: 

- Views: It allows to work with geographical data. The geographical information is
represented as a set of layers. 

- Tables: It allows to work with alphanumeric data. 
- Maps: It allows to design maps with the different cartographic elements which

make a map (View, legend, scale...) to print it or export it as a PDF.  

First step would be to create a new View in our gvSIG project. For that we would select
the View icon at the Project Manager, and then we would choose the “New” button. The
View will be created and opened automatically, with the name “Untitled”. 

We can change the name by clicking the button “Rename” from the project manager (The
View that we want to rename should be selected). Then a dialog box appears where we
can type the new name. 

We also can rename the View from the View Properties window (at the View, accessing
to the View->Properties menu). 
 
From the View Properties window we also can change the Reference System of the View.

In our project we had some layers in EPSG 4326 (Geodetic coords.-WGS84) and other
ones in  EPSG 26918  (NAD_1983_UTM_Zone_18N,  in  Meters).  As  they are  different
reference systems, we have to decide the CRS to use. In our case we will work in EPSG
26918 (coordinates are in Meters and some geoprocesses work better). 

So we will  change the  reference system in  our  first  View. From the View Properties
window we will access to the “Current projection” section. 

ftp://ftporthos.dhses.ny.gov/napp%5CI9/Jersey_CityNE_tile2.zip


Figure 10. Window where reference system of a View can be changed in gvSIG

At the new window we will select Type EPSG, and we will search “26918”, at the “By
code” option. We get only one reference system. 

Figure 11. Selecting the reference system of the current View in gvSIG 

Then we accept it, and we also accept the View properties window. 

If we open the View we can see its reference system at the bottom line. 
 



Figure 12. Parts of the “View” document in gvSIG

The parts of the View are: 

1. Menu toolbar.
2. Buttons bar.
3. Table  of  contents  (ToC):  All  the layers  containing in  the View and the Legend

representing the symbology of each layer are listed. 
4. Locator. Displays the current frame in the total work area.
5. Visualization area.  Workspace where the geographical  information  is  displayed

and the main work is taken place (navigation, selection, edition, etc.).
6. Status Bar. Displays information of the View coordinate system, scale, coordinates

and units. The information resulting from the use of certain tools is shown in the
status bar. 

The 3, 4 and 5 components are resizables, dragging its edge to the right/left and for the
Locator and the TOC from up/down.

Once the View is  open we are going to add our  first  layer. It  will  be the NY streets
shapefile. We will access to the “View->Add layer” menu, or through the button at the

Toolbar 

A new window will be open where we can select the type of layer that we want to add. We
can add vector and raster local files (File tab), or remote services (WMS, WFS, WCS,
OSM... tabs). At the File tab we will press on the “Add” button at the right side. 

We will look for the file “StreetSegmentPublic.shp”, that will be at the folder where we
downloaded the cartography, and we will load it. We can see that the assumed reference
system is the same than the View, and it's correct because the layer is at that CRS. 



Figure 13. Reference system of the layer when it's not indicated

NOTE: From gvSIG 2.3, if the SHP file includes a PRJ file, if the projection of the layer is
different  than the View, it  will  be indicated at  that  point  (something like “CRS xxxxx,
Reprojected on the fly”). 

We finally click on the “OK” button and the layer is added to the View (it is a big layer so it
can last some time in being loaded). 

Figure 14. Layer loaded in a View in gvSIG 



Exercise 4: Reprojecting vector layers 

Now we are going to  load the layer  about Neighborhoods.  We open the “View->Add
layer” menu again, and at the “File” tab we click on “Add” button. We select the shapefile
about the Neighborhood-Tabulation-Areas (its name starts with “geo_export...”, and the
rest of the name is different every time is downloaded). In this case, after selecting it, at
the “Add layer” window we have to indicate that this layer is in another reference system.
For that we press “Properties”,  and at the Properties window we access to the CRS
option. 

Figure 15. Changing the reference system of a layer, when it's different than the View 

At the new window, if we see the EPSG 4326 at the “Recent” Type (because it is the CRS
by default  in gvSIG), we select it  and press “Finish”.  In case it's  not available at  the
“Recent” CRS's, we will select “EPSG” type, and we will search “By code” and “4326”,
and we press Finish.  



Figure 16. Reference system of a layer, when it is different than the View one

We finally accept the “Add layer” window and the Neighborhood layer will be reprojected
on the fly at the View. 

As the window says, the layer is reprojected on the fly, but if we want to do analysis
(geoprocesses...),  it will  be done on the original coordinates, so we need to have the
layer at the View CRS physicality. For that, we will export the reprojected layer (on the fly)
to a new layer. The new one will be in the View CRS. 

Firstly we have to put the layer active, clicking on it at the ToC. And then we go to the
“Layer->Export to” menu. 

At  the new window we will  select  “Shape format”,  then we press “Next,  and we will
access to the “...” button in order to select the folder where the file will be saved, and the
file name. We can name it “Neighborhood_26918.shp” (because it will be its new CRS).
Then we press “Next”, and “All records” option, and we finally press “Export”. We indicate
that we want to add that layer to the View, and we close the Window. 

A new layer is added to the View, and its CRS is the same than the View. 

We can delete the old layer from the View, clicking on it (the “geo_export...”), and with the
secondary button a contextual menu is open, where we select “Delete layer”. 

We can see the attribute table associated to the Neighborhood layer. For that we active it

and we press on  .  

The attribute table contains different fields with the data of each neighborhood. 

We can order the field about the neighborhoods (“ntaname” field). For that, we click on

the field name, and then we press    . 

The field values are ordered alphabetically. 



Question 1: 
After ordering neighborhood field, look for the value “Manhattanville” and select it.
Which is the area of that neighborhood (the value of the “shape_area” field)? Take
into account that the three last numbers are the decimal ones. 

Now we are going to load the layer about Skateparks. We will follow the same steps than
the Neighborhood layer previously. We open the “View->Add layer” menu again, and at
the “File” tab we click on “Add” button. We select the shapefile about the Skateparks (its
name starts with “geo_export...”). After selecting it, at the “Add layer” window we have to
indicate that this layer is in another reference system. For that we press “Properties”, and
at the Properties window we access to the CRS option. 

At the new window, if we see the EPSG 4326 at the “Recent” Type, we select it and press
“Finish”. 

We finally accept the “Add layer” window and the Skateparks layer will be reprojected on
the fly at the View. 

We also are going to export the reprojected layer (on the fly) to a new layer in order to
have the new one in the View CRS, like we did with Neighborhood layer.  

Firstly we have to put the layer active, clicking on it at the ToC. And then we go to the
“Layer->Export to” menu. 

At  the new window we will  select  “Shape format”,  then we press “Next,  and we will
access to the “...” button in order to select the folder where the file will be saved, and the
file name. We can name it “Skateparks_26918.shp” (because it will  be its new CRS).
Then we press “Next”, and “All records” option, and we finally press “Export”. We indicate
that we want to add that layer to the View, and we close the Window. 

A new layer is added to the View, and its CRS is the same than the View. 

We can delete the old layer from the View, clicking on it (the “geo_export...”), and with the
secondary button a contextual menu is open, where we select “Delete layer”. 

Exercise 5: Changing symbology 

We will keep visible only the Neighborhood layer at the View (we unmark the check for
Streets and Streetparks layers). 

We are going to apply a legend to the Neighborhood layer. 

For that, press double click on the layer at the View, and the Properties layer window will
be opened. Then press “Symbols” tab. 

Now we will open “Categories” section and we press “Unique values”. Then we select
“boro_name” field, and we select a table color with assorted colors. We press “Add all”. If



colors are different we press “Apply” firstly and finally “OK”. 

Figure 17. Symbology configuration 

We will be able to see the different districts of New York at the Neighborhood layer. 

Exercise 6: Labeling a layer 

Now we are going to label the neighborhoods by their name. Open the Properties layer
window again and press “Labeling” tab, and enable the labeling. Now we will label by
“ntaname” field, with 200 for “fixed height” value, and “Meters” for units. We will change
the label color, and we select red or yellow for example. Then we accept that window, and
labels will be added. 

Now  use  the  “Center  view  to  point”  tool (or  in  the  View->Navigation  menu),
and center the View to X=600000, Y=4509000.  

Question 2: 
After applying symbology and adding labels, and zooming to the specified point,
which is the neighborhood under that point? 

Exercise 7: Hyperlink 

Now we are going to use hyperlink tool to link an element of the Neighborhood layer to an



image. 

Firstly we will download this image to our computer, and we can save it in a short path
(for example C:\temp\), and name it “chinatown.jpg”: 

http://www.newyork.com/articles/wp-content/uploads/2013/04/manhattan-
chinatown_a_540x340_2013424-450x235.jpg 

Then we are going to active the Neighborhood layer at the View and we are going to
“Start editing”. 

Figure 18. Start editing option 

Then we open its attribute table, and we access to the “Table->Add column” menu. 

We will add a new string field called “Link”, and size “100”. 

Figure 19. New field configuration 

http://www.newyork.com/articles/wp-content/uploads/2013/04/manhattan-chinatown_a_540x340_2013424-450x235.jpg
http://www.newyork.com/articles/wp-content/uploads/2013/04/manhattan-chinatown_a_540x340_2013424-450x235.jpg


After accepting we will have the new field. 

Now we are going to use the “Select by attribute” tool   to select one of the elements.
We want  to  select  the  neighborhood “Chinatown”.  So we will  write  this  sentence (or
clicking on the field and value): ntaname = 'Chinatown' 

Figure 20. “Select by attribute” tool 

Clicking on “New set” the Chinatown register will  be selected on the View and in the
Table. 

If we press the “Move up selection” button   we can see it at the first line. 

Then we can use the “Zoom to selection” button   to see it on the View. 

At  the  table,  at  that  register,  we  will  fill  in  the  “Link”  field  with  our  path  to  the
“chinatown.jpg” image. 



Figure 21. Path to the image for the hyperlink tool 

Then  we  will  close  the  table  and  using  the  secondary  button  of  the  mouse  on  the
“Neighborhood” layer we will  finish editing mode. We will  have a zoom to Chinatown
neighborhood at that moment. 

Now we have to configure the Hyperlink properties. We will open the Neighborhood layer
properties (double-click, or secondary button of the mouse). Then we will access to the
“Hyperlink” tab. 

At that window, we will enable the Hyperlink, we will select the “Link” field at the display,
and “Link to image files”. Then we accept it. 

Figure 22. Hyperlink settings



At the View we will  use the “Hyperlink” tool   and we will  click on the “Chinatown”
polygon. The Chinatown image will appear in gvSIG. 

Exercise 8: Loading Excel files 

At this point we are going to join the fields of a table to another one. First of all we will
load  an  Excel  file,  that  we  have  downloaded  at  the  beginning.  The  file  is  called
New_York_City_Population.xls. 

We will open the Project Manager (from the “Show->Project manager” menu), and we
select “Table” document. Then we press “New”, and at the “File” tab we press “Add”. We
select the “New_York_City_Population.xls” file that we saved in our cartography folder,
downloaded from the NY website. 

When the XLS file appears at the “New table” window, we will have to configure it to be
loaded correctly, so we have to select the table and press “Properties”. 

Figure 23. Loading an Excel file

Then, at the “General” tab, we will mark the “Use first row as header” option. We accept
both windows and the table will be open in gvSIG. 

We can see a field called “NTA Code” that contains the Neighborhood codes, like we had
at  the  “Neigborhood”  layer.  We  also  have  a  field  with  the  population  of  every
neighborhood. We are going to include that population to the Neighborhood shapefile
attribute table. 



Figure 24. Common fields to join tables

Exercise 9: Joining tables

We are going to open the View, and we will open the Neighborhood attribute table. Then

we will open the “Create join” tool   (or in the Table menu). At the new window we will
select  “Neighborhood_26918” table as data store,  and then we press Next.  Then we
select Neighborhood_population table as second data store. Then at the next window we
select “ntacode” for field of the first table, “NTA Code” for the second one, “N” as a prefix
for the first tabla (from “Neighborhood”), and “P” for the second one (from “Population”),
and we select “Population” field to be imported. 

Figure 25. Table join settings



Then  we  press  “Next”  and  at  the  last  window  we  mark  the  option  to  load  the
transformation as a layer, and we select the “Untitled” view (it was the first one, in EPSG
32918). Then we press Finish and a virtual layer called “Join” is loaded at the View. If we
open its attribute table we can see that the Population field has been added at the end. 

We can order the field about the neighborhoods (“N_ntaname” field). For that, we click on
the field name, and then we press . 

The field values are ordered alphabetically. 

Question 3: 
After ordering neighborhood field, look for the value “Erasmus” and select it. How
many population does it have? 

Exercise 10: Field calculator 

Now that we have the population and area values of every neighborhood we want to
calculate their density. For that we will use the field calculator. 

As the “Join” layer that we created from the join of tables is a “virtual” layer, we will have
to export to a new SHP file in order to work on it. So we put the “Join” layer active qat the
View, and we go to “Layer->Export to” menu, like we did previously. Then we will select
Shapefile, and at the next window we access to the “...” button to select the output layer.
We will name it “Neigborhood_population.shp”, and we will export all the registers. We
finally  will  add it  to  the  current  View. We can see that  some fields  will  be  renamed
because the field names of dbf files can't have more than 10 characters. 

Now we will put the new layer active and we will start editing (second button on it). We
will open its attribute table, and we will go to “Table->Column manager” menu.  We will
click on “New field” and we will add a new field called “Density”, type: “Double”, and size:
50. The new field will be added at the end of the table. 

Figure 26. Creating new field in a table



Then we put it active and we open the Field calculator . 

We have to take into account that area value is available in meters, so the density won't
be clear. We will need to convert it to squared meters. So we have to write this operation: 

[P_Populati]/([N_shape_ar]/1000000)

(we can double-click on the field names to add them to the Expression box)  

Figure 27. Field calculator 

If we press OK, the density of every neighborhood will be added to the table (the last 3
characters are the decimals). 

We finish editing of the layer. 

Question 4: 
After ordering neighborhood field again, look for the value “Hollis” and select it.
How much density does it have? 

We also can see the main statistics of a field. For that, keeping the “Density” field active,
we can press “Statistics”. Then  we  will  see  the  Maximum  and  minimum  values,
Media... 



Question 5: 
What's the media of the population density in New York? 
 

Now  we  are  going  to  apply  a  symbology  by  intervals,  where  we  can  see  what
neighborhood areas are more populated in an easy visualization. 

Firstly we will  zoom to the Neighborhood_population layer. We put it  active, and then
secondary button of the mouse, and finally “Zoom to layer”.  

Then we will double-click on the Neighborhood_population layer to open its properties,
and we access to the Symbols tab. 

Then we access to Quantities-> Intervals. 

Now we select “Density”  as Classification field,  “Equal  intervals”,  and 5 intervals.  We
select the white color as origin one, and a dark color (we can keep the blue one that is by
default). Finally we press “Compute intervals”, and then “Apply” and “OK”. 

Figure 28. Symbology by intervals configuration

We will able to see the areas with a high density in an easy way. 



Figure 29. Symbology by intervals for neighborhood density of population

Exercise 11: Cartographic representation 

Now we are going to create a map with the cartography of the last view. We also will
include a legend, north arrow, scale... 

At the current view (“Untitled”), we are going to keep only the Neighborhood_population
layer visible, with the legend by density. 

Firstly we will download this image in our disk: 
https://cdn.civitatis.com/guias/nuevayork/fotos/thumbs/nueva-york.jpg 

Now, to create a map, we will open the Project manager (“Show-Project manager” menu),
and we click on the Layout  document.  Then we press “New”,  and a  new window is
opened. 

We will  select “Page Size”: A4, “Horizontal”,  and we select the “Untitled” view. A new
layout is created with that view. 

Now we can reduce its size, to have enough space for the different elements. 

Then we can access to the “Map->Insert” menu, and we will insert: 
- Legend: We will draw a rectangle on the map, and we will select the view that we

have at the layout. We select only Neighborhood_population layer for the legend.

https://cdn.civitatis.com/guias/nuevayork/fotos/thumbs/nueva-york.jpg


Figure 30. Legend settings at the layout

- Scale: We will  draw a rectangle where the scale will  be inserted, and we will
select the view that we have at the layout. Then we will choose a graphical scale.

Figure 31. Scale settings at the layout

- North: We will  draw a rectangle where the north will  be inserted, and we will
select the view that we have at the layout, and the type of north arrow. At this way, if we
rotate the view at the layout, the north arrow rotates at the same time.



Figure 32. North settings at the layout

- Image: We will draw a rectangle where the image will be inserted, and we will
select the image that we have downloaded (nueva-york.jpg), accessing to “Browse”. The
image will be added to the layout.

Figure 33. Layout in gvSIG

Now we can export it to a PDF file (from ). 
 

Question 6: 
Create a PDF file with the map of densities in New York neighborhoods. 



Exercise 12: Adding raster files 

We are going to add a raster file at the View now, so we are going to open it (the view
“Untitled”, from “View->Project manager” menu). 

Then we press “Add layer”   (or from the View menu), and at the File tab we press
“Add”. We look for the file “Jersey_CityNE_tile2.sid” that we downloaded at the beginning
(it is an orthophotography). And after accepting it, the image is added to the view. 

We can zoom to it, clicking on the active layer, and then using the secondary button of
the mouse, we select “Zoom to layer”. We will see the image on the Neighborhood layer. 

We can apply transparency to the raster layer in order to see the neighborhood layer
symbology too (the density). 

For that we put the Jersey_CityNE_tile2.sid layer active, and with the secondary button of
the mouse we select “Raster properties”. 

Then we go to the “Transparency” tab, we active “Opacity” and we apply about 40%. We
finally press “Apply” and “Accept”. We will see the colors of the Neighborhood layer and
the image. 

Figure 34. Applying transparency to a raster file 



Exercise 13: Geographical selection 

At this section we are going to use some selection tools. For example we want to select
the biggest skateparks in New York city and know their neighborhood area. 

For that we will put the Skatepark layer active, and we will open its attribute table. Then
we will open the “Select by attribute” tool   . We want to select the skateparks the area
of which is bigger than 15000m2, So we will  write this sentence (clicking on the field
name):

shape_area > 15000 

and then we press “New set”. They will be selected on the table and on the view. 

Then we go back to the view, and we put the neighborhood_population layer active. We
want to know the neighborhood that have the selected skateparks. For that we will open
the “Select by layer” tool (at the Selection menu), and we configure it at this way: 

Select items from active layer that...
Intersect with 

Selected items of a layer 
Skateparks_26918 

we finally press “New set”. If we close that window, we can see them on the view, and if
we open its attribute table and we use “Move up selection” tool we can see them at the
top of the table. 

Question 7: 
How  many  neighborhoods  have  big  skateparks  (the  records  that  have  been
selected)? 

Exercise 14: Loading WMS servers

We are going to load some remote layers, from different servers. There are several types
of servers. We are going to use Web Map Service (WMS), where the origin layers can be
raster or vector ones, and it's loaded as an image in Geographic Information Systems,
and Web Feature Servers (WFS), when data are in vector format and it is loaded as a
vector layer too, having access to the attribute information. 

We are going to load some layers in EPSG 4326 (Geodetic coordinates, WGS84), so we
are going to create a new view in that reference system. For that, we will open the Project
Manager (“Show->Project Manager” menu), and we will select the “View” document. We
press “New” to create a new one, and a new View is created in EPSG 4326 (because it's
selected by default at the gvSIG Preferences; if we change it, the new Views would be
created in the selected CRS). We can check it  at  the bottom of the View. It's  called
“Untitled-1”. 



Now we are going to load a layer from a remote server. It will be the ortho of USA. For
that we will press “Add layer”, and we open the “WMS” tab. 

Now we will connect to this URL: 
http://  s  ervices.nationalmap.gov/arcgis/services/USGSNAIPPlus/MapServer/WMSServer  ?

Figure 35. Connecting to WMS server

Then we press “Next”. At the next window we open the “USGSNAIPImagery” folder, we
select “Image” and we press “Add”. 

http://services.nationalmap.gov/arcgis/services/USGSNAIPPlus/MapServer/WMSServer
http://services.nationalmap.gov/arcgis/services/USGSNAIPPlus/MapServer/WMSServer
http://services.nationalmap.gov/arcgis/services/USGSNAIPPlus/MapServer/WMSServer


Figure 36. Selection of layers in a WMS server

At the next window, we will keep the styles by default, and at the “Formats” tab we will
select: 

- Format: png 
- SRS: 4326
- Text format: application/vnd.esri.wms_raw_xml 

Figure 37. Selecting image format, reference system and text format in a WMS service



We will press “OK” and the USA ortho imagery will be loaded. It will take some seconds
because it has to connect to the server. 

Exercise 15: Creating new layers, graphical editing

Now we are going to  create a new layer, from “View->New layer”  menu.  At  the first
window we will select “Shapefile”, and at the next one we will access to “...” button to
select the folder where it will be saved and its name. We can call it “buildings”.  

At the next window we will change the “Type” of the shapefile to “SURFACE” (it will be a
polygon layer), and we will add one field that we can call “buildings”. 

Figure 38. Configuring geometry type and fields in a shapefile

Then at the last window we keep it by default and we finish. The layer is added to the
view. 

Now we are going to zoom to a neighborhood area and we are going to add elements to
the layer, concretely some buildings, so we put it active and we start editing mode. 

Then we press “Insert polygon” tool. 

Figure 39. “Insert polygon” tool



And we can start to draw a polygon, and with secondary button of the mouse we can
finish it. 

Figure 40. Drawing polygons in editing mode in a vector layer

We can draw several polygons, 

Figure 41. Polygons created in a shapefile

We also can move them, changing their location (it's a supposed case). For that we will

select a building and we will use “Move geometry” tool  to move the geometry from the
current position to other one at the view. 

After that we will finish editing and we save changes. 



Exercise 16: Creating KML file to be loaded in Google Earth  

We can export the “buildings.shp” layer to a KML format in order to load it in Google
Earth. For that we put it active and go to “Layer->Export to” menu. We select KML format
at the first window, and at the next one we mark the “Show attributes in balloon” option (to
show the attribute information in GE. At the next window we access to “...”  button to
select its name and folder. We call it “buildings-GE.kml”, and we export all registers. If we
open that file in Google Earth we can see it (we will have to change the color of the lines
to see them easily). 

Exercise 17: Loading WFS servers

Now we are going to load a Web Feature Service (WFS). For that we will “Add layer”, and
we'll go to “WFS” tab. 

Then we will connect to http://demo.opengeo.org/geoserver/wfs  ? 

Figure 42. Connecting to WFS service

At the next window we will select “Countries” layer. 

http://demo.opengeo.org/geoserver/wfs


Figure 43. Selecting layers in a WFS service

At the next window we can select the fields to be loaded. We keep all of them. And at the
Options window we check that EPSG is 4326. 

Figure 44. Fields and general options settings in a WFS service

At the last window we could load only the elements from a location, but we are going to
load all of them. So we press “OK”. 



Figure 45. Selecting the area of a layer in a WFS service

The layer will  be loaded after some seconds (it  will  take more than WMS because it
manages more data). We can do a “Zoom extent” to see the new layer. 

We can put it active at the view, and open its attribute table. We could select elements,
change symbology... At the WMS we couldn't do it because it was loaded as an image. 

Question 8: 
Which is the country with “postal” = “DZ”?

Exercise 18: Adding an event layer 

The  other  data  that  we  have  is  an  attribute  table,  in  CSV  format,  with  the  graffiti
complaints, but they don't have geographical component, only two columns with Latitude
and Longitude. At gvSIG we can load that table, and create a point layer from it, where
Latitude and Longitude fields are used to georeference the complaints. 

We can open the CSV file with a text editor (Notepad, gedit, kate...) to check how it is
created, and we can see that field separators are comma. 

Firstly we have to load the attribute table in gvSIG. We will open the Project Manager
(from the “Show->Project manager” menu), and we select “Table” document. Then we
press “New”, and at the “File” tab we press “Add”. We select the “graffiti_complaints.csv”
file that we saved in our cartography folder, downloaded from the NY website. 

When the CSV file appears at the “New table” window, we will have to configure it to be



loaded correctly, so we have to select the table and press “Properties”. 

Then, at the “Basic” tab, we will select the “Standard (double quote, comma and crif)”
option in “profile”. That's because the field separators at the CSV file are “,”. 

Figure 46: Selecting field separators in a CSV file

Then, at the “Advanced” tab, we have to uncheck the “automaticTypesDetection” option,
and fill the “fieldtypes” box in with this text: 

type:string,address:string,city:string,lat:double,lon:double

At that way we are indicating the field types in order to load them correctly in gvSIG. As
we have 5 columns at the table, we indicate the name of every field and its type. 

NOTE: From gvSIG 2.4 it is planned to include a tool to load tables in an easy way, like in
the spreadsheets (Excel, LibreOffice...). 



Figure 47: “Advanced” tab configuration

After that we Accept it, and the table will be loaded in gvSIG, with the 5 fields, and their
new names. 

We can see that Latitude and Longitude fields have only 3 decimals. We can show 10
decimals changing the Table properties. For that we will access to the “Table->Properties”
menu, and at the “Pattern” column of the “lat” and “lon” fields we change it. Now we can
see: 

#,##0.000

and we will add 7 “zeros”. It will remain:  

#,##0.0000000000 

(after editing the pattern, we have to press “Enter” for it to have effect). 



Figure 48. Changing pattern of fields in an attribute table 

And now we see the fields with more decimals: 

Figure 49. Attribute table with new pattern

The next step would be to create a point layer from the attribute table. It can be done with
“Create event layer” tool when there are two fields with the coordinates. 

But they are in EPSG 4326 CRS, so we will have to load them in a View in that reference
system. For that, we will open the “Untitled-1” View, that was in that CRS. 

Now we are going to add an Event layer, from the previous attribute table. We will go to

the “View->Add event layer” menu (or ). At the first window we will select the “graffiti



complaints” table, and we press “Next”. Then we select the “lon” field for X coordinates
and “lat” field for Y coordinates, and we change projection to EPSG 4326. Then we press
“Next”. At the last window we keep the “Load the transformation output as a layer” option,
and we select the “Untitled-1” View at the list. 

The event layer is loaded at the “Untitled-1” View, but it is a virtual layer (it is a csv file, a
text file). The way to have a point layer in gvSIG would be to export it to a new layer. 

For that, we have to put the layer active, clicking on it at the ToC. And then we go to the
“Layer->Export to” menu. 

At  the new window we will  select  “Shape format”,  then we press “Next,  and we will
access to the “...” button in order to select the folder where the file will be saved, and the
file name. We can name it “graffiti_complaints_4326.shp” (because it is its CRS). Then
we press “Next”, and “All records” option, and we finally press “Export”. We indicate that
we want to add that layer to the View, and we close the Window. 

A new layer is added to the View, and now it is a SHP file, that is in EPSG 4326. 

Now we want to have that layer on the other View (Untitled), in EPSG 26918, so we have
to reproject it on the fly, and finally export the layer to a new SHP to have it in the new
reference system. For that, we go to Show->Project manager, and at the Project manager
we click on the “View” document, and we open the View “Untitled”. 

Now we are going to add the new point layer, so we open the “View->Add layer” menu,
and  at  the  “File”  tab  we  click  on  “Add”  button.  We  select  the
“graffiti_complaints_4326.shp” file, but in this case, at the “Add layer” window we have to
indicate that that layer is in another reference system. For that we press “Properties”, and
at the Properties window we access to the CRS option. 

Figure 50. Changing reference system of a new layer



At the new window, we select the EPSG 4326 at the “Recent” Type, and press “Finish”.
We will see now the “reprojected on the fly” text at the CRS properties.  

Figure 51. Reference system of the layer to be added

We finally accept the “Add layer” window and the Complaints layer will be reprojected on
the fly at the View. 

As the layer is reprojected on the fly, and we want to do analysis (geoprocesses...), we
need  to  have  the  layer  at  the  View  CRS  physicality.  For  that,  we  will  export  the
reprojected layer  (on the fly)  to  a  new layer. Firstly  we have to  put  the layer  active,
clicking on it at the ToC. And then we go to the “Layer->Export to” menu. 

At  the new window we will  select  “Shape format”,  then we press “Next,  and we will
access to the “...” button in order to select the folder where the file will be saved, and the
file name. We can name it  “graffiti_complaints_26918.shp” (because it  will  be its new
CRS). Then we press “Next”, and “All records” option, and we finally press “Export”. We
indicate that we want to add that layer to the View, and we close the Window. 

A new layer is added to the View, and its CRS is the same than the View. 

We can delete the old layer from the View, clicking on “graffiti_complaints_4326.shp”, and
with the secondary button a contextual menu is open, where we select “Delete layer”. 

Exercise 19: Geoprocessing with gvSIG

At this point, after loading the cartography at the View, we are going to analyze if the
situation of the skateparks have a relationship with the graffiti complaints. 

We can use several geoprocesses for that. 

For example, one way to check if there's a relationship is to create hot maps (density
maps), where an image is create and pixel value is different when the density of points is
higher. 

At the current View, we are going to keep visible only the “complaints” and “skateparks”
layers. 

We can consider that skaters work in an area of 1,5 kilometers from the parks (it's an
estimated area, but it will help to see if it affects. So we are to use the buffer geoprocess
to create polygons the radio of which is 1500 meters from the skateparks. 



Firstly we will  open the Toolbox   (or from “Tools->Geoprocessing->Toolbox” menu).
The geoprocessing manager will be opened. 

Now we are going to open the “Buffer” geoprocess, inside “gvSIG Geoprocesses->Vector
layer tools”. A new window is opened. We will select “Skateparks_26918.shp” as input
layer, we mark the second option where distance for buffer is fixed (not by a field), and
we write “1500”. We also select “Dissolve entities” because if there are a skatepark close
to other one we want an only polygon. 

Figure 52. Buffer configuration 

At the bottom of that window, in the “Outputs” option we access to the “...” button and we
select the folder where it will be saved, and we call the file “buffer.shp”. At the end we
accept it and the buffer is created, and the new layer added to the view. 

Question 9: 
How many polygons have been created? 

We are going to change its symbology, double-clicking on the rectangle with the color at
the ToC. We will remove the fill, and increase the thickness of the line. 



Figure 53. Changing symbology to a shapefile

Now we will use “Density (kernel)” geoprocess in order to get a density map, where areas
with a high density of points (complaints) will have different colors. 

We need a field at the attribute table with the weight to calculate the density. In our case
the weight  will  be  the  same,  so  it  will  be  the  same value.  We are  going  to  put  the
graffiti_complaints_26918 layer active and start editing. Then we open its attribute table,
and we access to “Table->Add column” menu. We will add a field called “Weight”, and this
settings: “type“: Integer, “Size“: 1, and “Default value“: 1. At this way all the registers are
filled in with “1”. 

Figure 54. Creating a new field on the table



Now we finish editing and we will have the new field. 

And now we can start with the geoprocess. For that we open the Toolbox again, and we
open  Sextante  geoprocesses,  and  “Rasterization  and  interpolation”  option.  We  open
“Density (kernel)”. 

At the geoprocess we will select “graffiti_complaints_26918” file for input layer. The field
will be “Weight”, and “Search radius” will be “100”. 

For output layer we access to “...” button and we select the folder. We can call the file
“Density”. It will be a raster file. 

At the “Output region” tab we will select: 
- Use extent from layer:  graffiti_complaints_26918 

And cell size will be 20. 

After accepting, the process will start, and it will take several minutes, depending on the
computer. 

We'll see an image, with several areas in different colors. We can apply a Color table in
order to see it easily. 

For that, we put the new layer active, and with secondary button of the mouse we access
to “Color table”. Then we have to mark “Activate color table”, and we can select one of
the color tables with a scale (from light color to dark one),  for  example “Deep Azure
(256)”. Then we change the “Alpha” value of the first register to 0. At this way pixels with
no value will be transparent. 

Figure 55. Applying a color table to a raster file 

After applying and accepting we will be the image, where the dark blue areas will be the



areas with more graffiti complaints. 

If we put the Buffer layer active and with secondary button of the mouse we select “Bring
to front”. 

At this way we can see the skateparks and the areas with high number of complaints. 



Conclusions

To analyze the  skatepark  location in  New York  city  in  relation  with  complaints  about
requests on graffiti cleaning, some geoprocesses have been applied. 

For this analysis, a density method has been used to get the areas where there are more
graffiti complaints. It has been a first method. The situation of the skateparks has been
taken into account too, calculating an estimated distance from them where the skaters
can move. 

Seeing the results we can interpret that only in one of the areas where there are some
skateparks can have a direct relationship with the number of complaints. That area is one
of the most populated areas in New York, where there's a high density of population, so it
can be related too. 

At the other locations of skateparks the density of graffiti complaints is not as much high
as in the other case, so in general we can't deduce that they are related directly. 

 
Figure 56. Results of the analysis 

We can see in red color the areas where skateparks can be related to graffiti complaints,
but at the other ones it's not very noteworthy. 



Answers

Warning: These values are for August 2016. Data can be uploaded at the website, so
they can change a little bit. 

Question 1: 
After ordering neighborhood field, look for the value “Manhattanville” and select it.
Which is the area of that neighborhood (the value of the “shape_area” field)? Take
into account that the three last numbers are the decimal ones. 

10647077,452

Question 2: 
After applying symbology and adding labels, and zooming to the specified point,
which is the neighborhood under that point? 

Kew Gardens Hills

Question 3: 
After ordering neighborhood field, look for the value “Erasmus” and select it. How
many population does it have? 

31392

Question 4: 
After ordering neighborhood field again, look for the value “Hollis” and select it.
How much density does it have? 

906467

Question 5: 
What's the media of the population density in New York? 

1496.6845418722953 

Question 6: 
Create a PDF file with the map of densities in New York neighborhoods. 

It can be like this one: 

Question 7: 
How  many  neighborhoods  have  big  skateparks  (the  records  that  have  been
selected)? 

8 neighborhoods



Question 8: 
Which is the country with “postal” = “DZ”?

Algerie

Question 9: 
How many polygons have been created? 

14 polygons
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