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Part 1: GIS Project

Introduction  
At this project we want to analyze the skateparks location in New York city in relation with the
complaints about requests on graffiti cleaning. 

These data will be used for the analysis: 

- Skateparks of New York: This layer contains the skateparks of New York city. It is a SHP
file available in EPSG 4326 reference system (geodetic coordinates, WGS84).  

- Graffiti complaints: This is a CSV file that contains the graffiti complaints in New York city.
It has two fields with Latitude and Longitude values, that will  be used to get a point layer. Its
reference system will be EPSG 4326. 

We only will need these two layers for the main analysis because the results obtained with them
can define if the skateparks location is related to the graffiti complaints, but other factors would be
able to be included using other data like population of New York or neighborhood areas. 

We can get them from a public website, and we are going to use the open source Geographic
Information System called gvSIG. Layers that we will use for this analysis are skatepark location
in NY, and an attribute table that contains the graffiti complaints in the city. 

Firstly we will load the layer with skateparks in a View, reprojecting it in order to work in a UTM
reference system instead on geographical coordinates.  

Then an attribute  table  with  the graffiti  complaints  will  be  loaded.  It  contains  two fields  with
Latitude and Longitude values, and a point layer will be created from it, in Geodetic coordinates,
and then it will be reprojected to work in the same reference system than the other layer. 

At that point, the final analysis will start. For that, the first step would be to get an estimated area
of influence from the skateparks. It will be the estimated area around the skateparks where the
skaters would be able to work, going by walk or skating. 

Then, for the point layer with the complaints, a density map will be got, where the values will be
different where there's a higher density of points (complaints). 

The results will be a raster layer, and a color table will be applied on that layer in order to see the
areas with more graffiti complaints in an easier way for a better analysis. 

Finally, visualizing the information that have been got at this point, we will be able to analyze if the
skateparks location in New York city has any relationship with the complaints about requests on
graffiti cleaning. We will see if the area of influence of each skatepark contains the areas with
highest density of complaints. 



Part 2: Using gvSIG for analysis 

Downloading the layers to be used at the project 
We will  download the cartography from public servers, and we will  use the open source GIS
software called gvSIG.

The data for the project can be download from https://nycopendata.socrata.com/. 

- Skateparks: 
At the previous web page we can look for “Skateparks” at the “Searching” text box. The first
result will  be: Skateparks, (Directory of Skateparks). We will  click on the “Skateparks”
link, and a new web page will be opened with a viewer. At the right side, there's a button
to export the layer (the blue one). 

When we click on it we get the export options for the current layer. At the “Download Geospatial
Data” section we can select the file format to be exported. We will select the shapefile format, that
can be loaded in gvSIG. When we download it we will get a .ZIP file, that we can save in our hard
disk. We will unzip it, and we'll see the shapefile, that is composed by 4 files (.shp, .shx, .dbf
and .prj files). 

We have to take into account the Reference System of the layers in order to load them correctly
in gvSIG. If we open the prj file, we can see that its reference system is EPSG 4326 (Geodetic
coordinates, WGS84). 

- Graffiti complaints: 
At  the  same  web  page,  https://nycopendata.socrata.com/,  we  can  look  for  “graffiti”  at  the
“Searching” text box. At the “Search Results” section we will see: “311 Service Requests from
2010 to Present”, where the 311 Service Requests are compiled in a database. 

We can filter by type of complaint in order to get the graffiti complaints. For that we will click on
the “filter” option at the right side, and we will display the pull-down menu to select: 

“Complaint Type” is, 
and we will write 

“graffiti”
and then we mark that option. 

At the attribute table we can see that there are registers where the Latitude and Longitude fields
are empty. So they can't  be georeferenced. We will  apply another filter then to remove these
registers. Firstly we have to press “Add a New Filter Condition”, and we will display the pull-down
menu to select:

“Latitude” is greater than 
and we will write “0”.  

The filter is applied automatically. We will see only the complaints related to “graffiti” issues (we
can check it at the “Complaint type” column”), and all the Latitude values completed. 

In addition, as there are a lot of columns without information, and other ones with less important
information, we can reduce the number of fields, keeping only the important ones. We will access
to the “Manage” option (the brown menu), where we can select the fields to show or hide. 

We will  hide all  of  them, excepting “Complaint type”,  “Incident address”,  “City”,  “Latitude” and
“Longitude”, and then we will press “Apply”. We will see only five columns. 

https://nycopendata.socrata.com/
https://nycopendata.socrata.com/


And finally we will click on the “Export” button at the top part (the blue one), and then on the
“CSV” format to download the results. We will save the file in the folder where we are saving the
cartography. We can name it “graffiti_complaints.csv”. 

About the reference system, in this case, the Latitude and Longitude fields indicate that the data
are in EPSG 4326 (Geodetic coordinates, WGS84). 

Starting with gvSIG
Now we run gvSIG, and first step would be to create a new View in our project. For that we would
select the View icon at the Project Manager, and then we would choose the “New” button. The
View will be created and opened automatically, with the name “Untitled”. 

We can rename the View from the View Properties window (at the View, accessing to the View-
>Properties menu). We also can change the Reference System of the View. 

In our project we had some layers in EPSG 4326 (Geodetic coords.-WGS84) but we decide to
work in EPSG 26918 (NAD_1983_UTM_Zone_18N, in Meters),  a common CRS in New York,
because coordinates are in Meters and some geoprocesses work better. 

So we will change the reference system in our first View. From the View Properties window we
will access to the “Current projection” section. 

Figure 1. Button where reference system of a View can be changed in gvSIG

At the new window we will  select  Type EPSG, and we will  search “26918”, at the “By code”
option.  We get  just  one reference system.  Then we accept  it,  and we also  accept  the View
properties window. At the View, we can see its reference system at the bottom line. 

Adding layers 
Once the View is open we are going to add our first layer. It will be the NY Skateparks one. We
will open the “View->Add layer” menu, and at the “File” tab we click on “Add” button. We select
the shapefile about the Skateparks (its name starts with “geo_export...”). After selecting it, at the
“Add layer” window we have to indicate that this layer is in another reference system (it  is in
EPSG  4326  (Geodetic  coordinates,  WGS84)).  For  that  we  press  “Properties”,  and  at  the
Properties window we access to the CRS option. 

At the new window, if we see the EPSG 4326 at the “Recent” Type, we select it and press “Finish”
If it doesn't appear we will search it “by code”. We finally accept the “Add layer” window and the
Skateparks layer will be reprojected on the fly at the View. 

Now we are going to export the reprojected layer (on the fly) to a new layer in order to have the
new one in the View CRS.  For that we have to put the layer active, clicking on it at the ToC. And
then we go to the “Layer->Export to” menu. At the new window we will select “Shape format”, then
we press “Next”, and we will access to the “...” button in order to select the folder where the file
will be saved, and the file name. We can name it “Skateparks_26918.shp” (because it will be its
new CRS). Then we press “Next”, and “All  records” option, and we finally press “Export”. We
indicate that we want to add that layer to the View, and we close the Window. 

A new layer is added to the View, and its CRS is the same than the View. 



We can  delete  the old  layer  from the View,  clicking  on it  (the  “geo_export...”),  and  with  the
secondary button a contextual menu is open, where we select “Delete layer”. 

Adding an event layer 
The graffiti  complaints are contained in an attribute table, in CSV format, but they don't  have
geographical component, only two columns with Latitude and Longitude. At gvSIG we can load
that  table,  and create a point  layer  from it,  where Latitude and Longitude fields are used to
georeference the complaints. 

We can open the CSV file with a text editor (Notepad, gedit, kate...) to check how it is created,
and we can see that field separators are comma. 

Firstly we have to load the attribute table in gvSIG. We will open the Project Manager (from the
“Show->Project manager” menu), and we select “Table” document. Then we press “New”, and at
the “File” tab we press “Add”. We select the “graffiti_complaints.csv” file that we saved in our
cartography folder, downloaded from the NY website. 

When the CSV file appears at the “New table” window, we will have to configure it to be loaded
correctly, so we have to select the table and press “Properties”. 

Then, at the “Basic” tab, we will select the “Standard (double quote, comma and crif)” option in
“profile”. That's because the field separators at the CSV file are “,”. 

Then, at the “Advanced” tab, we have to uncheck the “automaticTypesDetection” option, and fill
the “fieldtypes” box in with this text: 
type:string,address:string,city:string,lat:double,lon:double

At that way we are indicating the field types in order to load them correctly in gvSIG. As we have
5 columns at the table, we indicate the name of every field and its type. 

After that we Accept it, and the table will be loaded in gvSIG, with the 5 fields, and their new
names. 

We can see that Latitude and Longitude fields have only 3 decimals. We can show 10 decimals
changing the Table properties. For that we will access to the “Table->Properties” menu, and at the
“Pattern” column of the “lat” and “lon” fields we change it. Now we can see: 

#,##0.000
and we will add 7 “zeros”. It will remain:  

#,##0.0000000000 
(after editing the pattern, we have to press “Enter” for it to have effect). 

Figure 2. Changing pattern of fields in an attribute table 

The next step would be to create a point layer from the attribute table. It can be done with “Create
event layer” tool when there are two fields with the coordinates. But they are in EPSG 4326 CRS,
so we will have to load them in a View in that reference system. For that, we will create a new
View. For that, we will open the Project Manager (from the “Show->Project manager” menu), and
we select “View” document. Then we press “New”. A new View called “Untitled-1” is created, and
its reference system is EPSG 4326 because it's the CRS by default. 

Now we are going to add an Event layer, from the previous attribute table. We will go to the



“View->Add event layer” menu (or ). At the first window we will select the “graffiti complaints”
table, and we press “Next”. Then we select the “lon” field for X coordinates and “lat” field for Y
coordinates, and we change projection to EPSG 4326. Then we press “Next”. At the last window
we keep the “Load the transformation output as a layer” option, and we select the “Untitled-1”
View at the list. 

The event layer is loaded at the “Untitled-1” View, but it is a virtual layer (it is a csv file, a text file).
The way to have a point layer in gvSIG would be to export it to a new layer. 

For that, we have to put the layer active, clicking on it at the ToC. And then we go to the “Layer-
>Export to” menu. 

At the new window we will select “Shape format”, then we press “Next, and we will access to the
“...” button in order to select the folder where the file will be saved, and the file name. We can
name it “graffiti_complaints_4326.shp” (because it  is its CRS). Then we press “Next”, and “All
records” option, and we finally press “Export”. We indicate that we want to add that layer to the
View, and we close the Window. A new layer is added to the View, and now it is a SHP file, that is
in EPSG 4326. 

Now we want to have that layer on the other View (Untitled), in EPSG 26918, so we have to
reproject it on the fly, and finally export the layer to a new SHP to have it in the new reference
system. For that, we go to Show->Project manager, and at the Project manager we click on the
“View” document, and we open the View “Untitled”. 

Now we are going to add the new point layer, so we open the “View->Add layer” menu, and at the
“File” tab we click on “Add” button. We select the “graffiti_complaints_4326.shp” file, but in this
case, at the “Add layer” window we have to indicate that that layer is in another reference system.
For that we press “Properties”, and at the Properties window we access to the CRS option. 

Figure 3. Changing reference system of a new layer

At the new window, we select the EPSG 4326 at the “Recent” Type, and press “Finish”. We will
see now the “reprojected on the fly” text at the CRS properties.  

Figure 4. Reference system of the layer to be added

We finally accept the “Add layer” window and the Complaints layer will be reprojected on the fly at
the View. 

As the layer is reprojected on the fly, and we want to do analysis (geoprocesses...), we need to
have the layer at the View CRS physically. For that, we will export the reprojected layer (on the
fly) to a new layer. Firstly we have to put the layer active, clicking on it at the ToC. And then we go
to the “Layer->Export to” menu. 



At the new window we will select “Shape format”, then we press “Next, and we will access to the
“...” button in order to select the folder where the file will be saved, and the file name. We can
name it “graffiti_complaints_26918.shp” (because it will be its new CRS). Then we press “Next”,
and “All records” option, and we finally press “Export”. We indicate that we want to add that layer
to the View, and we close the Window. A new layer is added to the View, and its CRS is the same
than the View. 

We can delete the old layer from the View, clicking on “graffiti_complaints_4326.shp”, and with the
secondary button a contextual menu is open, where we select “Delete layer”. 

Figure 5. Skateparks layer loaded in the new CRS in gvSIG 

Geoprocessing with gvSIG
At this point, after loading the cartography at the View, we are going to analyze if the situation of
the skateparks have a relationship with the graffiti complaints. We can use several geoprocesses
for that. For example, one way to check if there's a relationship is to create hot maps (density
maps), where an image is create and pixel value is different when the density of points is higher. 

We can consider that skaters work in an area of 1,5 kilometers from the parks (it's an estimated
area, but it will help to see if it affects. So we are to use the buffer geoprocess to create polygons
the radio of which is 1500 meters from the skateparks. 

Firstly  we  will  open  the  Toolbox   (or  from  “Tools->Geoprocessing->Toolbox”  menu).  The
geoprocessing manager will be opened. 

Now we are going to open the “Buffer” geoprocess, inside “gvSIG Geoprocesses->Vector layer
tools”. A new window is opened. We will select “Skateparks_26918.shp” as input layer, we mark
the second option where distance for buffer is fixed (not by a field), and we write “1500”. We also
select “Dissolve entities” because if there are a skatepark close to other one we want an only
polygon. 



Figure 6. Buffer configuration 

At the bottom of that window, in the “Outputs” option we access to the “...” button and we select
the folder where it will be saved, and we call the file “buffer.shp”. At the end we accept it and the
buffer is created, and the new layer added to the view. 

We are going to change its symbology, double-clicking on the rectangle with the color at the ToC.
We will remove the fill, and increase the thickness of the line. 

Figure 7. Changing symbology to a shapefile

Now we will use “Density (kernel)” geoprocess in order to get a density map, where areas with a
high density of points (complaints) will have different colors. 

We need a field at the attribute table with the weight to calculate the density. In our case the
weight  will  be  the  same,  so  it  will  be  the  same  value.  We  are  going  to  put  the
graffiti_complaints_26918 layer active and start editing (secondary button on it and “Start editing”
option).  Then we open its  attribute  table  (from the contextual  menu,  clicking with  secondary
button on it), and we access to “Table->Add column” menu. We will add a field called “Weight”,
and this settings: “type“: Integer, “Size“: 1, and “Default value“: 1. At this way all the registers are
filled in with “1”. Then we finish editing (from secondary button on the layer at the View) and we
will have the new field. 

And now we can start with the geoprocess. For that we open the Toolbox again, and we open
Sextante geoprocesses, and “Rasterization and interpolation” option. We open “Density (kernel)”. 

At the geoprocess we will select “graffiti_complaints_26918” file for input layer. The field will be
“Weight”, and “Search radius” will be “100”. For output layer we access to “...” button and we
select the folder. We can call the file “Density”. It will be a raster file. 



At the “Output region” tab we will select: “Use extent from layer:  graffiti_complaints_26918”. And
cell size will be 20. 

After  accepting,  the  process  will  start,  and  it  will  take  several  minutes,  depending  on  the
computer. We'll see an image, with several areas in different colors. We can apply a Color table in
order to see it easily. 

For that, we put the new layer active, and with secondary button of the mouse we access to
“Color table”. Then we have to mark “Activate color table”, and we can select one of the color
tables with a variety of  colors, for example “purple-red+stripes”.  Then we change the “Alpha”
value of the first register to 0. At this way pixels with no value will be transparent. 

Figure 8. Applying a color table to a raster file 

After applying and accepting we will be the image, where the blue areas will be the areas with
more graffiti complaints. 

If we put the Buffer layer active and with secondary button of the mouse we select “Bring to front”.

At this way we can see the skateparks and the areas with high number of complaints. 

Cartographic representation 
Now we are going to create a map with the results. We also will include a legend, north arrow,
scale...  For that, we will open the Project manager (“Show-Project manager” menu), and we click
on the Layout document. Then we press “New”, and a new window is opened. 

We will select “Page Size”: A4, “Horizontal”, and we select the “Untitled” view. A new layout is
created with that view. 

Now we can reduce its size, to have enough space for the different elements. 

Then we can access to the “Map->Insert” menu, and we will insert: 
- Rectangles: We will draw different rectangles for the View, titles, legend and scale. 
- Legend: We will draw a rectangle on the map, and we will select the view that we have at



the layout. We select only Buffer layer for the legend.
- Scale: We will draw a rectangle where the scale will be inserted, and we will select the

view that we have at the layout. Then we will choose a graphical scale. 
- North: We will draw a rectangle where the north will be inserted, and we will select the

view that we have at the layout, and the type of north arrow. At this way, if we rotate the view at
the layout, the north arrow rotates at the same time. 

- Text: We will write title and subtitle. For each one we draw a rectangle and then we write
the text to be inserted and its properties (size, font...). 

Finally we can export the layout to a PDF file (from ). 

Seeing the results we can interpret that only in one of the areas where there are some skateparks
can have a direct relationship with the number of complaints.  

At the other locations of skateparks the density of graffiti complaints is not as much high as in the
other case, so in general we can't deduce that they are related directly. 

Figure 9. Layout created with the results 

We can see in red color  some areas where skateparks can be related to graffiti  complaints,
because they are close to some area with a huge number of complaints, but at the other ones it's
not very noteworthy. 

Conclusions
To analyze the skatepark location in New York city in relation with complaints about requests on
graffiti cleaning, some geoprocesses have been applied. 



For this analysis, a density method has been used to get the areas where there are more graffiti
complaints.  The  situation  of  the  skateparks  has  been  taken  into  account  too,  calculating  an
estimated distance from them where the skaters can move. 

After the analysis we can see that not all skateparks have a direct relationship with the number of
complaints.   We can't  deduce that  they are related directly because only in one of  them the
number of complaints are higher than the media. 

All this analysis have been able to be done with gvSIG software. The main advantage is that it is
open  source  software,  so  anyone  have  to  pay  for  using  it.  It  includes  a  huge  quantity  of
functionalities that allow to do raster and vector analysis. 

We also can conclude that the analysis can be done with the cartography available publicly. It
would be able to be improved with population data to analyze if the complaints coincide with the
most population areas of the city. This information is available at the same website, and also the
neighborhood areas, so they would be able to be used for that purpose. 
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