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OSGIS10 Setting up the LiveDVD

This page last changed on Jun 15, 2010 by jsanz.

Minimum requirements.

• Intel-compatible CPU (i486 or later)
• Minimum RAM: 256 MB, Recommended: 512 MB or more
• DVD reader with autorun (IDE/ATAPI, Firewire, USB or SCSI)
• SVGA-compatible graphics board

Starting the gvSIG LiveDVD

• Make sure the BIOS allows OS start from the Live-DVD.
• Insert the Live-DVD in the DVD reader and restart the computer.
• When the first screen appears, select Try Xubuntu without any change to your computer and press

Enter.

Press F2 to change the language, and F3 to change the keyboard. Press F1 to obtain more
help.

• After a few moments the gvSIG LiveDVD Desktop should appear
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Setting up the University Proxy

The Nottingham laboratory has a web proxy so you need to set it up on the LiveDVD web browser
(Mozilla Firefox)

• Open Firefox browser
• Go to Edit->Preferences->Advanced Section->Network tab->Connection Settings button:

 

• Add the url http://mainproxy.nottingham.ac.uk and the 8080 port to the HTTP proxy section:

http://mainproxy.nottingham.ac.uk
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• Now you should be able to navigate on the Internet
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OSGIS10 Brief introduction to the project gvSIG

This page last changed on Jun 18, 2010 by jsanz.

gvSIG is a tool oriented to manage geographic information. It is characterized by a user-friendly
interface, with a quick access to the most usual raster and vector formats. In the same view it includes
local as well as remote data (for example WMS, WCS or WFS source).

It is aimed at users of geographic information, whether professionals or civil servants (city councils,
councils, regional councils or ministries) from any part of the world (at the moment its interface is in
more than 20 languages, in addition to being free.

Given its Free Software nature (open source) it is highly interesting for the international community
of developers and, in particular, for university settings due to its R&D&I component. In fact, special
emphasis has been placed on the expansion of the project so that potential developers can easily expand
the functions of the application, as well as develop completely new applications from the libraries used in
gvSIG (as long as they comply with the GPL license).

gvSIG Desktop is a desktop application designed for capturing, storing, handling, analyzing and
deploying any kind of referenced geographic information in order to solve complex management and
planning problems. gvSIG is known for having a user-friendly interface, being able to access the most
common formats, both vector and raster ones. It features a wide range of tools for working with
geographic-like information (query tools, layout creation, geoprocessing, networks, etc.), which turns
gvSIG into the ideal tool for users working in the land realm.

gvSIG Mobile is a Geographic Information System (GIS) aimed at mobile devices, ideal for projects
that capture and update data in the field. It's known for having a user-friendly interface, being able to
access the most common formats and a wide range of GIS and GPS tools which are ideal for working
with geographic information. gvSIG Mobile aims at broadening gvSIG Desktop execution platforms to
a range of mobile devices, in order to give an answer to the needings of a growing number of mobile
solutions users, who wish to use a GIS on different types of devices. So far, gvSIG Mobile is a Geographic
Information System, as well as a Spatial Data Infrastructures client for mobile devices. Such a client is
also the first one licensed under open source.

Slides

The gvSIG introduction slides can be viewed online here

The slides are in SVG format and must be viewed using Firefox 3.0 or newer

Interesting links

• gvSIG community portal
° User docs
° gvSIG mailing lists

• gvSIG association
• OSOR.eu portal

° gvSIG Desktop
° gvSIG Mobile

• OSGeo Foundation
° gvSIG Incubation status
° OSGeo Live

http://gvsig-desktop.forge.osor.eu/downloads/pub/documents/reports/2010/06_OSGIS/gvsig-presentation.svg
http://www.gvsig.org
http://www.gvsig.org/web/projects/gvsig-desktop/docs/user
http://www.gvsig.org/web/home/community/mailing-lists
http://www.gvsig.com
http://www.osor.eu
http://forge.osor.eu/projects/gvsig-desktop/
http://forge.osor.eu/projects/gvsig-mobile/
http://www.osgeo.org
http://wiki.osgeo.org/wiki/GvSIG_Incubation_Status
http://live.osgeo.org/
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OSGIS10 Structure and configuration of a project in gvSIG

This page last changed on Jun 18, 2010 by jsanz.

gvSIG application works with projects, with .gvp extension. 

Every project can contain three different documents:  

• Views: where the cartography is loaded as different layers.
• Tables: attribute tables attached to every vector layer loaded in a view.
• Maps: layouts where views (with north arrows, legend...) can be added to be printed or exported to

a pdf file.

When gvSIG is opened, the Project manager window appears directly, and different views, tables and
maps can be created from it.

Preferences configuration

From the Windows->Preferences menu: 

• Editing: To change the configuration when editing tools are used.
• Maps: To activate grid and ruler in a Map.
• Symbology: To change the symbology by default.

° Change Default fill color to Aleatory
• Cartography: To change measure units
• View: To change default projection for the views, zoom factor, view back color, selection color, map

units...
• View->Layer loading order: To change the order of the loaded layers.
• Network->Firewall/Proxy: To select the Proxy configuration when we have internet through a proxy.
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• General->Language: To change to another language, install a new one or an update, or export to a
file to translate to a new language.
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OSGIS10 Visualization of data

This page last changed on Jun 19, 2010 by jsanz.

Contents

Error formatting macro: toc: java.lang.NullPointerException

Create a view and add a shapefile

• Add a new View and open it: From the Project manager, press New, select the new View, and press
Open. 

• A View has three different elements:
° Geographic View: Where the vector and raster layers are loaded graphically.
° Table of contents (TOC): Layers loaded in the Geographic View. The order of the layers is the

same than their visualization in the Geographic View.
° Locator: An easy way to navigate on the View.

• View->Add layer menu, and add esp_provincias.shp file from the /data/cartography/Spain/
folder.

Navigation on the View

Basic tools

Tip
To change the layer symbology, you should click on the Properties button and then close the locator
dialog

• Locator:

https://confluence.prodevelop.es/download/attachments/12419116/view-properties.png
https://confluence.prodevelop.es/download/attachments/12419116/load-esp-provincias.png
https://confluence.prodevelop.es/download/attachments/12419116/locator.png
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° View->Configure locator map menu
° Add layer: esp_localizador.shp

• Zoom to layer:
° Add layers to the View: Centro_2002.jp2 and Puerto_1980.ecw at /data/cartography/
Valencia/ folder..

° Select the layer Centro_2002.jp2 and right-click on it; then Zoom to layer to navigate to the
layer extent

• Zoom manager (1):
° Add layer: parcelas_Valencia.shp from the same folder
° Zoom to a little area of the Valencia's port.
° View->Navigation->Zoom manager menu; save the current zoom as Port

• Center view to a point:
° Add layer: Puerto_2002.ecw
° View->Center view to point menu:

- X: 725830
- Y: 4372060

https://confluence.prodevelop.es/download/attachments/12419116/zoom-manager.png
https://confluence.prodevelop.es/download/attachments/12419116/save-zoom.png
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• Zoom manager (2):
° View->Navigation->Zoom manager menu; select the Port zoom and press Select.

Areas and distances

• Over the view, Areas and Distances can be measured (from View->Query).
• Try to measure the area and maximum longitude of the Valencia City Hall Square

(x=725800,y=4372432)

Locate by attribute

• Another way to navigate on the view is with the Locate by attribute tool, where a zoom can be done
to an element of a layer, selecting the field of the layer and the value of the associated table.

• Go to the View->Locate by attribute menu.
• Select the following values:

° Layer: esp_provincias.shp
° Field: NOMBRE99
° Value: Valencia

https://confluence.prodevelop.es/download/attachments/12419116/measure-area.png
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Scale of a view

• The scale of a view can be modified from the scale bar. Default scale values can be selected, or a
value can be written by keyboard.

Styling

Transparency of a raster image

On the same view, keep only visible Puerto_2002.ecw and Puerto_1980.ecw layers, and
Puerto_2002.ecw as active layer.

• Press right button on the active layer, and then Raster properties (1). You'll see an overview of
raster characteristics(2).

• Select Transparency tab.
• Active Opacity, and select a 35% of transparency. The differencies of the port between 1980 and

2002 are shown on the view(3).

1 2 3

Extension

• Play with the bands switchers to change the colour assignment. This could be more
interesting if you add to a new view the raster file /data/cartography/Uruguay/raster/
RecorteB10_B70.tif.

• Try to remove the grey colour of the /data/cartography/Andalucia/relieve_andalucia.jpg
raster file activating the per-pixel transparency and using the small Pick RGB from view helper.

https://confluence.prodevelop.es/download/attachments/12419116/raster-properties-menu.png
https://confluence.prodevelop.es/download/attachments/12419116/raster-properties-overview.png
https://confluence.prodevelop.es/download/attachments/12419116/raster-transparency.png
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Legends and basic symbology

tip
You can change one symbol double-clicking on the TOC symbol preview

• Properties of the layer: Double-click on the esp_provincias.shp layer in the TOC.
• Select Symbology tab, then Categories->Unique values; change Classification field to NOMBRE99;

press Add all and Accept.
• Modifying symbology of a polygon:

° Access to the Properties of the layer again; select on the Albacete symbol (with double-click)
° Press Choose symbol, and change Fill color, Border color...

Extension

• Try to apply the Expressions category legend to show witch provinces of Spain are bigger than
1^10 square meters.

• Enter on the properties of the symbol and experiment with the polygon symbology options like
using a line fill, modifying the outline, etc.

https://confluence.prodevelop.es/download/attachments/12419116/false-color.png
https://confluence.prodevelop.es/download/attachments/12419116/remove-grey.png
https://confluence.prodevelop.es/download/attachments/12419116/legend-unique-values.png
https://confluence.prodevelop.es/download/attachments/12419116/basic-symbol.png
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Legend by intervals

• Do a copy of the first View: Project Manager->View, and right mouse button on the first View. Select
Copy, then left mouse button and Paste. Write a new name.

• Properties->Symbols of the esp_provincias.shp layer.
• Select Quantities->Intervals, and the following values:

° Field AREA
° Equal intervals
° Begin colour: White
° Number of intervals: 25

• Press Compute intervals, and then Accept.

Labelling

• Access to the Properties of the esp_provincias.shp layer, then the Labelling tab
• Select Enable labelling, and the following values:

° General: Settings from attributes field
° Field to be labeled: NOMBRE99
° Fixed height: 10
° Units: pixels, and In the world
° Fixed color: Black

https://confluence.prodevelop.es/download/attachments/12419116/expression-legend.png
https://confluence.prodevelop.es/download/attachments/12419116/polygon-advanced.png
https://confluence.prodevelop.es/download/attachments/12419116/legend-intervals.png
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Extension
The new advanced labelling features of gvSIG are out of the scope of this workshop but you can
check the documentation (sorry, at this time only in Spanish) or check the last gvSIG Conference
workshop video on new features of gvSIG 1.9 (translated in English) (minute 20:22).

Predefined legend

gvSIG has its own legend file format (.gvl) that supports all the gvSIG features.

• Create a new view, called Andalucia1.
• Add new layers: municipiosAndal.shp, hidro_andalucia.shp and ferrocarrilAndal.shp

(Reference system: 23030).
• Keep as visible layers municipiosAndal.shp and hidro_andalucia.shp
• Access to the Properties menu of the {{hidro_andalucia.shp* layer, and then Symbols tab.
• Press Load legend and load the jerarquia.gvl file (from the Andalucia folder).

A created legend can be exported to a symbology interchange format (.sld). It can be used to share
legends with other programs, but if it's used in gvSIG, some characteristics can disappear.

• Access to Properties->Symbols of the municipiosAndal.shp layer.
• Create a new symbology (Cathegories->Unique values), by the field PROVINCIAS. Then press Save

Legend, and save it as a .sld file.

Layer tools

Vector layer reprojection

• Add new layer: esp_4326.shp (with the Current projection by default: 23030).
• After a Zoom to the new layer, we see that the coordinates of the new layer aren't correct.
• Delete the last layer.
• Add new layer: esp_4326.shp , but changing the Current projection (1)

° Type: EPSG
° By code: 4326 (and press Enter)
° Select transformation: EPSG Transformation, and press Next. (1)
° Transformation: 1633 (Spain-mainland...), and press Finalize. (2)
° Finish the setting up and accept the warning, you should see the Spain shapefile well

transformed over the rest of the layers.

1 2 3

Add event layer

A layer of points can be added in a view from an alphanumeric table with coordinates.

https://confluence.prodevelop.es/download/attachments/12419116/basic-labelling.png
http://www.gvsig.org/web/docusr/userguide-gvsig-2-0/simbologia-y-etiquetado/etiquetado-avanzado/etiquetado-avanzado-definido-por-el-usuario/gvsig_allFolderContentsOnOnePage_view
http://www.viddler.com/explore/gvsig/videos/171
https://confluence.prodevelop.es/download/attachments/12419116/change-projection.png
https://confluence.prodevelop.es/download/attachments/12419116/change-projection-2.png
https://confluence.prodevelop.es/download/attachments/12419116/change-projection-3.png


Document generated by Confluence on Jun 24, 2010 16:21 Page 15

Firstly, the table has to be added to the project:

• From the Project manager, select Table document, then New and finally Add.
• Select XY_mun.dbf file at /data/cartography/Valencia/ folder (1)
• In the last view, go to the View->Add event layer menu (2) and select the following values :

Table X Y
XY_mun.dbf XUTM YUTM

• Press OK, you should see a new point layer at gvSIG with the centroids of the Valencian region
municipalities(3).

1 2 3

Remember
An event layer at gvSIG is just a graphical representation of an alphanumeric table, so no real data
has been converted on this process

Export data

Export the view to an image

A view can be exported to an image file without georeferencing. This is useful to add the view in
documents, presentations, etc.

• Access to the View->Export->Image menu and save our current view.

Exporting layers

Last exercise was a simple image export, to do a real conversion of vectorial data you should us the
Export tools. As the event layer is only a virtual layer, to obtain a real layer it must be exported to a
shapefile format for example.

• Having an active layer, if there are several elements selected on it, only those features will be
exported. If there aren't any element selected, all the layer features will be exported to a new one.

• It can be done from the Layer -> Export to -> SHP menu.

https://confluence.prodevelop.es/download/attachments/12419116/table-added.png
https://confluence.prodevelop.es/download/attachments/12419116/add-event-layer.png
https://confluence.prodevelop.es/download/attachments/12419116/event-layer.png
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OSGIS10 Selections and tables

This page last changed on Jun 19, 2010 by jsanz.

Contents

Error formatting macro: toc: java.lang.NullPointerException

Selecting tools

Basic tools

Create a new View and assure it's in EPSG:23030.

• Add the municipiosAndal.shp layer from /data/cartography/Andalucia folder.
• The following selecting tools can be used in gvSIG (from the View->Selection menu):

° Select by point (press "Ctrl" for multiple selection)
° Select by rectangle
° Select by polygon*
° Select by polyline*
° Select by circle

* (double-click to end)

Selection tools menu Selection toolbar

Select by buffer of distance

Other type of selection is the Select by buffer zone. This tool need a previous selection and doing a buffer
over the selected features it increases it.

• Remove any previous selection with the Clear selection tool (from the toolbar)
• Activate the municipiosAndal.shp layer, and select a feature with the Select by point tool (1).
• Go to View->Selection->Select by buffer zone
• Write 120.00 m. (this in fact means 12000m, see side note)
• In the Options area, activate Add buffer zone layers, and press OK (2).
• The selection will be performed, a new vector layer with the buffer calculated will be added and

finally a dialog with the details of the process will appear (3).

Bug!
There's a bug on this gvSIG version, you should write your distance taking in account the decimals
as normal zeros, so to ask for 12000 meters you have to write 120.00. A bug ticket with this issue
has been reported on the official gvSIG Desktop bugtracker.

1 2 3

http://forge.osor.eu/tracker/?func=detail&aid=14394&group_id=89&atid=732
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Selection by attributes

Instead of using graphical tools you can also do a selection based on attribute table values.

• Remove any previous selection with the Clear selection tool (from the toolbar)
• Add the ferrocarrilAndal.shp to your view
• Activate the layer: ferrocarrilAndal.shp
• Access to the Table->Filter menu
• Select the query "COD_ENT" = "V10", and press New set.

Tip
You can concatenate several selections adding or subtracting features from the current selection set.

Spatial select

You can do a more complex selection based on spatial topological rules. On this example will select all the
municipalities touched by the last railway selected.

• Activate municipiosAndal.shp layer
• Go to View->Selection->Selection by layer
• Do the following query:

° _Select items from active layers that are...
- Intersected with

° Selected items of a layer
- ferrocarrilAndal.shp

• Press New set

Tip
You can concatenate several selections adding or subtracting features from the current selection set.

https://confluence.prodevelop.es/download/attachments/12419119/buffer-select-point.png
https://confluence.prodevelop.es/download/attachments/12419119/buffer-select-configure.png
https://confluence.prodevelop.es/download/attachments/12419119/buffer-select-finish.png
https://confluence.prodevelop.es/download/attachments/12419119/select-by-attributes.png
https://confluence.prodevelop.es/download/attachments/12419119/select-spatial.png
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Exploring attribute tables

gvSIG has several features in order to let the user explore and navigate over the attribute table
associated with many vectorial data formats.

• Activate municipiosAndal.shp (there were several selected elements of the previous exercise)
• Open its attribute table (from Layer->See table of attributes)
• Move selected elements to top (1)
• Select the complementary elements (2)
• Go to the selected elements directly (3)

Information tools

Information of the elements can be consulted with two different tools: Information, and Quick info.

• Access to View->Query->Information, and click on an element of the municipiosAndal.shp layer
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• Activate ferrocarrilAndal.shp
• Access to View->Query->Quick info
• Select the ferrocarrilAndal.shp layer, activate the field COD_ENT, and select the Length calculated

field. After accepting, if the mouse is on an element of the layer, its information is shown directly.

Table tools

Table summarize

This tool gets statistics of field values grouping the data by one of their attributes.

• Add hidro_andalucia.shp, activate it and open its attribute table
• Open the Table summarize tool (from the toolbar) (1)
• The group will be done by the field JERARQUIA
• Then select from the field LENGTH the Minimum, Maximum and Sum
• Save as a new dbf file, for example /tmp/summarize.dbf (2)
• This new table is added to the gvSIG project (3)

1 2 3

Joining tables

On this exercise you will join an external comma separated file (.csv) with data coming from the Spanish
National Institute of Statistics with the Spanish provinces layer.

Note

https://confluence.prodevelop.es/download/attachments/12419119/info-tool.png
https://confluence.prodevelop.es/download/attachments/12419119/quick-info.png
https://confluence.prodevelop.es/download/attachments/12419119/summarize.png
https://confluence.prodevelop.es/download/attachments/12419119/summarize-table.png
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For a correct import of a CSV file you should use semicolon (; ) to separate your fields and use the
dot (.) as a decimal separator.

• Go to the Project Manager, and then Table
• Press New, and then Add
• Add PoblacionINE.csv from the /data/cartography/Spain/ folder
• On a new View add esp_provincias.shp
• Open the attribute table of this layer
• Go to Table->Join.
• Select esp_provincias.shp, field DPROV, a prov prefix and Next (1).
• Then PoblacionINE.csv, field CODIGO, a ine prefix and Finish (2)
• You'll get a joined table with the prefixes set up to identify the table where they come from (3)

1 2 3

You can remove a table join using the Table->Remove joins menu entry.

Import fields

The previous exercise doesn't modify the layer with the table joined. On this exercise we will do a similar
task but writing the imported fields so the first thing we need to do is to copy the shapefile where we can
modify it.

• Go to an explorer and copy the 5 files of the esp_provincias layer to the folder /home/ubuntu (1).
• Open it in a new View, and open its table
• Go to Table->Import fields
• Select the following values: Table: esp_provincias.shp, Link field: DPROV, Table to import:
PoblacionINE.csv, Link field: codigo, and then Next (2)

• Select the fields Nombre, Total, Hombres and Mujeres, and then Finish (3)

1 2 3

Using the selection tools now you can check witch features of the provinces shapefile have no values
on the statistics fields and see that their DPROV value maybe it's not so good...

Export table

This feature let you export any table to DBF} or Microsoft Excel format ({{.xls).

https://confluence.prodevelop.es/download/attachments/12419119/join-tables-i.png
https://confluence.prodevelop.es/download/attachments/12419119/join-tables-ii.png
https://confluence.prodevelop.es/download/attachments/12419119/join-tables-iii.png
https://confluence.prodevelop.es/download/attachments/12419119/import-fields-i.png
https://confluence.prodevelop.es/download/attachments/12419119/import-fields-i.png
https://confluence.prodevelop.es/download/attachments/12419119/import-fields-iii.png
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Table encoding

As you probably have noticed, the provinces shapefile shows some strange characters on the name field.
This is because the character enconding is not well set. The Shalom extension let the user to manually set
the encoding for dbf files.

• Close gvSIG
• Repeat the copy of the shapefile esp_provincias to your home folder (/home/ubuntu)
• Open gvSIG
• Open the gable esp_provincias.dbf, you'll see strange characters at NOMBRE99 field
• Assign the CP1252 enconding using Shalom->Set Encoding to dbf files
• Delete the table from your gvSIG project
• Create new View and add esp_provincipas.dbf. If you apply a labelling by the NOMBRE99 field

you'll be able to see the correct characters with accents, apostrophes, etc.

Before After

https://confluence.prodevelop.es/download/attachments/12419119/shalom-i.png
https://confluence.prodevelop.es/download/attachments/12419119/shalom-iv.png
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OSGIS10 Visualization and query of remote data

This page last changed on Jun 21, 2010 by jvhigon.

Proxy Settings
First of all, if a proxy is needed to connect internet you will have to change gvSIG settings. Go to Window
> Preferences ... > Network --> Firewall/Proxy and set your proxy parameters.

WMS - Web Map Service
On a gvSIG view we can have both kind of data: local and remote (WMS, WFS, WCS).

1. Copy the view VISTA1 that already exists (on the Project Manager). We are going to add a WMS
layer on this view.

2. Keep as active only the layer   Centro_2002.jp2
3. Go to View --> Add Layer... and click on the WMS tab. Put the url:  http://localhost/mapserver/

wms* and click Connect. The service description should appear.

http://localhost/mapserver/wms*
http://localhost/mapserver/wms*
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4. Click on Next button, go to the tab Layers and select the layer Constructions   in  Valencia, then click
on button Add. Select format .png and SRS 23030.The layer will be added to the TOC on the view. 

5. Change the opacity of the layers doing right click on the name of the layer and selecting Raster
properties. Select the tab Transparency and active the opacity to see the orthophoto below (use the
slide bar for selecting an opacity percentage).

6. Select the Information tool and click on one of the geometries of the vector layer. A window will
show only the queryable attributes. For example, you could find out what is the composition of any
building seeing the attribute called constru.
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7. Load another WMS layer, this time from Catastro (you must have internet connection). Its url
is _http://ovc.catastro.meh.es/Cartografia/WMS/ServidorWMS.aspx_ . Select the layer called
Catastro , the .png format and SRS 23030. 

8. If you click with the Information tool into one plot, a window will open showing the cadastrial
reference of that plot. This link is useful in order to see the public information related to this plot
published on the cadastrial web pages . 

9. Another use we can make from a WMS is to compare 2 different layers from the same extent but
different period of time. Connect again to http://localhost/mapserver/wms* , select the layer
Harbour from Valencia, years 1980 and 2002 and click on Add. Go to the tab called Dimension
and select and specific date (for example 1980 first). 

10. In order to see differences between two periods of time, load the same layer on a different time and
change its opacity (70 percent for example).

WMC - Web Map Context
Once you have a WMS layer added, you are able to export a WMC file (.cml format) that allows you to
save the local settings of your WMS layers added to the view (layers, zooms, extent).

1. You should have a WMS layer on the TOC (if not, add one to the view), click on the tool Center
view to point and type the coordinates X = 726300 and Y = 4372900. Once the view has been
centered on this coordinates and a red marker appears on it, change the scale on the state bar to
1:1000.

http://ovc.catastro.meh.es/Cartografia/WMS/ServidorWMS.aspx_
http://localhost/mapserver/wms*
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2. The next step will be to save the view state as a WMC file. To do that go to View/Export/Web
Map Context... and select a view, a title, an identifier and a file to save it. It is important to save
the file in a location with permissions like /home/ubuntu. Finally, choose the option Defined by the
view's extent .

 Now, the other way round: import WMC files.

1. Create a new view and go to  File/Import/Web Map Context in order to select and load the WMC
file. The new view should have the same WMS layers (and properties) and extent that the original
one. The same could be done if you import that WMC file in another computer.

WFS - Web Feature Service
The WFS service allows you to work with vectorial layers loaded from a remote service. The information is
retrieved in GML format.

1. Create a new view where the WFS layer will be added. Connect to  http://localhost/geoserver/wfs
and select the feature type Railway lines of Andalucia (linear layer). Select all the attributes
on the Field tab. On the Option tab do not change the value of Max. features (1000 by default).
Finally, keep the default settings for Options, Filter and Area.

http://localhost/geoserver/wfs
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2. After the wizard is completed, a vector layer will be added to the TOC of the view. This vector layer
is like any other vector layer, so you will be able to change its symbology. Go to the context menu of
the layer, click on Properties and select the Symbols tab. Choose the Unique values option and
set the legend to the field cod_ent.

3. Apply the new legend, go to Layer/Export to/SHP and export the date into a shapefile. Notice
that you can export the vector layer into other formats like dxf, kml, gml and postgis as well. 

4. Finally, try to change the request paramaters in the context menu WFS Properties of the layer. For
example use the filter option, change the fields request or set other maximum features to load.

WCS - Web Coverage Service

From this web servise you are able to load coverages to the gvSIG view. This is a kind of raster files, for
example DEM or DTM .

1. Create and Open a new view on the gvSIG project manager.  Select Add layer and go to the tab
WCS. Connect to the url http://localhost/mapserver/wcs

2. Once you are connected, select the layer  90m DTM of South West section   of   the   Iberian  
Peninsula and on the Format tab select GEOTIFF.

http://localhost/mapserver/wcs
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3. On the last tab you can select the image band to load. Select the only one available. Click on button
Accept and the layer will be added to the view.

4. In the context menu of the layer, you are able to change the WCS Properties, like others services.

Catalogue search
The catalogue search service gives us the possibility for searching geographical information on the net.

1. Open a new view, call it "Andalucia's towns". Click on the catalogue icon (Geodata search).

2. Set the url http://localhost/geonetwork/srv/csw and select the CSW/ISO 19115 protocol.

http://localhost/geonetwork/srv/csw
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3. After the connection to the server is established, type the keyword Andalucia and click the button
Search.

4. A window will be showed with the results of the geosearch, any metadata that contains this word
should appear. You can see the metadata details clicking on the button Description. Also, you can
load into the view any remote resource attached to the metadata clicking on the button Add Layer.
For example, go to the metadata called Populated places of Andalucia and add its WMS layer (Map).

Gazetteer
The Gazetteer service is a way of linking geographical coordinates and place names. gvSIG has a
gazetteer client in which you can search geographical keywords, and those places will be shown on the
gvSIG view.

1. On the same view used in the last exercise, click on the gazetteer icon (Finfing by gazetteer). A
connection dialog will appear (remember that the gazetteer icon will not appear until you load at
least one layer).
!gazetteer-button.png | align=center,width=32,height=32!

2. Connect to the server  http://localhost:8180/deegree/wfsg selecting the WFS-G protocol. 

http://localhost:8180/deegree/wfsg
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3. Type the keyword Sevilla and then click on Search. Two results will be displayed on the result pages.
Select the first one and click on Localize.

4. A red point will appear on the view centered on that place, showing the position and name of the
place.

5. Once the point is drew on the view, the rubber icon appears for erasing the place names added
before.

Access to PostGIS DataBase
gvSIG can access postgres table, as well as PostGIS layers that contain geographical (vector)
information.

In order to load a PostGIS layer you should do the following steps:

1. In the last view (or in a new one) go to View/Add layer/GeoBD and click on the button Add
Connection, on the right.

2. In the connection settings dialog, put these parameters:
a. Connection name: accesstest
b. Driver: PostGIS JDBC Driver
c. Server URL: localhost
d. Port: 5432
e. DB name: postgres
f. User: postgres
g. Password: postgres
h. Check the connected checkbox.
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3. Click the Accept button and you will see a list of available layers. Select the layer public.poblacion
and every field of that layer will appear on the right column. You could select one of those fields or
all of them. Select the field gid as the ID field and the field the_geom as the field that contains the
geometric field.
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4. Note that you can do another kind of selections, for example, setting a SQL restriction or an interest
area by extent.

5. After click the Accept button, the layer will be added to the view as another vector layer. This means
that you are able, for example, to change its symbology or open its table of attributes.
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OSGIS10 Editing

This page last changed on Jun 21, 2010 by jvhigon.

Duration 30 min

• Creating a new vector layer
• New shapefile from derived geometries
• Creating hiperlinks on vector layers.

Creating a new vector layer
In this excercise we are going to create a new vector layer from scratch on a new view.

1. Create a new view, you can call it Editing.
2. Load the raster image of the town center of Valencia  Centro_2002.jp2 It is on the folder data/

cartografia/Valencia.
3. Use the tool Center view to point  and the coordinates (X = 725704, Y = 4372413) to center the

view in the town hall of Valencia. Then set the graphical scale to 1:1000.
4. Go to View/New layer/New SHP to create a new vector layer
5. Select the type polygon and click on Next

6. We are going to add a new field with the name SoilUse and the data type (String) and length by
default.
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7. In the next window you have to select the name and route where the layer will be created on the
live DVD. For example, you can set CenterProject.shp as the name, and be careful to save it into /
home/ubuntu because it must be saved under a read and write folder. 

8. A new layer will be added to the TOC, on a red colour that means the layer is in edition mode (the
edition console must be on the bottom of the view and the new edition menus must appear). 

9. Put into active the new layer, and select the Polyline tool. Click on the view to define the first point
of the new polyline and then select each of the consecutive points in order to define a building's
base. In order to close the figure you can use the content menu's choice Close polyline or the C
letter in the edition console.
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10. The new polygon is standed out with the selection colour. You can add as many polygons as you
want, defining some groups of buildings. In order to define adjoining buildings you can use the
snapping tools. For this purpose, go to the content menu/Edit properties/Sanppings.

11. Probably, on edition mode, you will need to change one vertex defined previously. In order to do
this, go to the Select tool (editing tools) and then select the vertex you want to change and next on
the new position for that vertex.

12. If we made some kind of mistake, we can always click on the Undo/Redo arrows, and by opening
the command stack you will see a list of edition changes.

13. Another thing you will need to do is to fill in the attibutes table. To do that, first of all select on
the view the polygon you want to fill in, then open the table and type on the selected entry the
information you want to add, for example on the SoilUse field, you can add values like: Building,
GreenArea, Public place, etc. Close the atribute table when finished the table edition.

14. After all the geometries were drawn on the new layer and all the attributes were typed, it is needed
to close the editing mode, saving the changes done to the vector layer. This way, the layer name will
turn into black again (before it was in red).

15. As a next step, in order to see the differences between the soil uses, you can change the layer's
symbology through content menu/Properties/Symbols, choosing Categories/Unique Values and the
field SoilUse. Apply the changes, and Accept that window.

New shapefile from derived geometries
By this feature you are able to create a layer of lines from a polygon layer, for example. Let's see how it
works. 

1.  Add the layer puertos_andalucia.shp and municipios_andalucia.shp that is on the folder /cdrom/
data/cartografia/andalucia. Select the layer puertos_andalucia.shp.

2. Then go to the Layer/Crear SHP de geometrías derivadas (bear in mind that this tool will be avaiable
only in point and line shapefiles)

3. The original layer will be the one you have selected from the TOC, and then you will need to type
the new layer name such as distancia_puertos.shp that can be saved in /home/ubuntu

4. The geometry type choosen must be lines and the process selected should be points to lines. On
the next window you will see all the original features, and press Add all items if you want to add
all. If not, select the original features you want to derived, and then the plus button. If you want to
add or remove some axis, click on the plus or minus buttons, after selecting the features to want to
remove.

5.  Clicking on Generar will create the new layer, adding it to the current view above all the other
layers.

Creating hyperlinks on vector layers
It is possible to link text files, html, and pdf files to geometries that are on a vector layer. This feature in
gvSIG isa called Hyperlinks.

1. Add the layer  municipiosAndal.shp to the view and then apply Zoom to layer. We need to save a
new layer (from the one added to the view) on a read and write folder because it is needed to put
the layer into editing mode to add the hyperlinks. 

2. So, go to Layer/Export to /SHP and save the new file into the folder /home/ubuntu.
3. Then start editing mode on that new layer, open the attribute table and go to Table/Manage fields.

We are going to create 3 new fields: image_link, html_link, pdf_link, all of them from type String.
Each of those fields will be filled with the route to the file we want to link to. 

4. For example, we can link an image from Granada. In this case, the first thing is to identify the entry
of the table where we have to edit in order to add the link.

5. Open the attribute table, and the filter tool to identify NOMBRE = 'GRANADA' . After filtering this
entry, the polygon will remain selected on the view and on the table. Then go to this entry and type
  /cdrom/data/cartografia/Andalucia/granada (with no extension at all) on the field image_link .

6. The same way as before, we can identify the table entry for NOMBRE = 'SEVILLA' , then on the field
html_link write the url  of the Town Hall of Sevilla: http://www.sevilla.org/impe/sevilla/portada

7. Last, we are goingo to add a link to a pdf format file. We are going to add a file for routing Jaén,
writing  /cdrom/data/plantillas/ruta1.pdf

8. Once you have edited all the related entries, close the table and Finish the editing mode.
9. Now it's time to set the hyperlinks on the layer properties. Go throught the content menu to the

properties of the vector layer. Then click on the Hyperlink tab, and active the hyperlink.

http://www.s


Document generated by Confluence on Jun 24, 2010 16:21 Page 35

10. For the first kind of hyperlink (image), select the field where you had done it (image_link), write the
extension as jpg and choose the option Link to image files. Then click on the Add action, and set
the other two kind of hyperlinks (html_link and pdf_link). Accept hose changes on the properties
window.

11. At last, go to the view again, go to each of the the 3 entries (you can use the filter tool again):
Granada, Sevilla and Jaén and in each one click on the hyperlink tool and after that click on the
feature. You will be able to see the image, the web page and the pdf, each on a different window.

Note: if some of the file do not apear on the window, make sure you have edited the vector entry with
the right text.
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OSGIS10 Layouts

This page last changed on Jun 14, 2010 by jsanz.

8.Graphical output
8.1. Quick print tool

You can print a view semi-automatically with the tool called "quick print" (menu: View > Quick print).
There you'll find a window with a few options. A map will be automatically generated and will be sent to
the printer.

8.1.1. Create a view. Rename it to "Andalucia".
8.1.2. Open it and add the layer municipiosAndal.shp
8.1.3. Select the layer and configure the legend (right-click on the layer: Properties > Symbols) like this:
Categories > Unique values > Classification field = "PROVINCIAS".
8.1.4. Go to menu View > Quick print and set the following paremeters: Formats = A4, Orientation =
Horizontal, Title = "Andalusian municipalities", Show legend = ok, Show grid = ok, Image = by default.
Then, click on Preview. The new map will be generated. If it's ok we could print it or export it as a PDF.

8.2. Making a map

We can create a completely new map or we can use a template created before.

8.2.1. Load the template called Plantilla4.gvt (menu: File > Open template).

Adding a view.

8.2.2. Insert the view "Andalucia" in the bigger rectagle (menu: Map > Insert > View).
8.2.3. Adding a grid to the view. Select the view, right-click on it and select Properties. Select Show grid
and click on Configure. There you can set the parameters: interval, symbol and font.
8.2.4. Setting the view scale. Within the view properties dialog we can select three types of scales:
Automatic, Maintain view scale and Specified by user. Apart from that we can do zoom and pan on the
view in order to get the desired aspect (zoom in, zoom out and pan view frame buttons). Notice that the
view must be selected.
8.2.5. Rotating the view. Select the view,  right-click on Properties and input the degrees manually or
clicking on the arrows.

Adding a legend.

8.2.6. Go to Menu: Map > Insert > Legend. Drag and drop the mouse over the area you want to place
the legend. There you must select the view and the layers whose legends you want to show.
8.2.7. To modify the legend elements select the legend and go to menu: Map > Graphics > Simplify
legend.

Adding other map elements.

8.2.8. Scale. To add a scale go to menu Map > Insert > Scale. Then drag and drop over the area you
want to place the scale and set the parameters. Notice that the scale is dinamic: if we change the scale
view, the scale symbol will be updated automatically.
8.2.9. North symbol. To add a north symbol go to menu > Map > Insert > North. Then drag and drop
over the area you want to place the north, choose one of the showed symbols and select the view the
north must be linked with. Notice that the north orientation is dinamic: if we rotate the view, the north
will be updated automatically.
8.2.10. Locator. To add a locator go to menu Map > Insert > Locator. Then drag and drop over the area
you want to place it and set the required parameters.
8.2.11. You can add other elements like text, rectangles, lines or images.
8.2.12. You can group, ungroup, align, place back and bring to front all the elements (menu Map >
Graphics >...).

8.3. Printing the map

8.3.1. To print the map go to menu Map > Print. The print dialog will appear.
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8.3.2. Instead of printing the map you can export it to a PDF or PS (PostScript) file (menu File > Export
to...).
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