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OSGIS 2010 gvSIG Workshop

This page last changed on Jun 19, 2010 by jsanz.

OSais

OFEN SOURCE GEOSPATIAL

Welcome

This is the OSGIS 2010 gvSIG workshop main
page. Below this page you'll find the handout of
the proposed exercises.

Contents of the workshop

OSGIS10 PART I Introduction

* OSGIS10 Setting up the LiveDVD
» OSGIS10 Brief introduction to the project

Lecturers gvSIG
OSGIS10 PART 1I gvSIG as Desktop
| Name | organization |  e-mail and SDI client

Amelia del Rey gvSIG

adelrey@gvsig.com

Association -

Prodevelop

José Vicente gvSIG

jvhigon@gvsig.com «

« OSGIS10 Structure and configuration of a
project in gvSIG
OSGIS10 Visualization of data

Association
- Software
Colaborativo

gvSIG

Higdn

Jorge Sanz jsanz@gvsig.com

Association -
Prodevelop

Workshop URL

This workshop is accessible at

http://tinyurl.com/gvsig-0sgis10

Surveys

Please, consider filling up these surveys. Getting
this valuable feedback help us a lot to improve our
workshops.

» Before the workshop survey
« After the workshop survey

These links will work only during the OSGIS
event

LiveDVD

This workshop is intended to be done using
the gvSIG LiveDVD that will be provided to any
attendant of the OSGIS 2010 event.

(@ If you didn't attend the conference, you'll be
able to download the DVD image from the
gvSIG portal page.
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* OSGIS10 Selections and tables

e OSGIS10 Visualization and query of remote
data

» OSGIS10 Editing

* OSGIS10 Layouts

* OSGIS10 Appendix

OSGIS10 PART III gvSIG Mobile

* OSGIS10 Brief introduction to gvSIG Mobile

0.3

OSGIS10 Installation and requirements

OSGIS10 Download of gvSIG 0.3

OSGIS10 Description of the exercise

OSGIS10 Exportation of data from a gvSIG

Project into the PDA

* OSGIS10 Configuration of the device and
project

 OSGIS10 Visualization of local and remote
data

* OSGIS10 Obtaining and Searching
information, making measures

 OSGIS10 Editing a vector layer by using XML
files

» OSGIS10 Export data

» OSGIS10 Thematic maps generation

0OSGIS10 Internal

OSGIS10 Workshop license

Handout

You can print a handout of this workshop, but you
should realize that this is a live space and the
handout could be a little bit outdated, check the
dates of the document.
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date | file
17th of June of 2010 workshop-export.pdf

Workshop license

Este material se distribuye bajo una licencia Creative Commons Atribucidn-No comercial-Compartir igual

All these materials are provided to you under a Creative Commons license Attribution-Non Commercial-
Share Alike

Cannot resolve external resource into attachment.
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OSGIS10 Setting up the LiveDVD

This page last changed on Jun 15, 2010 by jsanz.

Minimum requirements.

 Intel-compatible CPU (i486 or later)

e Minimum RAM: 256 MB, Recommended: 512 MB or more

« DVD reader with autorun (IDE/ATAPI, Firewire, USB or SCSI)
* SVGA-compatible graphics board

Starting the gvSIG LiveDVD

* Make sure the BIOS allows OS start from the Live-DVD.

» Insert the Live-DVD in the DVD reader and restart the computer.

« When the first screen appears, select Try Xubuntu without any change to your computer and press
Enter.

423 xubuntu

Try ¥ubunfu wlthowt any change to your computer

@ PressF2to change the language, and F3 to change the keyboard. Press F1 to obtain more
help.
« After a few moments the gvSIG LiveDVD Desktop should appear
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Setting up the University Proxy

]

The Nottingham laboratory has a web proxy so you need to set it up on the LiveDVD web browser

(Mozilla Firefox)

* Open Firefox browser

* Go to Edit->Preferences->Advanced Section->Network tab->Connection Settings button:

File _Edit_\ﬂew History Bookmarks Tools FE

Undo Ctrl+Z
ﬁ art.

Redo Ctri+Shift+Z2

M

B cut ctri+x [°St

Copy Ctri+C

Paste Ctri+wv

Delete Del

(5] select an Ctrl+A

') Find Ctrl+F

Find Again Ctrl+G

Switch Text Direction Ctrl+Shift+X

#®| Preferences N
\Walrarma ta | lhintin 2 NA

I ="T. -

Main  Tabs Content Applications

Privacy Security BEGIEglH=Te!

General | Network | Update | Encryption

Connection

Configure how Firefox connects to the Internet

Offline Storage

[

[, [ - Y Y T R

8L settings....

[

* Add the url http:// mai nproxy. notti ngham ac. uk and the 8080 port to the HTTP proxy section:
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http://mainproxy.nottingham.ac.uk

Configure Proxies to Access the Internet -
) No proxy
) Auto-detect proxy settings for this network
) Use system proxy settings

® Manual proxy configuration: |

| HTTP Proxy: | proxynottingham. ac. uk| Port: mﬂ

[ Use this proxy server for all protocaols

SSL Proxy | - Port: | ol
! —  T.1

* Now you should be able to navigate on the Internet
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OSGIS10 Brief introduction to the project gvSIG

This page last changed on Jun 18, 2010 by jsanz.

gvSIG is a tool oriented to manage geographic information. It is characterized by a user-friendly
interface, with a quick access to the most usual raster and vector formats. In the same view it includes
local as well as remote data (for example WMS, WCS or WFS source).

It is aimed at users of geographic information, whether professionals or civil servants (city councils,
councils, regional councils or ministries) from any part of the world (at the moment its interface is in
more than 20 languages, in addition to being free.

Given its Free Software nature (open source) it is highly interesting for the international community

of developers and, in particular, for university settings due to its R&D&I component. In fact, special
emphasis has been placed on the expansion of the project so that potential developers can easily expand
the functions of the application, as well as develop completely new applications from the libraries used in
gvSIG (as long as they comply with the GPL license).

gvSIG Desktop is a desktop application designed for capturing, storing, handling, analyzing and
deploying any kind of referenced geographic information in order to solve complex management and
planning problems. gvSIG is known for having a user-friendly interface, being able to access the most
common formats, both vector and raster ones. It features a wide range of tools for working with
geographic-like information (query tools, layout creation, geoprocessing, networks, etc.), which turns
gvSIG into the ideal tool for users working in the land realm.

gvSIG Mobile is a Geographic Information System (GIS) aimed at mobile devices, ideal for projects
that capture and update data in the field. It's known for having a user-friendly interface, being able to
access the most common formats and a wide range of GIS and GPS tools which are ideal for working
with geographic information. gvSIG Mobile aims at broadening gvSIG Desktop execution platforms to

a range of mobile devices, in order to give an answer to the needings of a growing number of mobile
solutions users, who wish to use a GIS on different types of devices. So far, gvSIG Mobile is a Geographic
Information System, as well as a Spatial Data Infrastructures client for mobile devices. Such a client is
also the first one licensed under open source.

Slides

The gvSIG introduction slides can be viewed online here

(=] The slides are in SVG format and must be viewed using Firefox 3.0 or newer

Interesting links

» gvSIG community portal
° User docs
° gvSIG mailing lists
» gvSIG association
* OSOR.eu portal
° gvSIG Desktop

° gvSIG Mobile
» OSGeo Foundation

° gvSIG Incubation status
° OSGeo Live
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OSGIS10 Structure and configuration of a project in gvSIG

This page last changed on Jun 18, 2010 by jsanz.

gvSIG application works with projects, with .gvp extension.

Every project can contain three different documents:

Views: where the cartography is loaded as different layers.

Tables: attribute tables attached to every vector layer loaded in a view.

Maps: layouts where views (with north arrows, legend...) can be added to be printed or exported to
a pdf file.

When gvSIG is opened, the Project manager window appears directly, and different views, tables and
maps can be created from it.

gvsIG 1.9:Untitled

File  Show  Sh

alom  Window Help H

|BAY=22)

{i# Project manager

Docurment type

5

Yiew
ey
Session
Mame: Untitled
Sawved as:
Creation date: Jun 18, 2010
Properties...

i Application started.

Preferences configuration

From the Windows->Preferences menu:

Editing: To change the configuration when editing tools are used.
Maps: To activate grid and ruler in a Map.
Symbology: To change the symbology by default.
° Change Default fill color to Aleatory
Cartography: To change measure units
View: To change default projection for the views, zoom factor, view back color, selection color, map
units...
View->Layer loading order: To change the order of the loaded layers.
Network->Firewall/Proxy: To select the Proxy configuration when we have internet through a proxy.
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« General->Language: To change to another language, install a new one or an update, or export to a
file to translate to a new language.

Preferences...
----- Annotations
----- Cartography -
----- Default DBF encoding Editing
----- Editing
F+General
pearance Adjust color and opacity of markings:

~Default directories
- Extensions

rSelection color

—Extensions directory Fill | m E Opacity
~Language
SCrREN
- Skin rReference axis color
Wb browser Fill: ’—E Opacity
..... Map
- Metwork,
----- Raster ~Selection rectangle color
..... S\y,mbnlogv . . —
S viewr Fill: D Oparity =k

rSelection handle color

Fill: ]—E outline | m [] Opacity

Festore option defaults]
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OSGIS10 Visualization of data

This page last changed on Jun 19, 2010 by jsanz.
Contents

Error formatting macro: toc: java.lang.NullPointerException

Create a view and add a shapefile

+ Add a new View and open it: From the Project manager, press New, select the new View, and press
Open.
« A View has three different elements:
° Geographic View: Where the vector and raster layers are loaded graphically.
° Table of contents (TOC): Layers loaded in the Geographic View. The order of the layers is the
same than their visualization in the Geographic View.
° Locator: An easy way to navigate on the View.
» View->Add layer menu, and add esp_provincias.shp file from the / dat a/ car t ogr aphy/ Spai n/
folder.

S Whew prapeilies i}
Hure ks - 0
Cresion due JIAFLD 1745 P
v
Hiz il eI -
HERD TS WP CLL =

e Mptpr -
Caffend @rogcsee.  EFIC 23030

CErmmeTn

Bk [ler

= Carvisd

p-at

Navigation on the View

Basic tools

& Tip
To change the layer symbology, you should click on the Properties button and then close the locator

dialo
Y S

AwE LR RO AR A RGE TE] BaE N & R

|—|—

» Locator:
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View->Configure locator map menu
° Add layer: esp_localizador.shp
e Zoom to layer:

° Add layers to the View: Centro_2002.jp2 and Puerto_1980.ecw at / dat a/ cart ogr aphy/

Val enci a/ folder..

° Select the layer Centro_2002.jp2 and right-click on it; then Zoom to layer to navigate to the

layer extent

{4 View: Untitled - 0
.[w] % Puerto_1980.ecw J
#7 Centro_2002.jp2
.. ESp Rename...

Zoom to layer

Zoom to 1:1 resolution

Delete
Reload

Show errars

e Zoom manager (1):

Add layer: parcelas_Valencia.shp from the same folder
° Zoom to a little area of the Valencia's port.
View->Navigation->Zoom manager menu; save the current zoom as Port

[0 0 G eiang rasd FOm& @ k WIS ha
'

B
[ — -
[ P—

[y

T T

l
I
o |
!
|

* Center view to a point:
° Add layer: Puerto_2002.ecw
° View->Center view to point menu:
- X: 725830
- Y: 4372060
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G View: Untitled - 0

[v] ¥ Puerto_2002.ecw :

|:| M parcelas_Yalencia. sh
(] %7 Puerto_1980.ecw

(] ¥ Centro_2002. jp2 ¥ |725830

v 4272060

(] M esp_provincias. shp

« Zoom manager (2):

° View->Navigation->Zoom manager menu; select the Port zoom and press Select.

Areas and distances

* Over the view, Areas and Distances can be measured (from View->Query).
* Try to measure the area and maximum longitude of the Valencia City Hall Square

(x=725800,y=4372432)

0 e lied B
= 1= J i e ¢
Fabc, 1002 Bow T . :
Rl DR T
= fmine 15 o = e
0 e il md wd2H e [, CF.
8 e vt 1 |

Locate by attribute

« Another way to navigate on the view is with the Locate by attribute tool, where a zoom can be done

to an element of a layer, selecting the field of the layer and the value of the associated table.

* Go to the View->Locate by attribute menu.
e Select the following values:

° Layer: esp_provincias.shp

° Field: NOMBRE99

° Value: Valencia

{# Locate by attribute...

Laver: ’ESp_prDMHciaS.shp

Field: [NOMERES9 -|
Salue: "u’alentia S waldncia v]

|| Show an apening wiew

’ 200 ] ’ Exit
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Scale of a view

» The scale of a view can be modified from the scale bar. Default scale values can be selected, or a
value can be written by keyboard.

1

N A

200,000 -

" |500,000 o

;ﬂ.-'f‘ 1,000,000 |

2,000,000 B

5,000,000 -
1:/5.000,000 v |Met:

Styling
Transparency of a raster image

On the same view, keep only visible Puerto_2002.ecw and Puerto_1980.ecw layers, and
Puerto_2002.ecw as active layer.

e Press right button on the active layer, and then Raster properties (1). You'll see an overview of
raster characteristics(2).

» Select Transparency tab.

» Active Opacity, and select a 35% of transparency. The differencies of the port between 1980 and
2002 are shown on the view(3).

8 Wi : Ueinled - 0 e ees
P PN T L s
=15 ul Hename .

e T 1 layer —
Teom te 1] rezeleton e
® pa -
Belrie
B es
LT
Mrve to bap
e
| masterprperies | —
o -
Lt}

.ﬂ Extension

« Play with the bands switchers to change the colour assignment. This could be more
interesting if you add to a new view the raster file / dat a/ cart ogr aphy/ Ur uguay/ r ast er/
RecorteBl10 _B70.tif.

e Try to remove the grey colour of the / dat a/ car t ogr aphy/ Andal uci a/ rel i eve_andal uci a. j pg
raster file activating the per-pixel transparency and using the small Pick RGB from view helper.
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fr=rTrr

Legends and basic symbology

& tip
You can change one symbol double-clicking on the TOC symbol preview

/| M esp_provindias.shp |~

----- Albacete

----- [ | alicante falacant
----- B imerDa

----- B :sturias

----- B Eadajoz

----- B Ealears (lles)

» Properties of the layer: Double-click on the esp_provi nci as. shp layer in the TOC.

« Select Symbology tab, then Categories->Unique values; change Classification field to NOMBRE99;
press Add all and Accept.

« Modifying symbology of a polygon:
° Access to the Properties of the layer again; select on the Albacete symbol (with double-click)
° Press Choose symbol, and change Fill color, Border color...

Q Extension

- Try to apply the Expressions category legend to show witch provinces of Spain are bigger than
1710 square meters.

« Enter on the properties of the symbol and experiment with the polygon symbology options like
using a line fill, modifying the outline, etc.
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Lok ot

Legend by intervals

« Do a copy of the first View: Project Manager->View, and right mouse button on the first View. Select
Copy, then left mouse button and Paste. Write a new name.
 Properties->Symbols of the esp_provincias.shp layer.
» Select Quantities->Intervals, and the following values:
° Field AREA
° Equal intervals
° Begin colour: White
° Number of intervals: 25
» Press Compute intervals, and then Accept.

e ]

Labelling

» Access to the Properties of the esp_provi nci as. shp layer, then the Labelling tab
. SeIect Enable labelling, and the following values:
General: Settings from attributes field
° Field to be labeled: NOMBRE99
° Fixed height: 10
° Units: pixels, and In the world
° Fixed color: Black
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(i) Extension
The new advanced labelling features of gvSIG are out of the scope of this workshop but you can
check the documentation (sorry, at this time only in Spanish) or check the last gvSIG Conference
workshop video on new features of gvSIG 1.9 (translated in English) (minute 20:22).

Predefined legend

gvSIG has its own legend file format (. gvl ) that supports all the gvSIG features.

» Create a new view, called Andalucial.

¢ Add new layers: nuni ci pi osAndal . shp, hi dro_andal uci a. shp and ferrocarril Andal . shp
(Reference system: 23030).

« Keep as visible layers nuni ci pi osAndal . shp and hi dr o_andal uci a. shp

» Access to the Properties menu of the {{hidro_andalucia.shp* layer, and then Symbols tab.

e Press Load legend and load the j er ar qui a. gvl file (from the Andal uci a folder).

A created legend can be exported to a symbology interchange format (. sl d). It can be used to share
legends with other programs, but if it's used in gvSIG, some characteristics can disappear.

« Access to Properties->Symbols of the muni ci pi osAndal . shp layer.
» Create a new symbology (Cathegories->Unique values), by the field PROVI NCl AS. Then press Save
Legend, and save it as a . sl d file.

Layer tools

Vector layer reprojection

¢ Add new layer: esp_4326.shp (with the Current projection by default: 23030).
« After a Zoom to the new layer, we see that the coordinates of the new layer aren't correct.
» Delete the last layer.
e Add new layer: esp_4326.shp , but changing the Current projection (1)

° Type: EPSG

° By code: 4326 (and press Enter)

° Select transformation: EPSG Transformation, and press Next. (1)

° Transformation: 1633 (Spain-mainland...), and press Finalize. (2)

° Finish the setting up and accept the warning, you should see the Spain shapefile well

transformed over the rest of the layers.

1 | 2

Add event layer

A layer of points can be added in a view from an alphanumeric table with coordinates.
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Firstly, the table has to be added to the project:

» From the Project manager, select Table document, then New and finally Add.
e Select XY_nmun. dbf file at/dat a/ cart ogr aphy/ Val enci a/ folder (1)
« In the last view, go to the View->Add event layer menu (2) and select the following values :

Table X | Y
XY_rmun. dbf XUTM YUTM
* Press OK, you should see a new point layer at gvSIG with the centroids of the Valencian region
municipalities(3).

1 2 3

Flie .nm\-|'|l'hu Layer Tabie Shalom ‘wind

0 B H| & & Ceoprocessing toots 1

& Eljespg  SueTY L
S Wz L Selection ]
*pg  Quick print-out |

Expart 1o b
E: Center wew an poim

18, Locare by aribune.
3 = Pe

& Py

- A points fegm rabee

v Bl hewimer b |
& i sl @ Aok kaver A0
Havigation k

S Ier as U

Configure locaior

Froperties

Remember
An event layer at gvSIG is just a graphical representation of an alphanumeric table, so no real data
has been converted on this process

Export data

Export the view to an image

A view can be exported to an image file without georeferencing. This is useful to add the view in
documents, presentations, etc.

» Access to the View->Export->Image menu and save our current view.
Exporting layers

Last exercise was a simple image export, to do a real conversion of vectorial data you should us the
Export tools. As the event layer is only a virtual layer, to obtain a real layer it must be exported to a
shapefile format for example.

< Having an active layer, if there are several elements selected on it, only those features will be
exported. If there aren't any element selected, all the layer features will be exported to a new one.
» It can be done from the Layer -> Export to -> SHP menu.
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OSGIS10 Selections and tables

This page last changed on Jun 19, 2010 by jsanz.

Contents

Error formatting macro: toc: java.lang.NullPointerException
Selecting tools

Basic tools

Create a new View and assure it's in EPSG:23030.

« Add the nuni ci pi osAndal . shp layer from / dat a/ car t ogr aphy/ Andal uci a folder.
. The following selecting tools can be used in gvSIG (from the View->Selection menu):
Select by point (press "Ctrl" for multiple selection)
° Select by rectangle
° Select by polygon*
° Select by polyline*
° Select by circle

* (double-click to end)

| Selection tools menu | Selection toolbar
File  Show | Wiew Layer Table Shalom  Window  Help —
0 ¥ H | &[# Geoprocessing taols... @ | k |% % E '-';-.:S?"' .4 q D |
G View : U Query [ = B —
= Selection » q Select by circle - —H '-'a m ]

=-[v] M m

& Select by pohdine
Export to b | Select by buffer zone
@ select all

k Select by point

Quick print-out...

F Certer view on paint

Q Locate by attribute
MNew |ayer » i Select by rectangle

& Add layer Al-o |Gy Select by pohgon
MNawigation » Spatial selection

Set layer as »

c§? mven selecunn
Configure locator.

Froperties
T T

Select by buffer of distance

Other type of selection is the Select by buffer zone. This tool need a previous selection and doing a buffer
over the selected features it increases it.

+ Remove any previous selection with the Clear selection tool (from the toolbar)

« Activate the nmuni ci pi osAndal . shp layer, and select a feature with the Select by point tool (1).

» Go to View->Selection->Select by buffer zone

» Write 120.00 m. (this in fact means 12000m, see side note)

» In the Options area, activate Add buffer zone layers, and press OK (2).

» The selection will be performed, a new vector layer with the buffer calculated will be added and
finally a dialog with the details of the process will appear (3).

.@ Bug!
There's a bug on this gvSIG version, you should write your distance taking in account the decimals
as normal zeros, so to ask for 12000 meters you have to write 120. 00. A bug ticket with this issue

has been reported on the official gvSIG Desktop bugtracker.
| 1 2 3
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Selection by attributes

Instead of using graphical tools you can also do a selection based on attribute table values.

« Remove any previous selection with the Clear selection tool (from the toolbar)
e Add theferrocarril Andal . shp to your view

« Activate the layer: ferrocarril Andal . shp

» Access to the Table->Filter menu

» Select the query "COD_ENT" = "V10", and press New set.

e ey SP—— -

& Tip
You can concatenate several selections adding or subtracting features from the current selection set.

Spatial select

You can do a more complex selection based on spatial topological rules. On this example will select all the
municipalities touched by the last railway selected.

« Activate muni ci pi osAndal . shp layer
» Go to View->Selection->Selection by layer
« Do the following query:
° _Select items from active layers that are...
- Intersected with
° Selected items of a layer
- ferrocarril Andal . shp
* Press New set

| el <! IR,

;—u’""f

& Tip
You can concatenate several selections adding or subtracting features from the current selection set.
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Exploring attribute tables

gvSIG has several features in order to let the user explore and navigate over the attribute table
associated with many vectorial data formats.

e o o o o

Activate nmuni ci pi osAndal . shp (there were several selected elements of the previous exercise)
Open its attribute table (from Layer->See table of attributes)
Move selected elements to top (1)
Select the complementary elements (2)
Go to the selected elements directly (3)

File Show  Wiew Layer Takle Field Zhalom  Window #Help
e H<fbe BRESHECTE
II@- Tahle: At ute table: municipiosAndal.shp :_:

Copico | MOMEBRE | 1 PROWINCIA
1400l ADAMUE CORDOEBA, = |
14005 AlMOoDOV AR DEL RO CORDOBA, B
14020 COMOUIET A CORDOBA,
14021 CORDOBA CORDOEBA,
14036 HOREMACHUELDS CORDOEA,
140432 M OMT QRO CORDOBA, E
140445 Palma DEL RO CORDOEBA, N
140532 POSADAS CORDOBA, g
14067 WILLAFREAMCA DE CORDOBA CORDOBA, a
l40es WILLAMUEY A DE CORDOEA CORDOEBA,
41006 ALCOLEA DEL EOO SEVILLA }
41018 BEEMES SEVILLA
41023 CANTILLAM.A SEVILLA iy
41024 AR M O A, SEVILLA
41055 LOEA DEL EOO SEVILLA
41074 PEOAFLOFR SEVILLA E
41081 Lé RIMCOMNADA SEVILLA ¢
41091 SEWILLA SEVILLA
41095 WILLAMUEY A DEL EOO Y MIRAS SEVILLA -
Qoool CASTILLA- LA W ANCHA CASTILLA- LA MAMNCHA,
Qoo CEUT A CEUTA
QOQ0E ExXTREEM.ADURA EXTREEMADURA,
Qooog CIBFALT AR, GIERALT AR,
QOQ0s M AR MEDITEREOMNED MAR MEDITEREOMED =
12 7 778 Total records selected.
Information tools
Information of the elements can be consulted with two different tools: Information, and Quick info.

» Access to View->Query->Information, and click on an element of the nuni ci pi osAndal . shp layer
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» Activate ferrocarril Andal . shp

» Access to View->Query->Quick info

e Select the ferrocarril Andal . shp layer, activate the field COD_ENT, and select the Lengt h calculated
field. After accepting, if the mouse is on an element of the layer, its information is shown directly.
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Table tools

Table summarize

This tool gets statistics of field values grouping the data by one of their attributes.

« Add hi dr o_andal uci a. shp, activate it and open its attribute table
» Open the Table summarize tool (from the toolbar) (1)

e The group will be done by the field JERARQUI A

» Then select from the field LENGTH the Minimum, Maximum and Sum
» Save as a new dbf file, for example / t np/ summari ze. dbf (2)

» This new table is added to the gvSIG project (3)

| 1 2 | 3

lom  Window  Help

Tow rarorch o

3 HZz ROo ZOjar

- e oY

Joining tables

On this exercise you will join an external comma separated file (. csv) with data coming from the Spanish
National Institute of Statistics with the Spanish provinces layer.

i Note
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For a correct import of a CSV file you should use semicolon (; ) to separate your fields and use the
dot (.) as a decimal separator.

Go to the Project Manager, and then Table

Press New, and then Add

Add Pobl aci onl NE. csv from the / dat a/ car t ogr aphy/ Spai n/ folder

On a new View add esp_provi nci as. shp

Open the attribute table of this layer

Go to Table->Join.

Select esp_provi nci as. shp, field DPROV, a prov prefix and Next (1).

Then Pobl aci onl NE. csv, field CODI GO, a i ne prefix and Finish (2)

* You'll get a joined table with the prefixes set up to identify the table where they come from (3)

1 2 | 3 |

L] =
Sourie Ladle Sefmilien Targes Lable orfisition
AurCE Nt stribune (abi @ prowanas thp - Tangn rab i kit oniHE o
Fimlca joizan  |peRgw - M (o e o0 [oaggn

Foedi prefa e Finid prafis

i, You can remove a table join using the Table->Remove joins menu entry.

Import fields

The previous exercise doesn't modify the layer with the table joined. On this exercise we will do a similar
task but writing the imported fields so the first thing we need to do is to copy the shapefile where we can
modify it.

Go to an explorer and copy the 5 files of the esp_provi nci as layer to the folder / home/ ubunt u (1).
Open it in a new View, and open its table

Go to Table->Import fields

Select the following values: Table: esp_provi nci as. shp, Link field: DPROV, Table to import:

Pobl aci onl NE. csv, Link field: codi go, and then Next (2)

« Select the fields Nonbr e, Tot al , Honbr es and Mij er es, and then Finish (3)

1 2 | 3

i, Using the selection tools now you can check witch features of the provinces shapefile have no values
on the statistics fields and see that their DPROV value maybe it's not so good...

Export table

This feature let you export any table to DBF} or M crosoft Excel format ({{.xls).
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Table encoding

As you probably have noticed, the provinces shapefile shows some strange characters on the name field.
This is because the character enconding is not well set. The Shalom extension let the user to manually set
the encoding for dbf files.

Close gvSIG

Repeat the copy of the shapefile esp_provi nci as to your home folder (/ hone/ ubunt u)

Open gvSIG

Open the gable esp_provi nci as. dbf , you'll see strange characters at NOVBRE99 field

Assign the CP1252 enconding using Shalom->Set Encoding to dbf files

Delete the table from your gvSIG project

» Create new View and add esp_provi nci pas. dbf . If you apply a labelling by the NOVBRE99 field
you'll be able to see the correct characters with accents, apostrophes, etc.

| Before | After

1| NOMERESS 4_ID | NOMBRESS | SHAPE.

 Coruda A Corufia (&) 10325
CuipOzcoa Cuiplzcoa 28427
425 08
Cantabria Cantabria 21810,
LeOn Ledn 82144
Burgos Burgos 99463!
Falencia Falencia BL0ES5
Wizraya Wizcaya IG2ES.
Prntewerra Drmtrnrmddra G5 T
5 L - 9 k | - = B
Ll i ] e ¢ Barg s 117 - Sona I'-lru;uu : = o
FLTHY Taragarn, L jegavia Tarragana
J ey | qumll,url e
Illurlélbu"l_ I.J Tenal it N ’.'l:lvlllﬂln i Casneld
Cammllin  Cantwll - - lotads Cugrca dul
i Cusrcs == ! Valamsia / Valsnc
Wathrich } Vil incia bt Faal dlbacaia
Blicants [ Blacarn
el Aal atue - o Jwdn Murcia
alicants | Rlacuns
Jatn f Marcia st
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OSGIS10 Visualization and query of remote data

This page last changed on Jun 17, 2010 by jvhigon.

Proxy Settings

First of all, if a proxy is needed to connect internet you will have to change gvSIG settings. Go to Window
> Network --> Firewall/Proxy and set your proxy parameters.

> Preferences ...

[

(=™

[

Annotations
Cartography

Default DBEF encading
Editing

Ceneral

Metwork,
“-Firewallfproxy

Swmbology
=

Preferences...

Firewall { proxy

Use HTTP proxy serner

HTTP proxy senver:
HTTP proxy port:
User name:
Passwaord:

Connect directhyto:

http:j,fmainproxv.nottingharr

8080

[ Use SOCKS praoxy server
SOCKS proxy haost:
SOCKS proxy port:

WMS - Web Map Service

On a gvSIG view we can have both kind of data: local and remote (WMS, WFS, WCS).

1. Copy the view VISTA1 that already exists (on the Project Manager). We are going to add a WMS
layer on this view.

2. Keep as active only the layer Centro_2002.jp2

3. Go to View --> Add Layer... and click on the WMS tab. Put the url: http://localhost/mapserver/
wms* and click Connect. The service description should appear.
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e Add'layer... e
File ', GeoDE | WCS ' WMS | ArcIMS | WFS | Annotation |

rServer

|http:Hlncalhnst,fmapsemerjwms [v]

[ Refresh cache

rDescription

Mame:

Fegional Ministry of Pullic Waorkes and Transpartation. Regional Government of
Andalucia
(http:jfwww.jumadeandalucia.eQﬂbraspublicaswranspor‘tes,fmﬁ.-w,fjsp,festatic
a.jspfct=8&pmsa=7&e=cantografia/descargasfdescarga_datos. es. html).
Characteristics: railways, municipalities, hydrology urban areas and elewation
of Ahdalucia.

Servertype: WMS L1L1 Prewious | [ Mext

f - | g— al

4. Click on Next button, go to the tab Layers and select the layer Constructions in Valencia, then click
on button Add. Select format .png and SRS 23030.The layer will be added to the TOC on the view.

5. Change the opacity of the layers doing right click on the name of the layer and selecting Raster
properties. Select the tab Transparency and active the opacity to see the orthophoto below (use the
slide bar for selecting an opacity percentage).

6. Select the Information tool and click on one of the geometries of the vector layer. A window will
show only the queryable attributes. For example, you could find out what is the composition of any
building seeing the attribute called constru.

gvSIG 1. 9:Untitled

File Show ‘iew Layer Shalom  Window  Help

DpHeaasEcsd0@e=ag0aG o=
& B WMS layer -
@ View : Untitled - 0

WMS layer

Above ground
Below ground
Green area

I Suinning pools

Soil
0thers {not recogni:
*7 Centro_2002.jp2

FiE

[»]

) i >
! @# Identify results B}
WMS layer [ runicipio Adtribute Valug |
! [ masa
P
-7 tipo
-] parcela
[ constru
N [»]
|
i 116,968 >||Meters [ =726,486.98 [f=4,371,925.34 [EPSGC.23030
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7. Load another WMS layer, this time from Catastro (you must have internet connection). Its url
is _http://ovc.catastro.meh.es/Cartografia/WMS/ServidorWMS.aspx_ . Select the layer called
Catastro , the .png format and SRS 23030.

8. If you click with the Information tool into one plot, a window will open showing the cadastrial
reference of that plot. This link is useful in order to see the public information related to this plot
published on the cadastrial web pages .

9. Another use we can make from a WMS is to compare 2 different layers from the same extent but
different period of time. Connect again to http://localhost/mapserver/wms* , select the layer
Harbour from Valencia, years 1980 and 2002 and click on Add. Go to the tab called Dimension
and select and specific date (for example 1980 first).

Add layer...

File ', GeoDB | WCS " WMS | ArcIMS | WFS | Annotation |

Information ', Layers ' 5tyies * Dimensions ‘\ Format ',
Dimension
Settings

TIME in 508601 1280

Settings editor
TIME Yalue: 1580

= —
LIR]] 1/2 (LaL:)
(I Single walue

() Multiple walue

() Interyal
| add || Clear |

1980 |

| Sett|

Servertype: WMS L1L1 | Prewvious | | Mext

10. In order to see differences between two periods of time, load the same layer on a different time and
change its opacity (70 percent for example).

WMC - Web Map Context

Once you have a WMS layer added, you are able to export a WMC file (.cm/ format) that allows you to
save the local settings of your WMS layers added to the view (layers, zooms, extent).

1. You should have a WMS layer on the TOC (if not, add one to the view), click on the tool Center
view to point and type the coordinates X = 726300 and Y = 4372900. Once the view has been
centered on this coordinates and a red marker appears on it, change the scale on the state bar to
1:1000.
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2. The next step will be to save the view state as a WMC file. To do that go to View/Export/Web
Map Context... and select a view, a title, an identifier and a file to save it. It is important to save
the file in a location with permissions like /home/ubuntu. Finally, choose the option Defined by the
view's extent .

\..} Web Map Context properties

o H

Options
Frojectyiew: |Llntitled -0 "'|
Title:: |mytitle |
ID: [ myid |
File: |Ih0me,fubuntu,fmywmc.cml || Choose. .. |
Warsion: |110—'|

Extent; () Defined by the view's axtent R

(3) Use full extent [} |M|
| Ok || Cancel |
T W T AR TEFT T B T L

Now, the other way round: import WMC files.

1. Create a new view and go to File/Import/Web Map Context in order to select and load the WMC

file. The new view should have the same WMS layers (and properties) and extent that the original
one. The same could be done if you import that WMC file in another computer.

WFS - Web Feature Service

The WFS service allows you to work with vectorial layers loaded from a remote service. The information is
retrieved in GML format.

1. Create a new view where the WFS layer will be added. Connect to htip: //localhost/geoserver/wfs

and select the feature type Railway lines of Andalucia (linear layer). Select all the attributes
on the Field tab. On the Option tab do not change the value of Max. features (1000 by default).
Finally, keep the default settings for Options, Filter and Area.
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Add'layer...

File ', GeoDB ', WCS |, WMS ', ArclMS ' WFS |, Annotation |

Informmation * Layers | Fields |, Options | Filer |, Area |

Layer name
Railway lines of Andalucia |

Layer selection

Layer name Ceometry tyioe |
Foads of Andalucia &=
Canstructions in Yalencia
Hydrology of Andalucia

Municipalities of Andalucia

gazetiear

Urban areas of Andalucia

Faibaay lines of Andalucia Multiline
archsites_Type

hugsites_Tyvpe

restricted _Tywpe

roads_Tywpe

streams_Tywpe

diant_palkygon_Type 5]
poi_Type
poky_landmarks_Twpoe
tiger_roads_Tywpe

54 Population 4
[] Show datasource names h
Servertype: WFS 1.0.0 | Prewioys | | Mext |
| (0]4 | | Canceal |

2. After the wizard is completed, a vector layer will be added to the TOC of the view. This vector layer
is like any other vector layer, so you will be able to change its symbology. Go to the context menu of
the layer, click on Properties and select the Symbols tab. Choose the Unique values option and
set the legend to the field cod_ent.

3. Apply the new legend, go to Layer/Export to/SHP and export the date into a shapefile. Notice
that you can export the vector layer into other formats like dxf, kml, gml and postgis as well.

4. Finally, try to change the request paramaters in the context menu WFS Properties of the layer. For
example use the filter option, change the fields request or set other maximum features to load.

WCS - Web Coverage Service

From this web servide you are able to load coverages to the gvSIG view. This is a kind of raster files, for
example DEM or DTM .

1. Create and Open a new view on the gvSIG project manager. Select Add layer, and then go to the
tab WCS. Connect to the url http: /flocalhost/mapserver/wcs

2. Once you are in, select the layer 90m DTM of South West section of the Iberian Peninsula and
on the Format tab select GEOTIFF.

3. On the last tab you can select the image band to load. Select the only one available. Accept and
then the layer will be added to the view.

4. From the conext menu, you will be able to change the WCS Properties, like you have done to the
others web map services.
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Access to PostGIS Data Bases

gvSIG can access postgres table, as well as PostGIS layers that contain geographical (vector)
information.

In order to load a PostGIS layer you will need to follow these steps:

1. In the last view (or in a new one) go to View/Add layer/GeoBD and click on the button Add
Connection, on the right.

2. In the connection settings windows, put those parameters:

Connection name: accesstest

Driver: PostGIS JDBC Driver

Server URL: Jocalhost

Port: 5432

DB name: postgres

User: postgres

g. Password: postgres
h. Check the connected checkbox.

3. Click the Accept button and you will see a list of avialable layers. Select the layer public.poblacion
and all the field of that layer will appear on the right column. You can select one of those fields or all
of them. Select the field gid as the ID field, and the field the_geom as the field that contains the
geometric field.

4. Note that you can do another kind of selections, for example, setting a SQL restriction or an
interest area by it minimum and maximum extent.

5. After accepting the postgis access window, the layer will be added to the view as another vector
layer. This means that you are able, for example, to change its symbology, or open its table of
attributes.

~0anTo

Catalogue search

The catalogue search service gives us the possibility of searching geographical information on the net. For
that purpose, gvSIG offers an interface where the user can configure the needed parameters.

1. Open a new view, call it "Andalucia's towns". Click on the catalogue icon.

2. Paste the service url available on the liveDVD htip: //localhost/geonetwork/srv/csw and select the
CSW/ISO 19115 protocol.

3. After the connection to the server is established, type the keyword Andalucia and then the button
Search.

4. A window appears with the results of the geosearch, showing 5 layers that contains the keyword on
their metadata. Go straight the 3° geodata called Populated places of Andalucia, and click on the
Add layer button in order to see which kind of layer you will be able to add.

5. In this case, you'll see a WMS as Map for loading it into the view of gvSIG. Clicking on Maps the
layer will be added.

Gazetteer

The Gazetteer service is way of linking geographical coodinates and place names. gvSIG has a gazetteer
client in which you can search for geographical keywords, and those places will be shown on the gvSIG
view.

1. On the same view used in the last excercise, click on the gazetteer icon (Finfing by gazetteer) and
the parameters window will appear (if you are not on the same view as before, remember that the
gazetteer icon will not appear until you load at least one layer).

2. Connect to the server http: /flocalhost: 8180 /deegree/wfsg selecting the WFS-G protocol.

3. Type the keyword Seuvilla and then click on Search. Two results will appear displayed on the result
pages. Select the first one, and click on Localize.

4. This way, a red point will appear on the view recentered on that place, showing the position of the
place name and the name itself.

5. Once the point is on the view, the rubber icon appears for erasing the place names you added
before.
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OSGIS10 Editing

This page last changed on Jun 17, 2010 by jvhigon.

Duration 30 min

» Creating a new vector layer
* New shapefile from derived geometries
« Creating hiperlinks on vector layers.

Creating a new vector layer

In this excercise we are going to create a new vector layer from scratch on a new view.

1. Create a new view, you can call it Editing.

2. Load the raster image of the town center of Valencia Centro_2002.jp2 1t is on the folder data/
cartografia/Valencia.

3. Use the tool Center view to point and the coordinates (X = 725704, Y = 4372413) to center the
view in the town hall of Valencia. Then set the graphical scale to 1:1000.

4. Go to View/New layer/New SHP to create a new vector layer

5. Select the type polygon and click on Next

6. We are going to add a new field with the name SoilUse and the data type (String) and length by
default.

7. In the next window you have to select the name and route where the layer will be created on the
live DVD. For example, you can set CenterProject.shp as the name, and be careful to save it into /
home//ubuntu because it must be saved under a read and write folder.

8. A new layer will be added to the TOC, on a red colour that means the layer is in edition mode (the
edition console must be on the bottom of the view and the new edition menus must appear).

9. Put into active the new layer, and select the Polyline tool. Click on the view to define the first point
of the new polyline and then select each of the consecutive points in order to define a building's
base. In order to close the figure you can use the content menu's choice Close polyline or the C
letter in the edition console.

10. The new polygon is standed out with the selection colour. You can add as many polygons as you
want, defining some groups of buildings. In order to define adjoining buildings you can use the
snapping tools. For this purpose, go to the content menu/Edit properties/Sanppings.

11. Probably, on edition mode, you will need to change one vertex defined previously. In order to do
this, go to the Select tool (editing tools) and then select the vertex you want to change and next on
the new position for that vertex.

12. If we made some kind of mistake, we can always click on the Undo/Redo arrows, and by opening
the command stack you will see a list of edition changes.

13. Another thing you will need to do is to fill in the attibutes table. To do that, first of all select on
the view the polygon you want to fill in, then open the table and type on the selected entry the
information you want to add, for example on the SoilUse field, you can add values like: Building,
GreenArea, Public place, etc. Close the atribute table when finished the table edition.

14. After all the geometries were drawn on the new layer and all the attributes were typed, it is needed
to close the editing mode, saving the changes done to the vector layer. This way, the layer name will
turn into black again (before it was in red).

15. As a next step, in order to see the differences between the soil uses, you can change the layer's
symbology through content menu/Properties/Symbols, choosing Categories/Unique Values and the
field SoilUse. Apply the changes, and Accept that window.

New shapefile from derived geometries

By this feature you are able to create a layer of lines from a polygon layer, for example. Let's see how it
works.

1. Add the layer puertos andalucia.shp and municipios_andalucia.shp that is on the folder /cdrom/
data/cartografia/andalucia. Select the layer puertos_andalucia.shp.

2. Then go to the Layer/Crear SHP de geometrias derivadas (bear in mind that this tool will be avaiable
only in point and line shapefiles)

3. The original layer will be the one you have selected from the TOC, and then you will need to type
the new layer name such as distancia_puertos.shp that can be saved in /home/ubuntu
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4.

The geometry type choosen must be lines and the process selected should be points to lines. On
the next window you will see all the original features, and press Add all items if you want to add

all. If not, select the original features you want to derived, and then the plus button. If you want to
add or remove some axis, click on the plus or minus buttons, after selecting the features to want to
remove.

Clicking on Generar will create the new layer, adding it to the current view above all the other
layers.

Creating hyperlinks on vector layers

It is possible to link text files, html, and pdf files to geometries that are on a vector layer. This feature in
gvSIG isa called Hyperlinks.

1.

10.

11.

Add the layer municipiosAndal.shp to the view and then apply Zoom to layer. We need to save a
new layer (from the one added to the view) on a read and write folder because it is needed to put
the layer into editing mode to add the hyperlinks.

So, go to Layer/Export to /SHP and save the new file into the folder /home/ubuntu.

. Then start editing mode on that new layer, open the attribute table and go to Table/Manage fields.

We are going to create 3 new fields: image _link, html_link, pdf link, all of them from type String.
Each of those fields will be filled with the route to the file we want to link to.

For example, we can link an image from Granada. In this case, the first thing is to identify the entry
of the table where we have to edit in order to add the link.

. Open the attribute table, and the filter tool to identify NOMBRE = 'GRANADA' . After filtering this

entry, the polygon will remain selected on the view and on the table. Then go to this entry and type
/cdrom/data/cartografia/Andalucia/granada (with no extension at all) on the field image _link .

. The same way as before, we can identify the table entry for NOMBRE = 'SEVILLA', then on the field

html_link write the url of the Town Hall of Sevilla: http: //mmww. sevilla.org /impe/sevilla/portada
Last, we are goingo to add a link to a pdf format file. We are going to add a file for routing Jaén,
writing /cdrom/data/plantillas/rutal.pdf

. Once you have edited all the related entries, close the table and Finish the editing mode.

Now it's time to set the hyperlinks on the layer properties. Go throught the content menu to the
properties of the vector layer. Then click on the Hyperlink tab, and active the hyperlink.

For the first kind of hyperlink (image), select the field where you had done it (image_link), write the
extension as jjpg and choose the option Link to image files. Then click on the Add action, and set
the other two kind of hyperlinks (html_link and pdf_link). Accept hose changes on the properties
window.

At last, go to the view again, go to each of the the 3 entries (you can use the filter tool again):
Granada, Sevilla and Jaén and in each one click on the hyperlink tool and after that click on the
feature. You will be able to see the image, the web page and the pdf, each on a different window.

Note: if some of the file do not apear on the window, make sure you have edited the vector entry with
the right text.
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OSGIS10 Layouts

This page last changed on Jun 14, 2010 by jsanz.

8.Graphical output

8.1. Quick print tool

You can print a view semi-automatically with the tool called "quick print" (menu: View > Quick print).
There you'll find a window with a few options. A map will be automatically generated and will be sent to
the printer.

8.1.1. Create a view. Rename it to "Andalucia".

8.1.2. Open it and add the layer municipiosAndal.shp

8.1.3. Select the layer and configure the legend (right-click on the layer: Properties > Symbols) like this:
Categories > Unique values > Classification field = "PROVINCIAS".

8.1.4. Go to menu View > Quick print and set the following paremeters: Formats = A4, Orientation =
Horizontal, Title = "Andalusian municipalities", Show legend = ok, Show grid = ok, Image = by default.
Then, click on Preview. The new map will be generated. If it's ok we could print it or export it as a PDF.

8.2. Making a map

We can create a completely new map or we can use a template created before.
8.2.1. Load the template called Plantilla4.gvt (menu: File > Open template).
Adding a view.

8.2.2. Insert the view "Andalucia" in the bigger rectagle (menu: Map > Insert > View).

8.2.3. Adding a grid to the view. Select the view, right-click on it and select Properties. Select Show grid
and click on Configure. There you can set the parameters: interval, symbol and font.

8.2.4. Setting the view scale. Within the view properties dialog we can select three types of scales:
Automatic, Maintain view scale and Specified by user. Apart from that we can do zoom and pan on the
view in order to get the desired aspect (zoom in, zoom out and pan view frame buttons). Notice that the
view must be selected.

8.2.5. Rotating the view. Select the view, right-click on Properties and input the degrees manually or
clicking on the arrows.

Adding a legend.

8.2.6. Go to Menu: Map > Insert > Legend. Drag and drop the mouse over the area you want to place
the legend. There you must select the view and the layers whose legends you want to show.

8.2.7. To modify the legend elements select the legend and go to menu: Map > Graphics > Simplify
legend.

Adding other map elements.

8.2.8. Scale. To add a scale go to menu Map > Insert > Scale. Then drag and drop over the area you
want to place the scale and set the parameters. Notice that the scale is dinamic: if we change the scale
view, the scale symbol will be updated automatically.

8.2.9. North symbol. To add a north symbol go to menu > Map > Insert > North. Then drag and drop
over the area you want to place the north, choose one of the showed symbols and select the view the
north must be linked with. Notice that the north orientation is dinamic: if we rotate the view, the north
will be updated automatically.

8.2.10. Locator. To add a locator go to menu Map > Insert > Locator. Then drag and drop over the area
you want to place it and set the required parameters.

8.2.11. You can add other elements like text, rectangles, lines or images.

8.2.12. You can group, ungroup, align, place back and bring to front all the elements (menu Map >
Graphics >...).

8.3. Printing the map

8.3.1. To print the map go to menu Map > Print. The print dialog will appear.
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8.3.2. Instead of printing the map you can export it to a PDF or PS (PostScript) file (menu File > Export
to...).
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OSGIS10 Brief introduction to gvSIG Mobile 0.3

This page last changed on Jun 14, 2010 by jsanz.

See attached pdf: gvSIG_Mobile_introduction _workshop OSGIS_2010.pdf
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OSGIS10 Installation and requirements

This page last changed on Jun 14, 2010 by jsanz.

* System requirements:link
¢ Previous requirements: link
¢ Manual of installation:link
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OSGIS10 Download of gvSIG 0.3

This page last changed on Jun 15, 2010 by adelrey.

« To download gvSIG 0.3 this link: link

NOTE: For this workshop as we have to run gvSIG Mobile 0.3 in a PC, we will use the version of gvSIG
0.3 for Tablet PCs for Windows XP: link
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OSGIS10 Description of the exercise

This page last changed on Jun 16, 2010 by adelrey.

The exercise will consist of updating the shape file "services" as if we were in situ with gvSIG Mobile, by
the location and editing of a new service (a restaurant) in the street "La Paz" in the center of Valencia.

We need to register this new service with the number of the official Cadastre Reference (REF_REG), that
we will take from the WMS of this Public Administration of Spain.

The data we are going to use is:

Ortophoto of Valencia center: vic_centro_23030.ecw

Point shapefile with the services in the center of Valencia: services.shp

Line shapefile with the services in the center of Valencia: streets.shp

Web Map Service of the National Cadastre of Spain: http://ovc.catastro.meh.es/Cartografia/ WMS/
ServidorWMS.aspx?

We will edit the attributes of the new point through a custom form by using a xm!/ file called
SERVICES_Valencia.xml
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OSGIS10 Exportation of data from a gvSIG Project into the PDA

This page last changed on Jun 15, 2010 by adelrey.

1.- Extension to synchronize with gvSIG Mobile

To download this extension click here.Currently this extension works under gvSIG 1.1.2 version. To install
the gvSIG 1.1.2, the version gvSIG 1.1 have to be previously installed (to download this version click
here). After the gvSIG 1.1. instalation we can install the gvSIG 1.1.2 version (to download this version
click here).

2.- gvSIG Project and add data

2.1.- We create a new project with gvSIG called: Valencia Center-services.gvp

gvSIG:Untitled [=1=]x]

File Show Window Help ‘

@ Projecemanager . 0 o o B
Document ypes
] e
L‘ A\‘:ﬂ;/‘g
Wi Table Map
View:
Untitled - 0
Rename
| omew |
‘07‘ Type the new name
en
R |Va|en:\a Cen\er,ser\nces\
‘ Rename ‘ —
p——— ok
‘ Delete ‘
‘ Properties ‘
Session properties
Session name:  Untitled
Saved in:
Creation clate: May 13, 2010
Properties
/& Warning: Error abriendo el documento: Tabla de atributos: streets.shp ProjectTable Meters po=332 fr=62 [EPsc:z3020

2.2.- We add data to the new window:

« an ortophoto of the center of Valencia, tiff format: ortophoto_valencia center _tif. tif
 a shape file with the streets of Valencia : streets.shp
» a point shapefile with information about the current services in Valencia center.: SERVICES. shp

The structure of the table of shape file of the services of Valencia is the following one:

+ CATEGORY
+ REF_REG
« STREET

« NUM
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gvsSiG:Valencia center.gvp

File Show Layer Window Field Table Yiew Help
D=8« » |5
% View : valencia Center_services

=) SERVICES.shp

Default

A streets shp

/" Default
. ortagphoto_walencia_center _tif tif

& Table: Table of atuibutes: SER.. “ & [E]

CATEGORY | REF.REC | STREET | nuM
5423302... Fintor Ser
5423302... Xatva
5423302... Avellanas
5423302... Guillem d...
5423302... Pintor Sor.

5423302... Bailia
5423302... Paz
5423302 Paz

0/ 8 Total of selected records

@ Errar: User error Meters M =726,856.96 ¥ = 4,371,637.52 |EP5G:23030

2.3.- To carry out the job at the field,we should select just the information we need through the
extension to export data.

o gvSIG:Valencia center.gvp [==]E]
File Show Layer Window Table View Help ‘
OrEzlccasixapr|esa s rdameBvreios o [BE # bbbk (B |
i View: Valencia Center_services i

A SERVICES.shp ¢ %

L e Export to gvSIG mobile
A streets shp
/" Default Proyect narme |Update valencia Center sesion 1
. ortophoto_
Export to |!homefade\rev[warkshan T31G Mobile 03CIS ‘ D
lmport Zone Layer Atri
@) View O Exent [ J

streets.sh
MNarne

Expon ! o

I view Name iy

4 ortophoto_valencia_center_tiftif 00 |:\ Al - 4 CODIGO
£4 streets.shp 15715 [ £ CODIGO.CCG

£4 SERVICES. shp a4 [ 1 LF_ADD

LT_ADD
RF_ADD
RT_ADD

STREET_TYP String

J [ Cancel

Gd [ ] [

@ Error: User error 1[15,903 [xiMeters b=72482443 [ =-437366835 [EPSC:23030

We can select area to export by using:

* Active view.
« Frame.

To export to gvSIG Mobile we can:

Select layers to export according to their location in the View and the area to be exported.
Full layers can be exported.

e Clip by rectangle.

e Select geometries to export.
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» Select attributes to export.

» Generate gvSIG Mobile export project. (gvm)
» Export simple symbols.

« Export viewing scales.

Project name: Update Valencia Center sesion 1
Path: the default paht of the workshop

The result is a folder with the name ..................... /Update Valencia Center sesion 1, that contains the
shapes files and the ortophoto and also a gvSIG Mobile project (.gvm):

» SERVICES_select points.shp
» streets_select_lines.shp
» Update Valencia Center sesion 1.gvm

2.4.- To put this information in the PDA we have to copy this information through a programm like:
ActiveSync. For this workshop we have already copy this information to the Live DVD.
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OSGIS10 Configuration of the device and project

This page last changed on Jun 16, 2010 by adelrey.

1.- Start gvSIG Mobile for Windows XP
Just to click the gvSIG Mobile.bat file that is in the folder: gvSIG MobileXP_0OSGIS.

2.- Start gvSIG Mobile from a PDA

We start gvSIG Mobile from the PDA Start Menu.

4 Start 3, 4% 18:19 HE |5tart &, é 1822 [X

%, Today

i@ Calendar

FB Contacks L

#5? g¥5IG Mobile

4 Internek Eupluré '

{& Messaging
G Windows Media

"% File Explorer

fig; Programs
fF; Settings
? Help

Calendar Contacts Calendar Contacts

3.- Main Toolbar

The application has a vertical Main Toolbar (1) with icons representing groups of functions, and a
horizontal Secondary Toolbar (2), which shows the specific tools of whichever icon is selected on the
main toolbar.

Main Toolbar:
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* Project Management
GPS Tools

Editing Tools

Layer Management
Navigation Tools
Information Tools

4.- Set up the defult settings of the device

Through the Project Management Function, we are going to set up the default settings of the device,
for example the language, the path to the project files, the spatial reference system, the background
colour of the view and the maximun and minimum extends of the project.

*‘ ‘ * ﬁ " * 9 : Application settings

General | Wiew | Startup project |

SRS |EF‘SG:432E . |

Path: I".,gxrmJ:\rnjects | L1

Eq calor: O

Extent:

¥ (mnin, max): |-13|:|.|:| ||18IZI.IJ |

Y (rnin, rnax): I-EHZI.IZI ||‘3IZI.IZI |

In our case:

* The SRS will be: EPSG:23030 (UTM Hayford Elipsoid ED-50).For example the EPSG: 4326
correspond to WGS84.

» The path: by default

» Language: English

The default settings of the application can be different from the properties of the view. For example, we
can set up a default SRS for the application and change this SRS fro the view of the Project.

5.- Open a existing project

We open the gvSIG Mobile project created before: Update Valencia Center sesion 1.gvm by clicking Open
Project
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H .l,'l gvSIG M < 19:42

Open

Folder: |2l Folders ~|[ cancel |
Type: |*.gvm v|
Marme & |F|:|Ider

Cities ovm_rojects
Tezt avm_projects

E‘ egetation avm_projects

‘ Cpen Project...
* Sawe Project

1.- We click New project.

2.- We can set up the properties of the project by clicking Project Properties.
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HC | gvsIG (£ 18:29 X L | ovsIG {2 19:58 [X HC | gvSIG M (£ 20:00 [X
3 ¥
* ‘ * “ ’ * o ] Project properties Project properties
i Basic | Wiew
o Marne [MewProiect | SRS |EDSG:4325 - |
Path: L1 [eacsbr O
Extent:
% (in, max): | i) |
Description: ¥ fomin, ma: | Il |
Created: | |
Updated: | |
90 lx]

As I said before, the default settings of the application can be different from the properties of the view.
For example, we can set up a default SRS for the application and change this SRS of the view of the
project.

In our case:

e SRS: EPSG: 23030
* Name of the project: OSGIS.gvm
e Path: OSGIS

7.- GPS Configuration

As we are making this exercise by using gvSIG Mobile 0.3 for Windows XP and here there is no GPS
signal, we are going to make this exercise without GPS. However I will explain how to set the GPS devide
in case we could go to the field.

We can set up the properties of GPS by the GPS Setup option.

"i"lu o :I.

Py
L -]

'
}
x,y O

‘& Display

'h StartiSkop Tracklog

*

BB, view GPS activity...

Connect/Disconnect

We can decided if the GPS signals are to be received from an active GPS (Serial Device) or whether the
GPS device will be simulated by using data from a text file containing NMEA GPS data (Simulated Device).
In our case if we could go to the field we would use a Serial Device. (3) y (4)
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! | ovSIGMobile 0.2 &* 4£ 09:48 [X

» B ol

/ ¢ | ovSIGMobile 0.2 &% £ 20:17 [X

GPS Preferences

Crawice | Logging | Drisplay |

Protacal: |NI‘--1EA 0183 ~| £
(W) Serial device

Part name;  |COMI: P
Baud rate:  |3600 <]
() Simulsted device

File name: | | Ca

Period(ms]: I |

90

As a simulated exercise, we will define the GPS preferences as:

* Protocol: From the drop-down list we select NMEA 0183 (At present only this protocol is supported
but it is been working to give also support to the NTRIP Protocol)

¢ Port name: COM 2

» Baud rate: 9600

I would like to comment that the Logging tab is used to specify the format and files names for the
waypoints and trackpoints . Two formats are currently supported: GPX and CSV.

The Display tab is used to control how GPS icon is displayed. There are options for recentering the view
based on the GPS position displaying the GPS icon or a combination of these two options.
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OSGIS10 Visualization of local and remote data

This page last changed on Jun 16, 2010 by adelrey.

1.- Layer Management Function

=) |
ﬁ Add WYectarial Layer...

,‘ Add Raster Layer...

==
& Add WwMs,.,

5 Table of Contents...

1.1. Add raster data
gvSIG Mobile supports:

« ECW
« PNG
« JPEG (with .wld file)

We add the ortophoto of Valencia center: vic_centro_23030.ecw
1.2. Add vector data
gvSIG Mobile supports:

2D and 3D point and multipoint shape files

2D and 3D Line and polyline shape files

2D and 3D polygon and multipoligon shape files

Multigeometry version 2.x and SFP (Simple Features Profile) version 3.2
GML (Geographic Markup Language) files

MultiGeometry version 2.1 KML (Keymap Markup Language) files

» Point and track GPX (GPS exchange) files

We add the two shape files we selected from our gvSIG Project: Update Valencia Center sesion 1.gvm .
........ /Update Valencia Center sesion 1

« Line shape file with the services in the center of Valencia: streets_select_lines.shp
« Point shape file with the services in the center of Valencia: services_select_ points.shp

1.3. Add remote data

At the moment gvSIG Mobile 0.3 supports WMS but the next version gvSIG 1.0 will also support the WFS
protocol.

We add the WMS of the Cadastre National Service of Spain, that it is in the list by default.
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/o | ovsiGMobile 02 &% ¢ 14:26 X
WMS layer options

Server: http:/jove. catastro.meh.esfCar v|

SRS: EPSG:23030 -

Format: imagefpng

) [wms)
Cartografia Catastral

Catastro
CONSTRU
TXTCONSTRU
SUBPARCE
[l n | [ »

v 1]

4

[ m [»

4

« We select :
° Server: http://ovc.catastro.meh.es/Cartografia/WMS/ServidorWMS.aspx? from the list.
° SRS, in this case EPSG:23030
° The format of the image: png/jpj
° The layers we want to use: we will select all layers.

1.4.- Change the properties of the layers through the Table of Contents

‘e | gvSIG Mobile 0.2 3, ¢ 20:43 X - | gvSIGMobile 0.2 %, 4¢ 20:42 X

Table of Contents L .
ayer properties
& Iﬂ_’;ym, &7 Lapername En Mame: [Cities
o o [] cities d il File: [Cities.shp
A [ Rivers ia] visible: |
e I:l Roads 1'3 Infoable: v
= D Prowinces f Fesonal Forl ~ [[Mone]
OO o Maxseale: | [5000
ﬁ Min seale: [ |
".. 3) &
=== Comrent:
U/ Q0
{6) H [ [T+

iy

Another feature of the Tablet of Contents is that the properties of any of the layers in the project can be
viewed and configured by

the button (2) Layer properties. We can cange the following properties:

« Name

* File

« Visible. Indicates if the layer is visible in the project or not (3)

« Infoable. Indicates if the attributes associated to the layer can be viewed.

» Personal Form: a custom form based on a XML file can be used to display the attributes of the
specific layer. By ticking the check box you can provide the path were the .xm/ file is.

» Max scale. Indicates the maximum scale of the layer (6)

* Min scale. Indicates the minimum scale of the layer (6)

« Comment. A space for providing information about the layer.

From the Table of contents is also possible to add new layers to the project. This window shows all the
layers that are currently loaded in the project.
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1) We are going to change the symbology of the layers:

‘e | gvsIG M_ o< 20:45 [X

o | gvsIG M: £ 20:46 [X

T .'l gvsIG M' % 20:46 [X

Layer symbology Layer symbology Layer symbology
Size: L | ol fuinewign: 3 | | uinewidth: 1 4 1|
Colar . Color: D Border color: .
Filled: v
Fill calar: |
1] @ v 1]

BT SR 2 e 0 e

» the colour and line width of the line shapefile streets_select_lines.shp
» the colour and size of the point shapefile services_select_points.shp

2) We can change the order of the layers, delete the layers, etc.

3) We are going to associate the custom form SERVICES valencia.xml to the shapefile
services_select_points.shp

2. Navigation Tools

fhade  CRLX
ARG ® = § R |

*‘ Zoorn Rectangle

@ oo

t Zoam Cut

‘;_. Zoom Previous

) Zoom Mext

' Manual Pan
a Zoom Extenzion

gvSIG Mobile's various navigation tools allow the user to view the project's graphical information at
varying levels of detail, making the browsing of
different locations easy and convenient.

Zoom Rectangle
This tool allows a zoom area to be defined by drawing a rectangle around the area of interest.

Zoom In

It zooms in to the View by a fixed amount,thereby increasing the level of detail each time the button is
clicked.
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Zoom Out

It decreases the level of detail by reducing the display scale each time the button is clicked.

Zoom Previous and Zoom Next

The Zoom previous returns to the previous display in the View,while the Zoom next button advances to
the next display.

Pan and Recenter

By using the Pan tool to drag the map around, the user can interactively recenter the map without
changing the scale. Clicking on the map with the

Recenter tool, causes the View to be recentered on the point clicked by the user, also without changing
the scale.

Zoom Extension

Clicking the Zoom Extension button will result in the View zooming out to the full extent of all the
different layers in the project.
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OSGIS10 Obtaining and Searching information, making measures

This page last changed on Jun 15, 2010 by adelrey.
1.- Obtain information about a feature

In our case, we are going to obtain information about this two files:

- street_select_line.shp (without associated custom form)
» services_select point.shp (with an associated custom form)

For that goal we are going to use the Query tool (1), that is used to display information about features in
the project's layers.

f.'l gvsIG (£ 16:25 [X

@ﬂ_“. v}
)

.. .
L4 i Measure Distance
L]

. | ; Measure Area

@- Search by Attributes,,,

Using the Get Information button , click on a point in the View to obtain information on the feature(s) at
that position. This opens the Information by point form (2), which displays information on the features
intersecting the point that was clicked. Note that the query button retains its active or inactive state until
clicked again (clicking the button toggles between these two states). With the button in its active state
the View can be queried multiple times.

If the position queried contains no features, then nothing will be displayed. If the layer being queried is a
raster layer, then the information will be displayed in the format shown in the figure below.
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However, if the queried position contains at least one vector layer with editable attributes, then
a form is displayed. If the first layer intersected by the query point has a personal form, then this is

the form that is displayed. If the layer is not editable, the information displayed in the form cannot be

changed and is displayed in a grey colour (3). However, if the layer is editable, then the fields in the form
can be edited and will be displayed in black (4). The figure below gives examples of the same information
displayed in both a Standard Form (5) and a Personal Form (6). Note that this figure illustrates the forms
displayed when the Get Information tool is used to query a vector layer.

2.- Search by attribute

We are going to make a search in order to locate the street La Paz, where the exercise
will be carry out. For that goal we are going to use the Search by Attribute tool (1).
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By Clicking the Search by Attributes button (1 )o pens the Search by attribute value form, which contains
the following
fields:

e Layer. Select the layer to query from the list of layers in the project.: street_select_lines. shp
e Column. Select the attribute column in which to conduct the search. STREET_NAM

« Op. Select the query operator: CONTAINS

« Value. Enter the value to search for in the selected attribute column: PAZ

The selected street will be highlighted in yellow colour and we will make a zoom to the selection by
clicking the last button.

3.- Select features

We can also select geometries (1) in a vector layer. When using this tool, only one vector layer must be
marked selectable (infoable) in the Table of Contents.

We can make three types of selection:

+ Select by point. (2) Select a geometry (feature) by clicking on it in the View. The selected
geometry will be highlighted in yellow.

« Select by rectangle. (3) Select a set of geometries by drawing a selection rectangle in the
View. Geometries wholly or partially within the selection rectangle will be selected. The selected
geometries will be highlighted in yellow.
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» Clear selection. (4) Deselect all geometries and restore their original colour.

4.- Making measures

We can make measures to obtain coordinates, distances and areas.
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OSGIS10 Editing a vector layer by using XML files

This page last changed on Jun 16, 2010 by adelrey.
1.-Editing tools

These editing tools are used to create new geometries in previously loaded vector layers. Three types of
geometries can be created:

» Points:Created with the Point tool (1).
» Lines: Created with the Line tool (2).
« Polygons: Created with the Polygon tool (3).

There are also editing tools for creating geometries using information from a GPS:

+ Waypoint :Add points with the Add vertex using GPS tool (4).

e Add a trail of points with the Add vertexes automatically using GPS tool (5). Points are captured
according to a specified time interval.
With the editing tools, vector layers can be updated with new data created by the user. Any new
geometries automatically inherit the attributes of the layer being edited. These attributes can be
entered once the geometry or feature has been digitized.

2.-Create a custom form

Personal forms are used to view, edit and insert alphanumeric data, exactly as with a generic form.
A personal form can display data in tabular format, define ranges of integers to be met by the values
contained in the fields, or even display icons along side labels.

Personal forms in gvSIG Mobile are based on Thinlet GUI toolkit, that is a User Interface tool. It is

a Java class, which interprets an XML file to display information on screen with a specific design, handle
user input, and perform basic associated operations. It separates the graphical display (defined in an XML
file) from the methods of the application (which are written in Java).

gvSIG Mobile already has generic application methods that interpret forms and execute the most
common field operations, and present data in an appropriate way.
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2.1. How can we create a custom form?
This process is explained in the manual attached on the LiveDVD of gvSIG Mobile 0.3. (page 64).

In this exercise we are going to use the file SERVICES_Valencia.xml, that it has been designed
previously at the office and associated to the services select points.shp file.

The general steps are:

» Step 1: Create a new XML: Use a text editor to create a new text file with an extension of XML,
for example "form.xml".
» Step 2: Select the components to appear on the form: Decide which components are needed
to represent the desired attributes. The types of components that are available are as follows:
Text field: A text box to enter data associated with an attribute of a feature.
Password field : A text box that hides the text entered by the user.
° Text area : A box in which to enter several lines of data associated with an attribute.
° Text label : A label used to name an attribute, or to display information on the form.
° Checkbox : A selection box associated with an attribute that allows only two values, namely
selected or not selected.
° Combo box: A component that displays a drop-down list of values. Values can be selected
from the list or a new value can be entered in the text box part of the
Numeric ranges : A box in which to enter number within a particular range.The box has
buttons to increase and decrease the number* Step 3: Design the layout and grouping of the
attributes: If attributes of a feature need to be grouped, or if grouping is needed to structure
the form then the following components can be used:
- Tree : Attributes are displayed in hierarchical form using a tree structure.
- Tab: Tabs can be used to group attributes, which can be displayed using any of the
component types described above.
- Panel: Groups of related attributes can be displayed on separate panels. Apanel can
contain any of the component types described above.
Table: A table is used to display several attributes that can have multipl values. n x m (n
samples of m values).

» Step 4: Write the XML file: Once the components have been selected and the layout has been
designed, the XML code can be written.

An easier way of having a fast custom form is to take the SERVICES Valencia.xml created as a template
and update it to the features we need to carry out our job.

3.- Edit the point shape file
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Once we have select the street La Paz we are goin to edit it . The procedure is as follows:

+ Step 1 - Enable Editing: Once a layer has been loaded into the View(1), editing of the layer
is enabled in the Table of Contents (hereafter referred to as TOC). The TOC is opened from the
Layers toolbar (2). To enable editing tick the checkbox (3) below the pencil icon of the layer
services_select_points.shp . Return to the View by clicking the Accept button (4) to close the TOC.

* Step 2 - Select the drawing tool: Select the appropriate drawing tool from the Editing toolbar
(1). Note that if the layer being edited is a point layer, then only the Add point (2), Add vertex
using GPS (5) and Add vertexes automatically using GPS (6) tools can be activated. For line layers
only the Add line (3) and the GPS buttons mentioned above can be activated, while for polygon
layers only the Add polygon tool (4) is available. For layers that support multiple geometries,
for example GML layers, any of the drawing tools can be activated. When a tool is selected and
activated for editing it is displayed with a yellow background. As we have not GPS, we edit the layer
by using the edit tool (Add a point) (1)

+ Step 3-- Add New Geometries: In our case , once the Add point tool (1) is activated, new points
are added to the editable layer by clicking at the desired positions in the View (2). As many points
as is needed can be digitised in this manner. New points are generated with the same attributes as
in the layer being edited, except that these attributes are empty.

* Step 4_ Select the custom form. In the TOC we indicated previously that the
service_select_points. shp has an associated custom form SERVICES_ Valencia.xml.
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+ Step 5_ To get information about the WMS: We need to have the information about the REF of
the new point, so we go to the TOC, we change the order of the layers by setting up that the WMS is
on the top.After that with the Get Information tool from the Information Management toolbar we get
this information. We can copy this value from the PDA by using Crt/+C
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NOTE: This way to copy the data only works by using gvSIG Mobile in the PDA, in our case we have
to introduce manually the value.

- Step 6_intoduction of attributes. To enter attribute data for a new point first activate the Get
Information tool from the Information Management toolbar, then click on the new point to bring up
the attributes form. We have to enter the following atributes:

CATEGORY: (CATEGORY table register name): Restaurant (we select this value from the scroll
bar)

° REFERENCE: (REF_REG table register name ): By using Crtl+V we paste the value that we
have copied before. NOTE: This way to copy the data only works by using gvSIG Mobile in the
PDA, in our case we have to introduce manually the value.

« Step 7_Save the layer. To disenable editing, tick the checkbox (3) below the pencil icon of the
layer services_select_point.shp.

- Step 8_To check that the file has been updated. With the Get Information tool from the
Information Management toolbar, click on the new point to bring up the attributes currently
updated.

4.- Limitations when editing layers

e The layer must be a vector layer.

« Only one vector layer can be edited at a time.

« If the original vector layer contains a single type of geometry (points, lines or polygons) then only
the same type of geometry can be added.

« It is not possible to create new attributes that are not already in the layer being edited. Each new
geometry only inherits attributes already existing for other geometries in the layer.

« It is not possible to modify geometries that existed in the layer before editing was enabled.
However, it is possible to edit their attributes.

« To cancel any changes made since editing was enabled, simply uncheck the Editing checkbox in the
TOC and click the cancel button when asked to save changes. The layer will return to the state it
was in prior to any editing.

« Generating of points and track points from a GPS is only be possible if the GPS is enabled and
working properly.
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OSGIS10 Export data

This page last changed on Jun 15, 2010 by adelrey.

1.- Exporting the results

We can export the result of our shape file into the following formats:

« GML 3.2
« GML 2.x
« KML 2.1
. SHP

74 | ovsiG Mobile 0.2 ¢4 < 21:22 [X

Export Vectorial Layer
Layer:
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We are going to export the results as:

services_select_point_update. KML
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OSGIS10 Thematic maps generation

This page last changed on Jun 15, 2010 by adelrey.
1. Creation of a thematic map

We are going to create a thematic map of the file services select_point.shp by range of value.
For example by the NUM value selected from the scroll bar.
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