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1 – Introducción - Definiciones
1.1) PostgreSQL
Es un Sistema de Gestión de Bases de Datos (SGBD) relacional orientado a objetos y 
libre.
SGBD, es un conjunto de programas que permiten el almacenamiento, modificación y 
extracción de información en una base de datos. Poseen métodos para mantener la 
integridad de los datos, administrar el acceso de usuarios a los datos y para recuperar la 
información en caso de fallo del sistema.

1.2) Postgis
Es un módulo que añade soporte de objetos geográficos a PostgreSQL, convirtiendo está 
en una base de datos espacial (permite definir la localización y relación espacial entre 
los objetos).
Los objetos deben estar referenciados en un determinado Sistema de Referencia 
Espacial (SRS) para definir las relaciones entre ellos.

Es posible utilizar datos y consultas espaciales compartiendo o utilizando información 
almacenada de forma tradicional en la base de datos.
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2 – Shapefile vs Postgis

Shapefile, formato de archivo propietario desarrollado por la compañía 
Esri.
Archivos locales almacenadas en el pc de usuario o red.
No permite edición de múltiples usuarios simultáneamente.
Difícil mantenimiento e integridad de datos.

Base de Datos PostgreSQL + Postgis, sofware libre.
Almacenamiento centralizado de información, geográfica o 
de otro tipo.
Relaciones entre objetos y datos.
Permite consulta y edición simultáneamente a múltiples 
usuarios.
Permite establecer distintos permisos para diferentes 
usuarios o grupos. 
Respaldos programables en forma automática.
Recuperación de datos (último, por fecha, totales, etc.).
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3 – Instalaciones
3.1) PostgreSQL

- Información y documentación: http://www.postgresql.org.es/
- Descargar archivo ejecutable desde:

http://www.enterprisedb.com/products-services-training/pgdownload#windows
 (elegir Sistema Operativo y versión para descargar)

Elegimos el directorio donde guardar el archivo de instalación, 
posteriormente procedemos a la instalación del mismo.

http://www.postgresql.org.es/
http://www.enterprisedb.com/products-services-training/pgdownload#windows


3 de Octubre 2014 – Taller Introducción a Postgis 2 5 de 32

3 – Instalaciones
3.2) Instalar PostgreSQL en Windows

- Ejecutar archivo “postgresql-9.5.5-1-windows-x64.exe” (nombre archivo 
puede variar según sistema operativo o versión descargada, debemos tener 
permisos de administrador para poder instalar programas):
 

1 - Iniciar instalación 2 -Elegir directorio de instalación 3 - Elegir directorio de datos

4 – Elegir contraseña para 
usuario postgres

5 – Elegir puerto instalación, 
por defecto 5432

6 – Elegir configuración de 
caracteres (dejar default sistema)
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3 – Instalaciones
3.2) Instalar PostgreSQL en Windows

 

7 – Luego de presionar “Siguiente” comienza el 
proceso de instalación

8 – Opcionalmente podemos instalar otras 
herramientas, podemos desmarcar esta opción y 
presionar “Terminar” para culminar la instalación 
de PostgreSQL.

NOTA: por defecto la instalación en Windows instala la herramienta de administración 
PgAdmin 3, en Linux puede ser necesario instalar PgAdmin 3 separado.
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3 – Instalaciones
3.3) Postgis

- Documentación: http://postgis.net/documentation
- Descargar archivo ejecutable desde:
http://download.osgeo.org/postgis/windows/pg93/

 (elegir versión para descargar, ej: Windows 64 bits archivo
postgis-bundle-pg93x64-setup-2.1.3-1.exe )

Elegimos el directorio donde guardar el archivo de instalación, 
posteriormente procedemos a la instalación del mismo.

http://postgis.net/documentation
http://download.osgeo.org/postgis/windows/pg93/
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3 – Instalaciones
3.3) Postgis

- Ejecutar archivo “postgis-bundle-pg93x64-setup-2.1.3-1.exe” (nombre 
archivo puede variar según Sistema Operativo o versión).  

1 – Aceptar contrato de 
licencia

2 – Marcar la opción “Create 
spatial database”, presionar “Next”

3 – Elegir el directorio para la 
instalación

4 – Ingresar la contraseña 
administrador postgres ingresada 
anteriormente

5 –Ingresar nombre nueva “Base de 
Datos”, presionar “Install”.

6 – Progreso de instalación



3 de Octubre 2014 – Taller Introducción a Postgis 2 9 de 32

3 – Instalaciones
3.3) Postgis

7 – Presionar “Yes” para aceptar la 
sugerencia de registrar la variable 
GDAL_DATA

8 – Presionar “Yes” para instalar el soporte de 
datos raster.

9 – Presionar “Yes” para instalar el soporte de 
datos raster.
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4 – Crear una base de datos geográfica
4.1) conectarse a postgresql

Utilizando pgAdmin

File -> Add Server

Por línea de comandos

# psql -U postgres -d template1
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4 – Crear una base de datos geográfica
4.2) crear una nueva base para 
almacenar los datos con geometrias:
Utilizando pgAdmin

Edit -> Create

Por línea de comandos

# CREATE DATABASE datosgis WITH 
ENCODING='UTF8' OWNER=postgres 
CONNECTION LIMIT=-1 ;
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4 – Crear una base de datos geográfica
4.3) crear extensión para 
soporte Postgis, raster y 
topología:
Utilizando pgAdmin

Tools -> Query Tool

Por línea de comandos

$ psql -U postgres -d datosgis ;
# CREATE EXTENSION postgis ;
# CREATE EXTENSION postgis_topology ;
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5 – Gestión de datos
5.1) Tipo de datos espaciales: almacenan formas (shapefile) como puntos, 
lineas y polígonos en columnas de geometría.

5.2) Funciones espaciales: sirven para consultar las propiedades y relaciones 
espaciales.

5.3) Índices espaciales: se utilizan para el procesamiento eficiente de las 
operaciones espaciales.

5.4) Tipos de geometrías soportadas: POINT, LINESTRING, 
GEOMETRYCOLLECTION, MULTIPOINT, MULTILENESTRING, 
MULTIPOLYGON
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5 – Gestión de datos
5.5) Tabla spatial_ref_sys: contiene la definición de los distintos Sistemas de 
Referencia existentes, ej: UTM Zona 21S Datum Sirgas 2000 (EPSG:31981)

5.6) Tabla (view) geometry_columns: almacena para cada tabla el nombre, de 
cual es su columna geométrica, las dimensiones de la misma (2D, 3D, 4D), el 
código correspondiente al Sistema de Referencia (se relaciona con la tabla 
spatial_ref_sys) y el tipo de geometría.  
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6 – Índice espaciales
6.1) Los índices espaciales son una de las funcionalidades más importantes de 
una base de datos espacial, estos consiguen que las búsquedas espaciales en un 
gran número de datos sean eficientes.
Los índices espaciales calculan y comparan básicamente el cuadro delimitador 
(bounding box) de cada elemento, este es el rectángulo de tamaño más pequeño 
capaz de contener un determinado elemento.   

Crear un índice geométrico:
    

# CREATE INDEX index_gist_my_table ON my_table USING gist (geom) ;
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7 – Análisis espacial
7.1) Importar archivo shapefile a la base de datos:

PgAdmin -> Plugins -> Postgis Shapefile Import/Export Manager 

- Presionar “Add File” y elegir archivo shapefile
- Seleccionar “Options...” para establecer opciones avanzadas
- Presionar “Import” para proceder a la importación
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7 – Análisis espacial
7.2) Importar archivos en formato shapefile a la base de datos:

Por línea de comandos:

$ shp2pgsql -s 31981 -S -W LATIN1 archivo.shp nombre_tabla > 
nombre_tabla.sql

Notas: 
-s para el Sistema de referencia
-S crea geometrías simples
-W para establecer la codificación de caracteres

$ psql -h localhost -U postgres -d datosgis -f nombre_tabla.sql
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7 – Análisis espacial
7.3) Importar archivos shapefile a la base de datos:

Ejercicios:
1 – Se cuenta con datos pertenecientes a la cartografía del departamento de 
Montevideo, se pide cargar el siguiente listado de capas en se encuentran en 
shapefile a nuestra base de datos geográfica “datosgis”.

- Límite departamental (depto_p.shp)
- Manzanas de Montevideo (v_mdg_manzanas.shp)
- Ejes de calles (v_mdg_vias.shp)
- Espacios libres de Montevideo (v_mdg_espacios_libres)
- Servicios Comerciales (serv_comerciales)

IMPORTANTE: las geometrías cargadas deberán ser del tipo “Single”, no multi 
geometry, el Sistema de Referencia de las tablas importadas deberá estar 
establecido en UTM Zona 21 Sur datum SIRGAS 2000 (EPSG:31981) y deberán 
contar con su índice de tipo gist correspondiente.
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7 – Análisis espacial
7.4) Exportar tabla desde base de datos a shapefile:

PgAdmin -> Plugins -> Postgis Shapefile Import/Export Manager 

- Seleccionar la pestaña “Export”
- Presionar sobre “Add Table” y elegir la tabla a exportar
- Seleccionar “Options...” para establecer opciones avanzadas (opcional)
- Presionar “Export” para proceder a la exportación
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7 – Análisis espacial
7.5) Exportar tabla desde base de datos a shapefile:

Por línea de comandos:

$ pgsql2shp -h localhost -u postgres -P password -f archivo.shp datosgis 
nombre_tabla

Notas: -h (indica nombre del servidor)
-u (usuario de conexión a la base de datos)
-P (password usuario de base de datos)
-f (nombre del archivo shapefile a guardar)
Datosgis (nombre base de datos)
nombre_tabla (nombre de la tabla almacenada en la base de datos)
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7 – Análisis espacial
7.6) Exportar tabla desde base de 
datos a shapefile:

Ejercicio:

- Exportar nuevamente en shapefile 
la tabla con la ubicación de los 
Servicios Comerciales de Montevideo 
cargada anteriormente.
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7 – Análisis espacial
7.7) Crear una tabla en la base de datos para agregar nuevas geometrías:

Desde PgAdmin

- Presionar sobre “Tables” , clíc con botón derecho del mouse, “New Object” 
-> “New Table”
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7 – Análisis espacial
7.7) Crear una tabla en la base de datos para agregar nuevas geometrías:

Desde PgAdmin

- Asignamos nombre y propietario de tabla

- Definimos el nombre y tipo de 
cada columna

- Presionamos “Aceptar” para terminar
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7 – Análisis espacial
7.7) Crear una tabla en la base de datos para agregar nuevas geometrías:

Desde PgAdmin

- Creamos la columna geométrica (geom) para guardar nuestros datos con 
geometrías.

- Tools -> Query Tool 

# SELECT AddGeometryColumn ('','nombre_tabla', 'geom','31981','POINT',2) ;

Notas: geom: nombre de columna geométrica
31981: código EPSG del Sistema de Referencia
POINT: tipo de geometría (POINT, LINESTRING, POLYGON....) 
2: dimensión del dato (ej: 2D, coordenadas X e Y)
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7 – Análisis espacial
7.8) Crear una tabla en la base de datos para agregar nuevas geometrías:

Utilizando línea de comandos:

# SELECT AddGeometryColumn ('','edu_escuelas', 'geom','31981','POINT',2) ;

Notas: geom: nombre de columna geométrica
31981: código EPSG del Sistema de Referencia
POINT: tipo de geometría (POINT, LINESTRING, POLYGON....) 
2: dimensión del dato (ej: 2D, coordenadas X e Y)

# CREATE TABLE edu_escuelas
(
  gid bigint NOT NULL,
  nombre character varying(50),
  numero integer,
  ubicacion character varying(120) 
);
ALTER TABLE public.edu_escuelas OWNER TO postgres;
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7 – Análisis espacial
7.9) Conexión desde un sofware SIG de escritorio.

- Ejemplo de conexión con QGIS.

Menú Capa -> Añadir capa PostGis, presionar botón “Nueva”.

Ingresar los 
datos:
- Servidor
- Puerto
- Base de datos
- Nombre de 
usuario
- Contraseña
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7 – Análisis espacial
7.9) Conexión desde un sofware SIG de escritorio.

- Ejemplo de conexión con QGIS.

- Presionar “Conectar” para establecer la conexión y seleccionar las tablas.
- Luego presionar “Añadir” para cargar la tabla seleccionada.
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7 – Análisis espacial
7.10) Insertar, actualizar o eliminar elementos.

- Ejercicios:

1 – Cargar los datos importados en la base de datos desde el cliente SIG de 
escritorio QGIS.

2 – Cargar la tabla edu_escuelas creada anteriormente.
3 – Agregar una nueva escuela en la intersección de 18 de Julio y Carlos Roxlo, 

la misma deberá contar con los siguientes datos:
Nombre = Escuela Roxlo
Número = 100
Ubicación = 18 de Julio esq. Carlos Roxlo

4 – Guardar los cambios de la capa.
5 – Agregar1 nuevo campo “tipo” de tipo texto variable, ingresar el valor 

'Escuela Pública'.
6 – Guardar los cambios y terminar la edición de la capa. 
7 – Verificar en PgAdmin la creación de este nuevo campo y que contenga el 

valor ingresado.
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7 – Análisis espacial
7.11) Geprocesos geográficos.

- Ejercicios:

8 – Establecer un área de influencia de 500 metros para la escuela creada, 
guardar el resultado en shapefile (realizar proceso desde menú Vectorial -> 
Herramientas de geoprocesos -> Buffer(s).
Ej. SQL - SELECT gid,ST_Buffer(geom,500) as geom FROM edu_escuelas ;

9 – Establecer cual es la carpeta catastral perteneciente a la ubicación de los 
distintos locales correspondientes a los Servicios Comerciales.
- Crear un nuevo shapefile con el resultado (realizar geoproceso desde menú 

 QGIS)
Ej. SQL - SELECT a.gid,a.geom,a.tipo, b.carpeta_ca FROM serv_comerciales a JOIN   

                       v_mdg_manzanas b ON ST_intersects(a.geom,b.geom) ;

10 – Agregar en tabla geométrica v_mdg_espacios_libres una columna para el 
área y otra para el perímetro, llenar las filas con los valores correspondientes 
(realizarlo desde las herramientas de QGIS).
Ej. SQL - SELECT gid,  nom_parque, ST_perimeter(geom) as perimetro  from 

v_mdg_espacios_libres ;

 Ej. SQL resultado en Km2 - 
SELECT gid,  nom_parque, (ST_perimeter(geom)*0.01) as perimetro  from v_mdg_espacios_libres ;
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8 - RASTER

- Es posible cargar y manipular datos raster, el objetivo de PostGis Raster es 
hacerlo lo más parecido posible el tipo Geometry, ofrecer un único conjunto de 
funciones que operen de manera transparente ya se trate de datos vectoriales .
- Una columna de tipo RASTER es una cobertura completa, con metadatos y 
geo referenciada.
- Permite la carga y teselado de coberturas completas, pero cada tesela por 
separado contiene sus propios metadatos y puede ser tratada como un objeto 
raster individual.

9 - TOPOLOGÍA

Proporciona métodos para 
verificar el cumplimiento de 
determinadas relaciones entre 
geometrías distintas, indican si 
cumplen o no una determinada 
relación espacial.
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10 – COPIA DE SEGURIDAD
10.1) Respaldar una tabla.

- Desde pgAdmin:
- Clíc botón derecho sobre nombre de tabla -> “Backup...”
- Elegimos nombre de archivo, encoding, rolename 

- Seleccionamos “Dump Options #2”  y 
marcamos las opciones “Use Column 
inserts” y “Use insert commands”.

- Presionar 
“Backup” para 
guardar el 
archivo de 
respaldo.
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10 – COPIA DE SEGURIDAD
10.2) Restaurar un respaldo guardao.

- Desde pgAdmin:
- Tools -> Query Tools 

- Seleccionamos File -> Open, elegimos el archivo guardado anteriormente
- Luego seleccionamos Query -> Execute...
De esta manera se restauran los datos respaldados.
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